summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriele Giorgetti <stroke@gentoo.org>2002-07-31 14:45:53 +0000
committerGabriele Giorgetti <stroke@gentoo.org>2002-07-31 14:45:53 +0000
commit83c721514d34aa584792debeebf6a499f78fe75e (patch)
treeb398c78c961f020033053d665c092e772259ffea /net-im/gnomeicu
parentSecurity fix (diff)
downloadgentoo-2-83c721514d34aa584792debeebf6a499f78fe75e.tar.gz
gentoo-2-83c721514d34aa584792debeebf6a499f78fe75e.tar.bz2
gentoo-2-83c721514d34aa584792debeebf6a499f78fe75e.zip
Version bump
Diffstat (limited to 'net-im/gnomeicu')
-rw-r--r--net-im/gnomeicu/ChangeLog6
-rw-r--r--net-im/gnomeicu/files/digest-gnomeicu-0.98.31
-rw-r--r--net-im/gnomeicu/gnomeicu-0.98.3.ebuild62
3 files changed, 68 insertions, 1 deletions
diff --git a/net-im/gnomeicu/ChangeLog b/net-im/gnomeicu/ChangeLog
index 65c000a1b704..cd02475201c7 100644
--- a/net-im/gnomeicu/ChangeLog
+++ b/net-im/gnomeicu/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-im/gnomeicu
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-im/gnomeicu/ChangeLog,v 1.7 2002/07/30 18:17:44 stroke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gnomeicu/ChangeLog,v 1.8 2002/07/31 14:45:53 stroke Exp $
+
+*gnomeicu-0.98.3 (31 Jul 2002)
+ 31 Jul 2002; Gabriele Giorgetti <stroke@gentoo.org> gnomeicu-0.98.3.ebuild :
+ New version.
*gnomeicu-0.98.2-r5 (30 Jul 2002)
30 Jul 2002; Gabriele Giorgetti <stroke@gentoo.org> gnomeicu-0.98.2-r5.ebuild :
diff --git a/net-im/gnomeicu/files/digest-gnomeicu-0.98.3 b/net-im/gnomeicu/files/digest-gnomeicu-0.98.3
new file mode 100644
index 000000000000..9b3ebf67c677
--- /dev/null
+++ b/net-im/gnomeicu/files/digest-gnomeicu-0.98.3
@@ -0,0 +1 @@
+MD5 ca0ff72cf170b4804465e10d47b0f609 gnomeicu-0.98.3.tar.gz 1457890
diff --git a/net-im/gnomeicu/gnomeicu-0.98.3.ebuild b/net-im/gnomeicu/gnomeicu-0.98.3.ebuild
new file mode 100644
index 000000000000..30761ad71a75
--- /dev/null
+++ b/net-im/gnomeicu/gnomeicu-0.98.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gnomeicu/gnomeicu-0.98.3.ebuild,v 1.1 2002/07/31 14:45:53 stroke Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Gnome ICQ Client"
+SRC_URI="mirror://sourceforge/gnomeicu/${P}.tar.gz"
+HOMEPAGE="http://gnomeicu.sourceforge.net/"
+
+DEPEND=">=gnome-base/gnome-libs-1.4.1.2-r2
+ >=sys-libs/gdbm-1.8.0
+ >=gnome-base/libglade-0.17*
+ >=media-libs/gdk-pixbuf-0.9.0
+ >=net-libs/gnet-1.1.0
+ gnome? ( =gnome-base/gnome-panel-1.4* )
+ esd? ( >=media-sound/esound-0.2.23 )"
+
+ # socks5? ( something to support socks5 in portage is needed )
+
+RDEPEND="nls? ( sys-devel/gettext )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc"
+
+src_compile() {
+ local myconf
+
+ myconf="--prefix=/usr"
+
+ use esd || myconf="${myconf} --disable-esd-test"
+
+ # Disabling socks5 support. if socks5 is present
+ # in USE, gnomeicu buid will fail. Check ChangeLog
+ # for more info about this issue. stroke@gentoo.org
+ # use socks5 && myconf="${myconf} --enable-socks5"
+
+ use nls || ( \
+ myconf="${myconf} --disable-nls"
+ mkdir ./intl
+ touch ./intl/libgettext.h
+ )
+
+ # remove the panel applet if you dont use gnome,
+ # nice hack for gnome2 compability
+
+ use gnome || myconf="${myconf} --disable-applet"
+
+ econf \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/log \
+ install || die
+
+ dodoc AUTHORS COPYING CREDITS ChangeLog NEWS README TODO ABOUT-NLS
+}