summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2004-08-23 09:07:39 +0000
committerMichael Januszewski <spock@gentoo.org>2004-08-23 09:07:39 +0000
commit9b4edbffbb355b730ff90412f8df13e2bda9dc61 (patch)
tree7243648a9b1bc82345ed2bf8add7fb81f3b083dd /net-im/gnugadu
parentAdded ~mips keyword. (Manifest recommit) (diff)
downloadgentoo-2-9b4edbffbb355b730ff90412f8df13e2bda9dc61.tar.gz
gentoo-2-9b4edbffbb355b730ff90412f8df13e2bda9dc61.tar.bz2
gentoo-2-9b4edbffbb355b730ff90412f8df13e2bda9dc61.zip
Version bump.
Diffstat (limited to 'net-im/gnugadu')
-rw-r--r--net-im/gnugadu/ChangeLog7
-rw-r--r--net-im/gnugadu/files/digest-gnugadu-2.0.51
-rw-r--r--net-im/gnugadu/gnugadu-2.0.5.ebuild63
3 files changed, 70 insertions, 1 deletions
diff --git a/net-im/gnugadu/ChangeLog b/net-im/gnugadu/ChangeLog
index b11b0cb48b7b..1a236a840515 100644
--- a/net-im/gnugadu/ChangeLog
+++ b/net-im/gnugadu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/gnugadu
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gnugadu/ChangeLog,v 1.18 2004/08/21 19:51:56 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gnugadu/ChangeLog,v 1.19 2004/08/23 09:07:39 spock Exp $
+
+*gnugadu-2.0.5 (23 Aug 2004)
+
+ 23 Aug 2004; Michal Januszewski <spock@gentoo.org> +gnugadu-2.0.5.ebuild:
+ Version bump.
21 Aug 2004; Michal Januszewski <spock@gentoo.org> gnugadu-2.0.4.ebuild:
Added support for history. Closed bug #60404.
diff --git a/net-im/gnugadu/files/digest-gnugadu-2.0.5 b/net-im/gnugadu/files/digest-gnugadu-2.0.5
new file mode 100644
index 000000000000..320aa62e4433
--- /dev/null
+++ b/net-im/gnugadu/files/digest-gnugadu-2.0.5
@@ -0,0 +1 @@
+MD5 b9538ac14b501e920134a1fe264e6099 gg2-2.0.5.tar.gz 1411805
diff --git a/net-im/gnugadu/gnugadu-2.0.5.ebuild b/net-im/gnugadu/gnugadu-2.0.5.ebuild
new file mode 100644
index 000000000000..ef539e002170
--- /dev/null
+++ b/net-im/gnugadu/gnugadu-2.0.5.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gnugadu/gnugadu-2.0.5.ebuild,v 1.1 2004/08/23 09:07:39 spock Exp $
+
+IUSE="debug tlen esd oss xosd arts jabber perl spell"
+
+inherit eutils
+
+MY_P="gg2-${PV}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="GTK-based Gadu-Gadu, Tlen and Jabber IM client"
+SRC_URI="mirror://sourceforge/ggadu/${MY_P}.tar.gz"
+HOMEPAGE="http://gadu.gnu.pl/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND=">=x11-libs/gtk+-2.2.0
+ sys-devel/gettext
+ >=sys-devel/automake-1.7
+ >=sys-devel/libtool-1.4
+ jabber? ( >=net-libs/loudmouth-0.15.1 )
+ xosd? ( x11-libs/xosd )
+ perl? ( dev-lang/perl dev-perl/XML-Parser )
+ arts? ( >=kde-base/arts-0.9.5 )
+ esd? ( media-sound/esound )
+ tlen? ( net-libs/libtlen )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -re 's#GTKSPELL_LIBS=`(.*)`#GTKSPELL_LIBS="`\1` -laspell"#g' -i configure
+}
+
+src_compile() {
+
+ myconf="--with-gui --with-gadu --with-remote --with-docklet_system_tray --with-docklet_dockapp \
+ --with-sms --with-update --with-external --with-gghist --with-history-external-viewer"
+ use spell && myconf="${myconf} --with-gtkspell"
+
+ if use arts; then
+ myconf="${myconf} --with-arts --with-arts-prefix=`artsc-config --arts-prefix`"
+ fi
+
+ econf ${myconf} \
+ `use_enable debug` \
+ `use_with oss` \
+ `use_with esd` \
+ `use_with xosd` \
+ `use_with arts` \
+ `use_with perl` \
+ `use_with tlen` \
+ `use_with jabber` || die
+ emake || die
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
+