summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-05-21 22:00:05 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-05-21 22:00:05 +0000
commit8dde507a4a4c0522fe43c2ecef63b4f67e0c925f (patch)
treedb772ec8989ca98dcf50d7139c495dd9b8844315 /net-im/gossip
parentVersion bump. (diff)
downloadgentoo-2-8dde507a4a4c0522fe43c2ecef63b4f67e0c925f.tar.gz
gentoo-2-8dde507a4a4c0522fe43c2ecef63b4f67e0c925f.tar.bz2
gentoo-2-8dde507a4a4c0522fe43c2ecef63b4f67e0c925f.zip
bump to 0.29. Bug fixes, eds integration and use of loudmouth 1.3.4.
(Portage version: 2.1.5)
Diffstat (limited to 'net-im/gossip')
-rw-r--r--net-im/gossip/ChangeLog7
-rw-r--r--net-im/gossip/gossip-0.29.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/net-im/gossip/ChangeLog b/net-im/gossip/ChangeLog
index 7376b2629a7d..0b7e4f11d9e2 100644
--- a/net-im/gossip/ChangeLog
+++ b/net-im/gossip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/gossip
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gossip/ChangeLog,v 1.74 2008/04/21 17:34:30 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gossip/ChangeLog,v 1.75 2008/05/21 22:00:05 eva Exp $
+
+*gossip-0.29 (21 May 2008)
+
+ 21 May 2008; Gilles Dartiguelongue <eva@gentoo.org> +gossip-0.29.ebuild:
+ bump to 0.29. Bug fixes, eds integration and use of loudmouth 1.3.4.
21 Apr 2008; <welp@gentoo.org> metadata.xml:
keyring to gnome-keyring in metadata.xml
diff --git a/net-im/gossip/gossip-0.29.ebuild b/net-im/gossip/gossip-0.29.ebuild
new file mode 100644
index 000000000000..82aed0ad04d2
--- /dev/null
+++ b/net-im/gossip/gossip-0.29.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gossip/gossip-0.29.ebuild,v 1.1 2008/05/21 22:00:05 eva Exp $
+
+inherit gnome2 eutils autotools
+
+DESCRIPTION="Lightweight Jabber client for GNOME"
+HOMEPAGE="http://developer.imendio.com/wiki/Gossip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="dbus eds galago gnome-keyring libnotify spell"
+
+RDEPEND="x11-libs/libXScrnSaver
+ >=dev-libs/glib-2.12.1
+ >=x11-libs/gtk+-2.10
+ >=gnome-base/libglade-2
+ >=gnome-base/gconf-1.2
+ >=dev-libs/libxml2-2.6.16
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gnome-vfs-2
+ >=net-libs/loudmouth-1.3.4
+ eds? ( >=gnome-extra/evolution-data-server-1.2 )
+ spell? ( app-text/aspell )
+ libnotify? ( >=x11-libs/libnotify-0.4.1 )
+ galago? ( dev-libs/libgalago )
+ dbus? ( >=dev-libs/dbus-glib-0.71 )
+ gnome-keyring? ( gnome-base/gnome-keyring )"
+DEPEND="${RDEPEND}
+ >=app-text/gnome-doc-utils-0.3.2
+ app-text/scrollkeeper
+ dev-util/pkgconfig
+ x11-proto/scrnsaverproto
+ >=dev-util/intltool-0.35"
+
+DOCS="AUTHORS README COPYING ChangeLog INSTALL NEWS README CONTRIBUTORS TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ ${mydebug}
+ $(use_enable dbus)
+ $(use_enable eds ebook)
+ $(use_enable galago)
+ $(use_enable gnome-keyring)
+ $(use_enable libnotify)
+ $(use_enable spell aspell)"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ ewarn "This version will drop any previously registred accounts."
+ ewarn "However it does not drop history."
+}