summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLukasz Strzygowski <lucass@gentoo.org>2004-07-11 15:47:17 +0000
committerLukasz Strzygowski <lucass@gentoo.org>2004-07-11 15:47:17 +0000
commite17d7d218f077c8e72f7d6c192c5cb9031c64b59 (patch)
treee6371e6ff973b9e96c146a0957989c22baf47dd2 /net-im/kf/kf-0.1.5.ebuild
parentprovide virtual/m3 (Manifest recommit) (diff)
downloadgentoo-2-e17d7d218f077c8e72f7d6c192c5cb9031c64b59.tar.gz
gentoo-2-e17d7d218f077c8e72f7d6c192c5cb9031c64b59.tar.bz2
gentoo-2-e17d7d218f077c8e72f7d6c192c5cb9031c64b59.zip
Version bump. Added long description to metadata.xml.
Diffstat (limited to 'net-im/kf/kf-0.1.5.ebuild')
-rw-r--r--net-im/kf/kf-0.1.5.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-im/kf/kf-0.1.5.ebuild b/net-im/kf/kf-0.1.5.ebuild
new file mode 100644
index 000000000000..0749e63bf607
--- /dev/null
+++ b/net-im/kf/kf-0.1.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/kf/kf-0.1.5.ebuild,v 1.1 2004/07/11 15:47:17 lucass Exp $
+
+inherit eutils
+
+DESCRIPTION="kf is a simple Jabber messenger."
+HOMEPAGE="http://www.habazie.rams.pl/kf/"
+SRC_URI="http://www.habazie.rams.pl/kf/files/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="spell"
+DEPEND=">=x11-libs/gtk+-2
+ >=net-libs/loudmouth-0.16
+ >=gnome-base/libglade-2
+ spell? ( >=app-text/gtkspell-2.0.4 )"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-0.1.4.1-gtkspell-2.0.4-compatibility.diff
+}
+
+src_compile() {
+ econf `use_enable spell gtkspell` || die 'econf failed'
+ emake || die 'emake failed'
+}
+
+src_install() {
+ make install DESTDIR=${D} || die 'make install failed'
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
+}