summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Pasternak <reb@gentoo.org>2006-02-08 12:57:45 +0000
committerKarol Pasternak <reb@gentoo.org>2006-02-08 12:57:45 +0000
commitd1327ad0710d69d36db5b4a7239b4be0374e36e5 (patch)
treef191458d846a4dba89d353005334437252829464 /net-im/micq/micq-0.5.1.ebuild
parentFixed bug #122101. (diff)
downloadgentoo-2-d1327ad0710d69d36db5b4a7239b4be0374e36e5.tar.gz
gentoo-2-d1327ad0710d69d36db5b4a7239b4be0374e36e5.tar.bz2
gentoo-2-d1327ad0710d69d36db5b4a7239b4be0374e36e5.zip
version bump
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'net-im/micq/micq-0.5.1.ebuild')
-rw-r--r--net-im/micq/micq-0.5.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-im/micq/micq-0.5.1.ebuild b/net-im/micq/micq-0.5.1.ebuild
new file mode 100644
index 000000000000..2f094e27eaab
--- /dev/null
+++ b/net-im/micq/micq-0.5.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/micq/micq-0.5.1.ebuild,v 1.1 2006/02/08 12:57:45 reb Exp $
+
+IUSE="tcltk ssl"
+
+SRC_URI="http://www.micq.org/source/${P}.tgz"
+DESCRIPTION="ICQ text-mode client with many features"
+HOMEPAGE="http://www.micq.org/"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+DEPEND="virtual/libc
+ ssl? ( >=net-libs/gnutls-0.8.10
+ dev-libs/openssl )
+ tcltk? ( dev-lang/tcl )"
+
+src_compile() {
+
+ econf `use_enable tcltk tcl` \
+ `use_enable ssl` \
+ || die "econf failed"
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ dodoc COPYING AUTHORS ChangeLog FAQ INSTALL NEWS README TODO
+}