summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2009-02-08 13:17:40 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2009-02-08 13:17:40 +0000
commitbaa27248c91e828dbe02bb134a0ec0582c25fa2e (patch)
treea245a93d711a055c93d225c6d0c111d5aaf8a028 /net-im/pidgin
parentFix forced as-needed by linking to libm by Kevin Pyle, bug #249359 (diff)
downloadgentoo-2-baa27248c91e828dbe02bb134a0ec0582c25fa2e.tar.gz
gentoo-2-baa27248c91e828dbe02bb134a0ec0582c25fa2e.tar.bz2
gentoo-2-baa27248c91e828dbe02bb134a0ec0582c25fa2e.zip
Fix ICQ (for protocol changes)
Thanks to MaratIK for reporting wrt bug #257570 (Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'net-im/pidgin')
-rw-r--r--net-im/pidgin/ChangeLog9
-rw-r--r--net-im/pidgin/files/pidgin-2.5.4-icq.patch19
-rw-r--r--net-im/pidgin/pidgin-2.5.4-r1.ebuild177
3 files changed, 204 insertions, 1 deletions
diff --git a/net-im/pidgin/ChangeLog b/net-im/pidgin/ChangeLog
index 7129aaf34149..ac44fe6265c7 100644
--- a/net-im/pidgin/ChangeLog
+++ b/net-im/pidgin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/pidgin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/ChangeLog,v 1.83 2009/01/21 01:12:51 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/ChangeLog,v 1.84 2009/02/08 13:17:40 drizzt Exp $
+
+*pidgin-2.5.4-r1 (08 Feb 2009)
+
+ 08 Feb 2009; Timothy Redaelli <drizzt@gentoo.org>
+ +files/pidgin-2.5.4-icq.patch, +pidgin-2.5.4-r1.ebuild:
+ Fix ICQ (for protocol changes) Thanks to MaratIK for reporting wrt bug
+ #257570
21 Jan 2009; Olivier Crête <tester@gentoo.org> pidgin-2.5.4.ebuild:
Remove autotools dep
diff --git a/net-im/pidgin/files/pidgin-2.5.4-icq.patch b/net-im/pidgin/files/pidgin-2.5.4-icq.patch
new file mode 100644
index 000000000000..3af838499c79
--- /dev/null
+++ b/net-im/pidgin/files/pidgin-2.5.4-icq.patch
@@ -0,0 +1,19 @@
+diff -urN pidgin-2.5.4.orig/libpurple/protocols/oscar/flap_connection.c pidgin-2.5.4/libpurple/protocols/oscar/flap_connection.c
+--- pidgin-2.5.4.orig/libpurple/protocols/oscar/flap_connection.c 2009-02-04 10:58:55.000000000 +0300
++++ pidgin-2.5.4/libpurple/protocols/oscar/flap_connection.c 2009-02-04 11:13:55.000000000 +0300
+@@ -317,12 +317,15 @@
+ {
+ FlapConnection *conn;
+
++ static const guint FlapLoginSeqs[] = { 5695, 23595, 23620, 23049, 0x2886, 0x2493, 23620, 23049, 2853, 17372, 1255, 1796, 1657, 13606, 1930, 23918, 31234, 30120, 0x1BEA, 0x5342, 0x30CC, 0x2294, 0x5697,0x25FA, 0x3303, 0x078A, 0x0FC5, 0x25D6, 0x26EE,0x7570, 0x7F33, 0x4E94, 0x07C9, 0x7339, 0x42A8 };
++
+ conn = g_new0(FlapConnection, 1);
+ conn->od = od;
+ conn->buffer_outgoing = purple_circ_buffer_new(0);
+ conn->fd = -1;
+ conn->subtype = -1;
+ conn->type = type;
++ conn->seqnum_out = FlapLoginSeqs[g_random_int_range(0, (sizeof FlapLoginSeqs) / (sizeof FlapLoginSeqs[0]))] - 1;
+
+ od->oscar_connections = g_slist_prepend(od->oscar_connections, conn);
+
diff --git a/net-im/pidgin/pidgin-2.5.4-r1.ebuild b/net-im/pidgin/pidgin-2.5.4-r1.ebuild
new file mode 100644
index 000000000000..9bb4fca3e871
--- /dev/null
+++ b/net-im/pidgin/pidgin-2.5.4-r1.ebuild
@@ -0,0 +1,177 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/pidgin-2.5.4-r1.ebuild,v 1.1 2009/02/08 13:17:40 drizzt Exp $
+
+EAPI=2
+
+inherit flag-o-matic eutils toolchain-funcs multilib perl-app gnome2
+
+DESCRIPTION="GTK Instant Messenger client"
+HOMEPAGE="http://pidgin.im/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="bonjour dbus debug doc eds gadu gnutls +gstreamer meanwhile"
+IUSE="${IUSE} networkmanager nls perl silc tcl tk spell qq gadu"
+IUSE="${IUSE} +gtk sasl ncurses groupwise prediction zephyr" # mono"
+
+RDEPEND="
+ bonjour? ( net-dns/avahi )
+ dbus? ( >=dev-libs/dbus-glib-0.71
+ >=dev-python/dbus-python-0.71
+ >=sys-apps/dbus-0.90
+ >=dev-lang/python-2.4 )
+ gtk? (
+ spell? ( >=app-text/gtkspell-2.0.2 )
+ >=x11-libs/gtk+-2.0
+ >=x11-libs/startup-notification-0.5
+ x11-libs/libXScrnSaver
+ eds? ( gnome-extra/evolution-data-server ) )
+ >=dev-libs/glib-2.0
+ gstreamer? ( =media-libs/gstreamer-0.10*
+ =media-libs/gst-plugins-good-0.10* )
+ perl? ( >=dev-lang/perl-5.8.2-r1 )
+ gadu? ( net-libs/libgadu[ssl] )
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( >=dev-libs/nss-3.11 )
+ meanwhile? ( net-libs/meanwhile )
+ silc? ( >=net-im/silc-toolkit-0.9.12-r3 )
+ zephyr? ( >=app-crypt/mit-krb5-1.3.6-r1[krb4] )
+ tcl? ( dev-lang/tcl )
+ tk? ( dev-lang/tk )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ dev-libs/libxml2
+ networkmanager? ( net-misc/networkmanager )
+ prediction? ( =dev-db/sqlite-3* )
+ ncurses? ( sys-libs/ncurses[unicode] )"
+ # Mono support crashes pidgin
+ #mono? ( dev-lang/mono )"
+
+DEPEND="$RDEPEND
+ dev-lang/perl
+ dev-perl/XML-Parser
+ dev-util/pkgconfig
+ gtk? ( x11-proto/scrnsaverproto )
+ doc? ( app-doc/doxygen )
+ nls? ( sys-devel/gettext )"
+
+# Enable Default protocols
+DYNAMIC_PRPLS="irc,jabber,oscar,yahoo,simple,msn,myspace"
+
+# List of plugins
+# app-accessibility/pidgin-festival
+# net-im/librvp
+# x11-plugins/guifications
+# x11-plugins/pidgin-encryption
+# x11-plugins/pidgin-extprefs
+# x11-plugins/pidgin-hotkeys
+# x11-plugins/pidgin-latex
+# x11-plugins/pidgin-libnotify
+# x11-plugins/pidgin-otr
+# x11-plugins/pidgin-rhythmbox
+# x11-plugins/purple-plugin_pack
+# x11-themes/pidgin-smileys
+
+pkg_setup() {
+ if ! use gtk && ! use ncurses ; then
+ einfo
+ elog "You did not pick the ncurses or gtk use flags, only libpurple"
+ elog "will be built."
+ einfo
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-icq.patch
+}
+
+src_configure() {
+ # Stabilize things, for your own good
+ strip-flags
+ replace-flags -O? -O2
+
+ # -msse2 doesn't play nice on gcc 3.2
+ [[ "`gcc-version`" == "3.2" ]] && filter-flags -msse2
+
+ local myconf
+
+ if use gadu; then
+ DYNAMIC_PRPLS="${DYNAMIC_PRPLS},gg"
+ myconf="${myconf} --with-gadu-includes=."
+ myconf="${myconf} --with-gadu-libs=."
+ fi
+
+ if use silc; then
+ DYNAMIC_PRPLS="${DYNAMIC_PRPLS},silc"
+ fi
+
+ if use qq; then
+ DYNAMIC_PRPLS="${DYNAMIC_PRPLS},qq"
+ fi
+
+ if use meanwhile; then
+ DYNAMIC_PRPLS="${DYNAMIC_PRPLS},sametime"
+ fi
+
+ if use bonjour; then
+ DYNAMIC_PRPLS="${DYNAMIC_PRPLS},bonjour"
+ fi
+
+ if use groupwise; then
+ DYNAMIC_PRPLS="${DYNAMIC_PRPLS},novell"
+ fi
+
+ if use zephyr; then
+ DYNAMIC_PRPLS="${DYNAMIC_PRPLS},zephyr"
+ fi
+
+ if use gnutls ; then
+ einfo "Disabling NSS, using GnuTLS"
+ myconf="${myconf} --enable-nss=no --enable-gnutls=yes"
+ myconf="${myconf} --with-gnutls-includes=/usr/include/gnutls"
+ myconf="${myconf} --with-gnutls-libs=/usr/$(get_libdir)"
+ else
+ einfo "Disabling GnuTLS, using NSS"
+ myconf="${myconf} --enable-gnutls=no --enable-nss=yes"
+ fi
+
+ econf \
+ $(use_enable ncurses consoleui) \
+ $(use_enable nls) \
+ $(use_enable perl) \
+ $(use_enable gtk gtkui) \
+ $(use_enable gtk startup-notification) \
+ $(use_enable gtk screensaver) \
+ $(use_enable gtk sm) \
+ $(use_enable tcl) \
+ $(use_enable spell gtkspell) \
+ $(use_enable tk) \
+ $(use_enable debug) \
+ $(use_enable dbus) \
+ $(use_enable meanwhile) \
+ $(use_enable eds gevolution) \
+ $(use_enable gstreamer) \
+ $(use_enable sasl cyrus-sasl ) \
+ $(use_enable doc doxygen) \
+ $(use_enable prediction cap) \
+ $(use_enable networkmanager nm) \
+ $(use_with zephyr krb4) \
+ $(use_enable bonjour avahi) \
+ "--with-dynamic-prpls=${DYNAMIC_PRPLS}" \
+ --disable-mono \
+ --x-includes=/usr/include/X11 \
+ ${myconf} || die "Configuration failed"
+ #$(use_enable mono) \
+}
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ gnome2_src_install
+ use perl && fixlocalpod
+ dodoc AUTHORS HACKING INSTALL NEWS README ChangeLog
+}