summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-04-24 22:31:26 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-04-24 22:31:26 +0000
commit4dea10196f3bdfeadd1a0b41f07bc3675c841909 (patch)
tree5a6eda0c61d45621ef7312fce70a517293710f7a /net-im/silc-client
parentnew version (diff)
downloadgentoo-2-4dea10196f3bdfeadd1a0b41f07bc3675c841909.tar.gz
gentoo-2-4dea10196f3bdfeadd1a0b41f07bc3675c841909.tar.bz2
gentoo-2-4dea10196f3bdfeadd1a0b41f07bc3675c841909.zip
fix stray man dir
Diffstat (limited to 'net-im/silc-client')
-rw-r--r--net-im/silc-client/ChangeLog6
-rw-r--r--net-im/silc-client/Manifest6
-rw-r--r--net-im/silc-client/silc-client-0.9.11.ebuild26
-rw-r--r--net-im/silc-client/silc-client-0.9.12.1.ebuild6
4 files changed, 33 insertions, 11 deletions
diff --git a/net-im/silc-client/ChangeLog b/net-im/silc-client/ChangeLog
index 7c6e077a26f1..e409bd6db746 100644
--- a/net-im/silc-client/ChangeLog
+++ b/net-im/silc-client/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for net-im/silc-client
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/silc-client/ChangeLog,v 1.11 2003/04/22 18:41:38 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/silc-client/ChangeLog,v 1.12 2003/04/24 22:31:18 liquidx Exp $
*silc-client-0.9.12.1 (22 Apr 2003)
+ 24 Apr 2003; Alastair Tse <liquidx@gentoo.org> silc-client-0.9.11.ebuild,
+ silc-client-0.9.12.1.ebuild:
+ fix stray man dir
+
22 Apr 2003; Martin Holzer <mholzer@gentoo.org> silc-client-0.9.12.1.ebuild:
Fixing echonfig is broken by a typo. Closes #19791
diff --git a/net-im/silc-client/Manifest b/net-im/silc-client/Manifest
index b0b1f741fb7c..0a40622d6661 100644
--- a/net-im/silc-client/Manifest
+++ b/net-im/silc-client/Manifest
@@ -1,5 +1,5 @@
-MD5 9c068f9711e17213e29a0bf0e9001b0a ChangeLog 1789
-MD5 bccd496b5f226b555131ff60de1fdc21 silc-client-0.9.11.ebuild 1350
-MD5 86c06910f2e55f72c3a079f07ab6641e silc-client-0.9.12.1.ebuild 1754
+MD5 c259b5f4e6699ee586918456564676b8 ChangeLog 1917
+MD5 3667e0bb6580d3472fbbd7bca5e47382 silc-client-0.9.11.ebuild 1631
+MD5 ffd815344055683d7f615d181b0201a7 silc-client-0.9.12.1.ebuild 1844
MD5 fb190d39f5c608735fb3650027e4499f files/digest-silc-client-0.9.11 72
MD5 c0de3b6dda921ad76210c11a653f40ee files/digest-silc-client-0.9.12.1 74
diff --git a/net-im/silc-client/silc-client-0.9.11.ebuild b/net-im/silc-client/silc-client-0.9.11.ebuild
index 1988cb679aef..0fe94d12e0d4 100644
--- a/net-im/silc-client/silc-client-0.9.11.ebuild
+++ b/net-im/silc-client/silc-client-0.9.11.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/silc-client/silc-client-0.9.11.ebuild,v 1.5 2003/03/11 21:11:46 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/silc-client/silc-client-0.9.11.ebuild,v 1.6 2003/04/24 22:31:18 liquidx Exp $
+
+inherit libtool
DESCRIPTION="IRSSI-based text client for Secure Internet Live Conferencing"
SRC_URI="http://www.silcnet.org/download/client/sources/${P}.tar.bz2"
@@ -9,20 +11,25 @@ HOMEPAGE="http://silcnet.org/"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ppc"
-IUSE="ipv6 perl"
+IUSE="ipv6 perl ncurses"
DEPEND="=dev-libs/glib-1.2*
perl? ( dev-lang/perl )
- sys-libs/ncurses"
+ ncurses? ( sys-libs/ncurses )"
src_compile() {
+ elibtoolize
+
econf \
- --mandir=${D}/usr/share/man \
+ --mandir=/usr/share/man \
--with-helpdir=/usr/share/silc/help \
--with-docdir=/usr/share/doc/${P} \
--with-simdir=/usr/lib/silc/modules \
--with-logsdir=/var/log/silc \
- --with-ncurses \
+ --with-etcdir=/etc/silv \
+ --with-libdir=/usr/lib \
+ --without-libtoolfix \
+ `use_with ncurses` \
`use_with ipv6` \
|| die "./configure failed"
@@ -30,7 +37,8 @@ src_compile() {
}
src_install() {
- myflags=""
+ local myflags
+
if [ "`use perl`" ]
then
R1="s/installsitearch='//"
@@ -41,7 +49,13 @@ src_install() {
myflags="${myflags} INSTALLSITELIB=${D}/${perl_sitearch}"
myflags="${myflags} INSTALLSITEARCH=${D}/${perl_sitearch}"
fi
+
+ myflags="${myflags} mandir=${D}/usr/share/man"
make DESTDIR=${D} ${myflags} install || die "make install failed"
+
+ # screwed up libtool installs things in the wrong place
+ mv ${D}/usr/libsilc* ${D}/usr/lib
+
rmdir ${D}/usr/include
}
diff --git a/net-im/silc-client/silc-client-0.9.12.1.ebuild b/net-im/silc-client/silc-client-0.9.12.1.ebuild
index 78395598b401..89805419dd6f 100644
--- a/net-im/silc-client/silc-client-0.9.12.1.ebuild
+++ b/net-im/silc-client/silc-client-0.9.12.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/silc-client/silc-client-0.9.12.1.ebuild,v 1.2 2003/04/22 18:41:38 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/silc-client/silc-client-0.9.12.1.ebuild,v 1.3 2003/04/24 22:31:18 liquidx Exp $
DESCRIPTION="IRSSI-based text client for Secure Internet Live Conferencing"
SRC_URI="http://www.silcnet.org/download/client/sources/${P}.tar.bz2"
@@ -29,6 +29,7 @@ src_compile() {
--with-helpdir=/usr/share/${PN}/help \
--with-logsdir=/var/log/${PN} \
--with-simdir=/usr/lib/${PN} \
+ --with-mandir=/usr/share/man \
--with-ncurses \
--without-silcd \
${myconf} \
@@ -57,4 +58,7 @@ src_install() {
mv ${D}/usr/libsilc.la ${D}/usr/lib/
rmdir ${D}/usr/share/silc/
rmdir ${D}/usr/include
+
+ dodir /usr/share/man
+ mv ${D}/man1 ${D}/usr/share/man
}