summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-07-24 08:18:57 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-07-24 08:18:57 +0000
commit29e4d18d8827a14a042176ef43eca380980b4e97 (patch)
tree73cc9a135fdd9bd33109ccac9d72a6584b5bbd70 /net-im
parentmarked x86 per bug 426760 (diff)
downloadgentoo-2-29e4d18d8827a14a042176ef43eca380980b4e97.tar.gz
gentoo-2-29e4d18d8827a14a042176ef43eca380980b4e97.tar.bz2
gentoo-2-29e4d18d8827a14a042176ef43eca380980b4e97.zip
Picked upstream patch to disable multiwindow mode. Thanks to Ulya Fokanova who noticed the problem.
(Portage version: 2.2.0_alpha116_p10/cvs/Linux x86_64)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/skypetab-ng/ChangeLog11
-rw-r--r--net-im/skypetab-ng/files/skypetab-ng-0.5.0-fix-multiwindows.patch23
-rw-r--r--net-im/skypetab-ng/skypetab-ng-0.5.0-r1.ebuild (renamed from net-im/skypetab-ng/skypetab-ng-0.4.11.ebuild)10
3 files changed, 39 insertions, 5 deletions
diff --git a/net-im/skypetab-ng/ChangeLog b/net-im/skypetab-ng/ChangeLog
index aea954a0ff4b..62d472c7c9bf 100644
--- a/net-im/skypetab-ng/ChangeLog
+++ b/net-im/skypetab-ng/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-im/skypetab-ng
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/skypetab-ng/ChangeLog,v 1.6 2012/06/26 20:03:54 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/skypetab-ng/ChangeLog,v 1.7 2012/07/24 08:18:57 slyfox Exp $
+
+*skypetab-ng-0.5.0-r1 (24 Jul 2012)
+
+ 24 Jul 2012; Sergei Trofimovich <slyfox@gentoo.org>
+ +files/skypetab-ng-0.5.0-fix-multiwindows.patch, +skypetab-ng-0.5.0-r1.ebuild,
+ -skypetab-ng-0.4.11.ebuild:
+ Picked upstream patch to disable multiwindow mode. Thanks to Ulya Fokanova who
+ noticed the problem.
*skypetab-ng-0.5.0 (26 Jun 2012)
@@ -41,4 +49,3 @@
+skypetab-ng-0.4.9_pre20111124.ebuild, +skypetab-ng-9999.ebuild:
Initial version. An LD_PRELOAD library to make your skype single-windowed
application. Handly for tiled WM users.
-
diff --git a/net-im/skypetab-ng/files/skypetab-ng-0.5.0-fix-multiwindows.patch b/net-im/skypetab-ng/files/skypetab-ng-0.5.0-fix-multiwindows.patch
new file mode 100644
index 000000000000..7edf056ccbe8
--- /dev/null
+++ b/net-im/skypetab-ng/files/skypetab-ng-0.5.0-fix-multiwindows.patch
@@ -0,0 +1,23 @@
+From ea02a30f76d771a70e5efc9dcb251c93f869784e Mon Sep 17 00:00:00 2001
+From: Nikita Tsukanov <keks9n@gmail.com>
+Date: Fri, 15 Jun 2012 16:38:27 +0400
+Subject: [PATCH] Fix 1 > 0
+
+---
+ skypetab-ng | 2 +-
+# skypetab-ng.src.rpm | Bin 28866 -> 28851 bytes
+ 2 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/skypetab-ng b/skypetab-ng
+index 1cc6d6b..c53dbf8 100755
+--- a/skypetab-ng
++++ b/skypetab-ng
+@@ -5,7 +5,7 @@ then
+ find|grep config.xml|while read line;
+ do
+ sed -i "s/.UseUniqueConversationsWindow.*//" $line
+- sed -i "s/<UI>/<UI>\n <UseUniqueConversationsWindow>1<\/UseUniqueConversationsWindow>/" $line
++ sed -i "s/<UI>/<UI>\n <UseUniqueConversationsWindow>0<\/UseUniqueConversationsWindow>/" $line
+ cat $line
+ done
+ fi
diff --git a/net-im/skypetab-ng/skypetab-ng-0.4.11.ebuild b/net-im/skypetab-ng/skypetab-ng-0.5.0-r1.ebuild
index 84231a937fe8..fb71489cbbe2 100644
--- a/net-im/skypetab-ng/skypetab-ng-0.4.11.ebuild
+++ b/net-im/skypetab-ng/skypetab-ng-0.5.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/skypetab-ng/skypetab-ng-0.4.11.ebuild,v 1.1 2012/06/09 14:28:03 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/skypetab-ng/skypetab-ng-0.5.0-r1.ebuild,v 1.1 2012/07/24 08:18:57 slyfox Exp $
EAPI=4
@@ -12,11 +12,11 @@ else
UNPACKER_ECLASS="vcs-snapshot"
fi
-inherit qt4-r2 multilib ${UNPACKER_ECLASS}
+inherit eutils qt4-r2 multilib ${UNPACKER_ECLASS}
if [[ -z ${LIVE_EBUILD} ]]; then
KEYWORDS="-* ~x86 ~amd64"
- SRC_URI="http://github.com/kekekeks/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+ SRC_URI="http://github.com/kekekeks/${PN}/tarball/v${PV}-fixed -> ${P}.tar.gz"
fi
DESCRIPTION="An LD_PRELOAD wrapper that adds tabs to Skype for Linux"
@@ -33,6 +33,10 @@ RDEPEND="${DEPEND}
net-im/skype[-qt-static]
"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fix-multiwindows.patch
+}
+
pkg_setup() {
use amd64 && multilib_toolchain_setup x86
}