summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-05-06 19:53:42 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-05-06 19:53:42 +0000
commit36fb24d053c4e3a923dfa0a2a7d301c29767c518 (patch)
tree579b47479e0a2dcd359eee630b07033b7eee25d6 /net-im
parentVersion bump. (diff)
downloadgentoo-2-36fb24d053c4e3a923dfa0a2a7d301c29767c518.tar.gz
gentoo-2-36fb24d053c4e3a923dfa0a2a7d301c29767c518.tar.bz2
gentoo-2-36fb24d053c4e3a923dfa0a2a7d301c29767c518.zip
Add jingle useflag, many thanks go to Erdroh Moshan <ErDroh@gmx.de> for bug 132423 and testing it with me
(Portage version: 2.1_pre10-r3)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/kopete/ChangeLog9
-rw-r--r--net-im/kopete/files/digest-kopete-0.12_beta2-r13
-rw-r--r--net-im/kopete/kopete-0.12_beta2-r1.ebuild77
3 files changed, 88 insertions, 1 deletions
diff --git a/net-im/kopete/ChangeLog b/net-im/kopete/ChangeLog
index 5b51f2e099aa..21f393649ef5 100644
--- a/net-im/kopete/ChangeLog
+++ b/net-im/kopete/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/kopete
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/kopete/ChangeLog,v 1.55 2006/03/21 11:59:59 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/kopete/ChangeLog,v 1.56 2006/05/06 19:53:42 genstef Exp $
+
+*kopete-0.12_beta2-r1 (06 May 2006)
+
+ 06 May 2006; Stefan Schweizer <genstef@gentoo.org>
+ -kopete-0.12_beta2.ebuild, +kopete-0.12_beta2-r1.ebuild:
+ Add jingle useflag, many thanks go to Erdroh Moshan <ErDroh@gmx.de> for bug
+ 132423 and testing it with me
*kopete-0.12_beta2 (21 Mar 2006)
diff --git a/net-im/kopete/files/digest-kopete-0.12_beta2-r1 b/net-im/kopete/files/digest-kopete-0.12_beta2-r1
new file mode 100644
index 000000000000..6fb33b150288
--- /dev/null
+++ b/net-im/kopete/files/digest-kopete-0.12_beta2-r1
@@ -0,0 +1,3 @@
+MD5 142cd8ddc4dbd5f493e03b80f36ad7ca kopete-0.12-beta2.tar.bz2 5643221
+RMD160 78fc5231b58557b671449f0ac43fa96766120bad kopete-0.12-beta2.tar.bz2 5643221
+SHA256 99445769fd1fdcb12990353e7259150f444aee52e4595895a56f2df9a9fb3632 kopete-0.12-beta2.tar.bz2 5643221
diff --git a/net-im/kopete/kopete-0.12_beta2-r1.ebuild b/net-im/kopete/kopete-0.12_beta2-r1.ebuild
new file mode 100644
index 000000000000..85b0791444fe
--- /dev/null
+++ b/net-im/kopete/kopete-0.12_beta2-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/kopete/kopete-0.12_beta2-r1.ebuild,v 1.1 2006/05/06 19:53:42 genstef Exp $
+
+inherit kde eutils
+
+MY_P="${P/_/-}"
+
+DESCRIPTION="KDE multi-protocol IM client"
+HOMEPAGE="http://kopete.kde.org/"
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="jingle sametime ssl xmms xscreensaver"
+
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+S="${WORKDIR}/${MY_P}"
+
+# The kernel_linux? ( ) conditional dependencies are for webcams, not supported
+# on other kernels AFAIK
+BOTH_DEPEND="dev-libs/libxslt
+ dev-libs/libxml2
+ net-dns/libidn
+ >=dev-libs/glib-2
+ app-crypt/qca
+ slp? ( net-libs/openslp )
+ jingle? (
+ >=media-libs/speex-1.1.6
+ dev-libs/expat
+ ~net-libs/ortp-0.7.1 )
+ sametime? ( =net-libs/meanwhile-0.4* )
+ xmms? ( media-sound/xmms )
+ || ( (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ xscreensaver? ( x11-libs/libXScrnSaver )
+ ) virtual/x11 )
+ kernel_linux? ( virtual/opengl )"
+
+RDEPEND="${BOTH_DEPEND}
+ ssl? ( app-crypt/qca-tls )
+ !kde-base/kopete"
+
+DEPEND="${BOTH_DEPEND}
+ kernel_linux? ( virtual/os-headers )
+ || ( (
+ x11-proto/videoproto
+ x11-proto/xextproto
+ x11-proto/xproto
+ kernel_linux? ( x11-libs/libXv )
+ xscreensaver? ( x11-proto/scrnsaverproto )
+ ) virtual/x11 )"
+
+need-kde 3.4
+
+#dev-libs/ilbc-rfc3951: could not see any benifit in it
+#sed -i 's:ilbc_found="no":ilbc_found="yes":' ${S}/kopete/protocols/jabber/jingle/configure.in.in
+
+src_unpack() {
+ kde_src_unpack
+ epatch "${FILESDIR}/${PN}-0.12_alpha1-xscreensaver.patch"
+ rm -f ${S}/configure
+}
+
+src_compile() {
+ # External libgadu support - doesn't work, kopete requires a specific development snapshot of libgadu.
+ # Maybe we can enable it in the future.
+ # The nowlistening plugin has xmms support.
+ local myconf="$(use_enable jingle)
+ $(use_enable sametime sametime-plugin)
+ $(use_with xmms) --without-external-libgadu
+ $(use_with xscreensaver)"
+
+ kde_src_compile
+}