summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-06-08 05:57:46 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-06-08 05:57:46 +0000
commit5019506f6f3e50ea3bbe0078058d9869696a5218 (patch)
tree8aa2ec5dc7cace15a25b8daa0b00ed43709ae194 /net-im
parentcleanup (diff)
downloadgentoo-2-5019506f6f3e50ea3bbe0078058d9869696a5218.tar.gz
gentoo-2-5019506f6f3e50ea3bbe0078058d9869696a5218.tar.bz2
gentoo-2-5019506f6f3e50ea3bbe0078058d9869696a5218.zip
New version, and gcc-3.1 fixes, masked for testing and maintainer approval
Diffstat (limited to 'net-im')
-rw-r--r--net-im/centericq/centericq-4.7.2.ebuild37
-rw-r--r--net-im/centericq/files/centericq-4.7.2-gentoo.patch446
-rw-r--r--net-im/centericq/files/digest-centericq-4.7.21
3 files changed, 484 insertions, 0 deletions
diff --git a/net-im/centericq/centericq-4.7.2.ebuild b/net-im/centericq/centericq-4.7.2.ebuild
new file mode 100644
index 000000000000..a205bf191fa2
--- /dev/null
+++ b/net-im/centericq/centericq-4.7.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-im/centericq/centericq-4.7.2.ebuild,v 1.1 2002/06/08 05:57:39 lostlogic Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A ncurses ICQ/Yahoo!/MSN Client"
+SRC_URI="http://konst.org.ua/download/${P}.tar.gz"
+HOMEPAGE="http://konst.org.ua/eng/software/centericq/info.html"
+SLOT="0"
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ >=dev-libs/libsigc++-1.0.4"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+
+ unpack ${P}.tar.gz
+ cd ${S}
+ echo "CFLAGS += ${CFLAGS}" >> Makefile.rules
+ patch -p1 < ${FILESDIR}/${P}-gentoo.patch || die "Failed to patch sources"
+
+}
+
+src_compile() {
+
+ ./configure --prefix=/usr --host=${CHOST} || die
+ emake || die
+
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+
+}
+
+
diff --git a/net-im/centericq/files/centericq-4.7.2-gentoo.patch b/net-im/centericq/files/centericq-4.7.2-gentoo.patch
new file mode 100644
index 000000000000..8a31478bae00
--- /dev/null
+++ b/net-im/centericq/files/centericq-4.7.2-gentoo.patch
@@ -0,0 +1,446 @@
+diff -Nru centericq-4.7.2-bad/kkconsui-0.1/src/cmenus.cc centericq-4.7.2/kkconsui-0.1/src/cmenus.cc
+--- centericq-4.7.2-bad/kkconsui-0.1/src/cmenus.cc Sat Mar 30 15:58:21 2002
++++ centericq-4.7.2/kkconsui-0.1/src/cmenus.cc Sat Jun 8 00:16:54 2002
+@@ -30,7 +30,7 @@
+ setcoords(px1, py1, px2, py2);
+ }
+
+-verticalmenu::verticalmenu(int pncolor = 0, int pscolor = 0) {
++verticalmenu::verticalmenu(int pncolor, int pscolor) {
+ initmembers();
+ setcolor(pncolor, pscolor);
+ }
+@@ -100,7 +100,7 @@
+ addline(ncolor, 0);
+ }
+
+-void verticalmenu::addline(int color, const char *fmt = 0, ...) {
++void verticalmenu::addline(int color, const char *fmt, ...) {
+ verticalmenuitem i;
+ char buf[10240];
+ va_list ap;
+@@ -377,7 +377,7 @@
+ first = firstdisp;
+ }
+
+-void verticalmenu::setpos(int cur, int first = -1) {
++void verticalmenu::setpos(int cur, int first) {
+ curelem = cur;
+ if(first != -1) firstdisp = first;
+ }
+diff -Nru centericq-4.7.2-bad/kkconsui-0.1/src/conscommon.cc centericq-4.7.2/kkconsui-0.1/src/conscommon.cc
+--- centericq-4.7.2-bad/kkconsui-0.1/src/conscommon.cc Thu Mar 28 13:27:44 2002
++++ centericq-4.7.2/kkconsui-0.1/src/conscommon.cc Sat Jun 8 00:17:43 2002
+@@ -288,7 +288,7 @@
+
+ #else
+
+-string makebidi(const string &buf, int lpad = 0) {
++string makebidi(const string &buf, int lpad) {
+ return buf;
+ }
+
+diff -Nru centericq-4.7.2-bad/kkconsui-0.1/src/dialogbox.cc centericq-4.7.2/kkconsui-0.1/src/dialogbox.cc
+--- centericq-4.7.2-bad/kkconsui-0.1/src/dialogbox.cc Sat Mar 30 15:58:21 2002
++++ centericq-4.7.2/kkconsui-0.1/src/dialogbox.cc Sat Jun 8 00:16:15 2002
+@@ -39,12 +39,12 @@
+ if(browser && freebrowser) delete browser;
+ }
+
+-void dialogbox::setwindow(textwindow *neww, bool fw = true) {
++void dialogbox::setwindow(textwindow *neww, bool fw) {
+ window = neww;
+ freewindow = fw;
+ }
+
+-void dialogbox::setbar(horizontalbar *newb, bool fb = true) {
++void dialogbox::setbar(horizontalbar *newb, bool fb) {
+ bar = newb;
+ freebar = fb;
+
+@@ -55,7 +55,7 @@
+ }
+ }
+
+-void dialogbox::setmenu(verticalmenu *newm, bool fm = true) {
++void dialogbox::setmenu(verticalmenu *newm, bool fm) {
+ menu = newm;
+ freemenu = fm;
+
+@@ -66,7 +66,7 @@
+ }
+ }
+
+-void dialogbox::settree(treeview *newt, bool ft = true) {
++void dialogbox::settree(treeview *newt, bool ft) {
+ tree = newt;
+ freetree = ft;
+
+@@ -77,7 +77,7 @@
+ }
+ }
+
+-void dialogbox::setbrowser(textbrowser *newbr, bool fbr = true) {
++void dialogbox::setbrowser(textbrowser *newbr, bool fbr) {
+ browser = newbr;
+ freebrowser = fbr;
+
+@@ -108,7 +108,7 @@
+ return browser;
+ }
+
+-bool dialogbox::open(int &menuitem, int &baritem, void **ref = 0) {
++bool dialogbox::open(int &menuitem, int &baritem, void **ref) {
+ bool ret = false;
+ list<keybarassociation>::iterator i;
+
+diff -Nru centericq-4.7.2-bad/kkconsui-0.1/src/textbrowser.cc centericq-4.7.2/kkconsui-0.1/src/textbrowser.cc
+--- centericq-4.7.2-bad/kkconsui-0.1/src/textbrowser.cc Sat Mar 30 15:58:22 2002
++++ centericq-4.7.2/kkconsui-0.1/src/textbrowser.cc Sat Jun 8 00:14:06 2002
+@@ -31,7 +31,7 @@
+ otherkeys = 0;
+ }
+
+-textbrowser::textbrowser(int clr = 0) {
++textbrowser::textbrowser(int clr) {
+ setcolor(clr);
+ idle = 0;
+ otherkeys = 0;
+diff -Nru centericq-4.7.2-bad/kkconsui-0.1/src/texteditor.cc centericq-4.7.2/kkconsui-0.1/src/texteditor.cc
+--- centericq-4.7.2-bad/kkconsui-0.1/src/texteditor.cc Mon Mar 4 13:25:49 2002
++++ centericq-4.7.2/kkconsui-0.1/src/texteditor.cc Sat Jun 8 00:12:56 2002
+@@ -260,7 +260,7 @@
+ }
+
+ void texteditor::modification(tundoaction action, const string &data,
+-bool connected = false, int curx = -1, int cury = -1) {
++bool connected, int curx, int cury) {
+ if(undolog && !data.empty()) {
+ undorecord *ur = new undorecord;
+ ur->x = curx < 0 ? CURCOL : curx;
+@@ -778,7 +778,7 @@
+ return k;
+ }
+
+-void texteditor::showline(int ln, int startx, int distance, int extrax = 0) {
++void texteditor::showline(int ln, int startx, int distance, int extrax) {
+ if(!show) return;
+
+ int i, n, inscount, bcolor, sxinscount, printed, j, lastoccur, q, eolstart, npos, offs;
+@@ -1043,7 +1043,7 @@
+ return osx != curfile->sx;
+ }
+
+-void texteditor::eddel(bool usetabs = true) {
++void texteditor::eddel(bool usetabs) {
+ char *p = CURSTRING;
+ int nextlen, todelete = 1, rm;
+ string deltext;
+@@ -1193,7 +1193,7 @@
+ updatecursor();
+ }
+
+-void texteditor::edenter(bool countspaces = true) {
++void texteditor::edenter(bool countspaces) {
+ char *p = CURSTRING, *r;
+ string spaceins;
+
+@@ -1237,7 +1237,7 @@
+ edmove(KEY_DOWN);
+ }
+
+-void texteditor::edmove(int k, int options = EM_TAB) {
++void texteditor::edmove(int k, int options) {
+ int i, lm;
+ bool fdraw = false, acted;
+ bool ctrlpressed = (options & EM_CTRL) && (getctrlkeys() & CONTROL_PRESSED);
+diff -Nru centericq-4.7.2-bad/kkconsui-0.1/src/textinputline.cc centericq-4.7.2/kkconsui-0.1/src/textinputline.cc
+--- centericq-4.7.2-bad/kkconsui-0.1/src/textinputline.cc Sat Mar 30 15:58:22 2002
++++ centericq-4.7.2/kkconsui-0.1/src/textinputline.cc Sat Jun 8 00:13:41 2002
+@@ -221,8 +221,8 @@
+ passwordchar = npc;
+ }
+
+-void textinputline::setcolor(int acolor, int ahistcolor = 0,
+-int ahistcurcolor = 0) {
++void textinputline::setcolor(int acolor, int ahistcolor,
++int ahistcurcolor) {
+ color = acolor;
+
+ if(!(histcolor = ahistcolor)) histcolor = color;
+diff -Nru centericq-4.7.2-bad/kkconsui-0.1/src/textwindow.cc centericq-4.7.2/kkconsui-0.1/src/textwindow.cc
+--- centericq-4.7.2-bad/kkconsui-0.1/src/textwindow.cc Sat Mar 30 15:58:24 2002
++++ centericq-4.7.2/kkconsui-0.1/src/textwindow.cc Sat Jun 8 00:14:45 2002
+@@ -29,7 +29,7 @@
+ }
+
+ textwindow::textwindow(int xx1, int yy1, int xx2, int yy2, int wcolor,
+-int noptions = 0, int tcolor = 0, const char *tfmt = 0, ...) {
++int noptions, int tcolor, const char *tfmt, ...) {
+ char buf[10240];
+
+ setoptions(noptions);
+diff -Nru centericq-4.7.2-bad/kkstrtext-0.1/kkstrtext.cc centericq-4.7.2/kkstrtext-0.1/kkstrtext.cc
+--- centericq-4.7.2-bad/kkstrtext-0.1/kkstrtext.cc Sun Apr 7 18:36:00 2002
++++ centericq-4.7.2/kkstrtext-0.1/kkstrtext.cc Sat Jun 8 00:11:08 2002
+@@ -276,7 +276,7 @@
+ }
+
+ const char *strqpbrk(const char *s, int offset,
+-const char *accept, const char *q, const char *esc = "") {
++const char *accept, const char *q, const char *esc) {
+ if(!s) return 0;
+ if(!s[0]) return 0;
+
+@@ -309,7 +309,7 @@
+ }
+
+ const char *strqcasestr(const char *s, const char *str,
+-const char *q, const char *esc = "") {
++const char *q, const char *esc) {
+ char quote = 0;
+ int i;
+
+@@ -328,7 +328,7 @@
+ }
+
+ const char *strqstr(const char *s, const char *str,
+-const char *q, const char *esc = "") {
++const char *q, const char *esc) {
+ char quote;
+ const char *ret = 0, *p, *ss, *r;
+ p = ss = s;
+@@ -442,17 +442,17 @@
+ return r;
+ }
+
+-string leadcut(const string &base, const string &delim = "\t\n\r ") {
++string leadcut(const string &base, const string &delim) {
+ int pos = base.find_first_not_of(delim);
+ return (pos != -1) ? base.substr(pos) : "";
+ }
+
+-string trailcut(const string &base, const string &delim = "\t\n\r ") {
++string trailcut(const string &base, const string &delim) {
+ int pos = base.find_last_not_of(delim);
+ return (pos != -1) ? base.substr(0, pos+1) : "";
+ }
+
+-string getword(string &base, const string &delim = "\t\n\r ") {
++string getword(string &base, const string &delim) {
+ string sub;
+ int i;
+
+@@ -492,7 +492,7 @@
+ return sub;
+ }
+
+-string getrword(string &base, const string &delim = "\t\n\r ") {
++string getrword(string &base, const string &delim) {
+ string sub;
+ int i;
+
+@@ -510,7 +510,7 @@
+ return sub;
+ }
+
+-string getrwordquote(string &base, const string &quote = "\"", const string &delim = "\t\n\r ") {
++string getrwordquote(string &base, const string &quote, const string &delim) {
+ string sub;
+ bool inquote = false;
+ int i;
+@@ -531,7 +531,7 @@
+ return sub;
+ }
+
+-int rtabmargin(bool fake, int curpos, const char *p = 0) {
++int rtabmargin(bool fake, int curpos, const char *p) {
+ int ret = -1, n, near;
+
+ if(p && (curpos != strlen(p))) {
+@@ -553,7 +553,7 @@
+ return ret;
+ }
+
+-int ltabmargin(bool fake, int curpos, const char *p = 0) {
++int ltabmargin(bool fake, int curpos, const char *p) {
+ int ret = -1, near, n = 0;
+ const char *cp;
+
+@@ -666,8 +666,8 @@
+ }
+ }
+
+-int find_quoted(const string &str, const string &needle, int offs = 0,
+-const string &quote = "\"'", const string &escape = "\\") {
++int find_quoted(const string &str, const string &needle, int offs,
++const string &quote, const string &escape) {
+ vector<quotedblock> positions;
+ vector<quotedblock>::iterator qi;
+ int npos = offs;
+@@ -686,8 +686,8 @@
+ return !found ? npos : -1;
+ }
+
+-int find_quoted_first_of(const string &str, const string &needle, int offs = 0,
+-const string &quote = "\"'", const string &escape = "\\") {
++int find_quoted_first_of(const string &str, const string &needle, int offs,
++const string &quote, const string &escape ) {
+ vector<quotedblock> positions;
+ vector<quotedblock>::iterator qi;
+ int npos = offs;
+@@ -706,7 +706,7 @@
+ return !found ? npos : -1;
+ }
+
+-void splitlongtext(string text, vector<string> &lst, int size = 440, const string cont = "\n[continued]") {
++void splitlongtext(string text, vector<string> &lst, int size, const string cont ) {
+ string sub;
+ int npos;
+
+@@ -734,11 +734,11 @@
+ }
+ }
+
+-string strdateandtime(time_t stamp, const string &fmt = "") {
++string strdateandtime(time_t stamp, const string &fmt ) {
+ return strdateandtime(localtime(&stamp), fmt);
+ }
+
+-string strdateandtime(struct tm *tms, const string &fmt = "") {
++string strdateandtime(struct tm *tms, const string &fmt ) {
+ char buf[512];
+ time_t current_time = time(0);
+ time_t when = mktime(tms);
+@@ -782,7 +782,7 @@
+ return r;
+ }
+
+-bool getconf(string &st, string &buf, ifstream &f, bool passemptylines = false) {
++bool getconf(string &st, string &buf, ifstream &f, bool passemptylines ) {
+ bool ret = false;
+ static string sect;
+
+diff -Nru centericq-4.7.2-bad/kkstrtext-0.1/kkstrtext.h centericq-4.7.2/kkstrtext-0.1/kkstrtext.h
+--- centericq-4.7.2-bad/kkstrtext-0.1/kkstrtext.h Sun Apr 7 18:36:00 2002
++++ centericq-4.7.2/kkstrtext-0.1/kkstrtext.h Sat Jun 8 00:05:07 2002
+@@ -93,7 +93,7 @@
+ string i2str(int i);
+ string ui2str(int i);
+
+-bool getconf(string &st, string &buf, ifstream &f, bool passemptylines = false);
++bool getconf(string &st, string &buf, ifstream &f, bool passemptylines = false );
+ bool getstring(istream &f, string &buf);
+
+ string unmime(const string &text);
+diff -Nru centericq-4.7.2-bad/kksystr-0.1/src/kkfsys.cc centericq-4.7.2/kksystr-0.1/src/kkfsys.cc
+--- centericq-4.7.2-bad/kksystr-0.1/src/kkfsys.cc Mon Mar 4 13:25:50 2002
++++ centericq-4.7.2/kksystr-0.1/src/kkfsys.cc Sat Jun 8 00:18:43 2002
+@@ -129,7 +129,7 @@
+ return stopwalk;
+ }
+
+-string pathfind(const string &name, const string &path, int amode = F_OK) {
++string pathfind(const string &name, const string &path, int amode) {
+ string token, current, buf = path;
+
+ while(!(token = getword(buf, ":")).empty()) {
+@@ -191,7 +191,7 @@
+ if((mode & m) && !regexec(&r, fname.c_str(), 0, 0, 0)) \
+ lst.push_back(fname);
+
+-vector<string> filefind(const string &mask, const string &aroot, int mode = FFIND_FILE) {
++vector<string> filefind(const string &mask, const string &aroot, int mode) {
+ vector<string> lst, rlst;
+ vector<string>::iterator is;
+ regex_t r;
+diff -Nru centericq-4.7.2-bad/src/centericq.cc centericq-4.7.2/src/centericq.cc
+--- centericq-4.7.2-bad/src/centericq.cc Wed May 8 20:07:05 2002
++++ centericq-4.7.2/src/centericq.cc Sat Jun 8 00:23:09 2002
+@@ -898,7 +898,7 @@
+ return c;
+ }
+
+-bool centericq::idle(int options = 0) {
++bool centericq::idle(int options) {
+ bool keypressed, online, fin;
+ fd_set rfds, wfds, efds;
+ struct timeval tv;
+diff -Nru centericq-4.7.2-bad/src/icqcontacts.cc centericq-4.7.2/src/icqcontacts.cc
+--- centericq-4.7.2-bad/src/icqcontacts.cc Tue Apr 9 13:10:33 2002
++++ centericq-4.7.2/src/icqcontacts.cc Sat Jun 8 00:29:46 2002
+@@ -34,7 +34,7 @@
+ icqcontacts::~icqcontacts() {
+ }
+
+-icqcontact *icqcontacts::addnew(const imcontact &cinfo, bool notinlist = true) {
++icqcontact *icqcontacts::addnew(const imcontact &cinfo, bool notinlist) {
+ icqcontact *c = new icqcontact(cinfo);
+
+ switch(cinfo.pname) {
+diff -Nru centericq-4.7.2-bad/src/icqface.cc centericq-4.7.2/src/icqface.cc
+--- centericq-4.7.2-bad/src/icqface.cc Thu May 16 17:32:09 2002
++++ centericq-4.7.2/src/icqface.cc Sat Jun 8 00:32:54 2002
+@@ -1049,7 +1049,7 @@
+
+ #define INPUT_POS LINES-2
+
+-string icqface::inputstr(const string &q, const string &defl = "", char passwdchar = 0) {
++string icqface::inputstr(const string &q, const string &defl, char passwdchar) {
+ screenarea sa(0, INPUT_POS, COLS, INPUT_POS);
+
+ attrset(conf.getcolor(cp_status));
+@@ -1066,7 +1066,7 @@
+ return input.getvalue();
+ }
+
+-string icqface::inputfile(const string &q, const string &defl = "") {
++string icqface::inputfile(const string &q, const string &defl) {
+ screenarea sa(0, INPUT_POS, COLS, INPUT_POS);
+ string r;
+
+@@ -1111,7 +1111,7 @@
+ if(defl == option) q[q.size()-1] = toupper(q[q.size()-1]);
+ }
+
+-int icqface::ask(string q, int options, int deflt = -1) {
++int icqface::ask(string q, int options, int deflt) {
+ int ret;
+ screenarea sa(0, INPUT_POS, COLS, INPUT_POS);
+
+@@ -1198,7 +1198,7 @@
+ }
+ }
+
+-void icqface::workarealine(int l, chtype c = HLINE) {
++void icqface::workarealine(int l, chtype c) {
+ attrset(conf.getcolor(cp_main_frame));
+ mvhline(l, sizeWArea.x1+1, c, sizeWArea.x2-sizeWArea.x1-1);
+ }
+@@ -1282,7 +1282,7 @@
+ restoreworkarea();
+ }
+
+-bool icqface::multicontacts(const string &ahead = "") {
++bool icqface::multicontacts(const string &ahead) {
+ int i, savefirst, saveelem;
+ bool ret = true, finished = false;
+ string head = ahead;
+@@ -1417,7 +1417,7 @@
+ update();
+ }
+
+-void icqface::quickfind(verticalmenu *multi = 0) {
++void icqface::quickfind(verticalmenu *multi) {
+ bool fin;
+ string nick, disp, upnick, upcurrent;
+ string::iterator is;
+@@ -2271,7 +2271,7 @@
+ w->write(2, 1+curline++, buf);
+ }
+
+-void icqface::icqprogress::show(const string &title = "") {
++void icqface::icqprogress::show(const string &title) {
+ if(!w) {
+ w = new textwindow(0, 0, face.sizeDlg.width, face.sizeDlg.height,
+ conf.getcolor(cp_dialog_frame), TW_CENTERED);
diff --git a/net-im/centericq/files/digest-centericq-4.7.2 b/net-im/centericq/files/digest-centericq-4.7.2
new file mode 100644
index 000000000000..88fac97706cf
--- /dev/null
+++ b/net-im/centericq/files/digest-centericq-4.7.2
@@ -0,0 +1 @@
+MD5 232f4bf04e6dbc59441af8c19f8211bb centericq-4.7.2.tar.gz 856151