summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2010-04-22 23:00:39 +0000
committerLars Wendler <polynomial-c@gentoo.org>2010-04-22 23:00:39 +0000
commit8bdcd9de91625f0aa7d75a157770d5a745193e5b (patch)
treec32adcadf85859fbf03d1d9ad8803b850e1d1e77 /net-im
parentUse Python 2. (diff)
downloadgentoo-2-8bdcd9de91625f0aa7d75a157770d5a745193e5b.tar.gz
gentoo-2-8bdcd9de91625f0aa7d75a157770d5a745193e5b.tar.bz2
gentoo-2-8bdcd9de91625f0aa7d75a157770d5a745193e5b.zip
Fix for bug #316691 and fix against possible sandbox violation.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/silc-client/ChangeLog10
-rw-r--r--net-im/silc-client/files/silc-client-1.1.8-sandbox-errors-fix.patch22
-rw-r--r--net-im/silc-client/silc-client-1.1.8.ebuild6
3 files changed, 35 insertions, 3 deletions
diff --git a/net-im/silc-client/ChangeLog b/net-im/silc-client/ChangeLog
index 1d36c413ce19..a6e431ae1884 100644
--- a/net-im/silc-client/ChangeLog
+++ b/net-im/silc-client/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-im/silc-client
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/silc-client/ChangeLog,v 1.58 2010/04/22 12:12:31 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/silc-client/ChangeLog,v 1.59 2010/04/22 23:00:39 polynomial-c Exp $
+
+ 22 Apr 2010; Lars Wendler <polynomial-c@gentoo.org>
+ silc-client-1.1.8.ebuild,
+ +files/silc-client-1.1.8-sandbox-errors-fix.patch:
+ non-maintainer commit:
+ Added a patch to work around a sandbox violation.
+ Also added >=net-im/silc-toolkit to DEPEND to fix bug #316691 which got
+ caught by flameeyes during his usual tinderbox runs.
22 Apr 2010; Christian Faulhammer <fauli@gentoo.org>
silc-client-1.1.8.ebuild:
diff --git a/net-im/silc-client/files/silc-client-1.1.8-sandbox-errors-fix.patch b/net-im/silc-client/files/silc-client-1.1.8-sandbox-errors-fix.patch
new file mode 100644
index 000000000000..0998c16c31b6
--- /dev/null
+++ b/net-im/silc-client/files/silc-client-1.1.8-sandbox-errors-fix.patch
@@ -0,0 +1,22 @@
+--- silc-client-1.1.8/lib/Makefile.am
++++ silc-client-1.1.8/lib/Makefile.am
+@@ -75,7 +75,7 @@
+
+ install-exec-hook:
+ if SILC_ENABLE_SHARED
+- -mkdir -p $(libdir)
++ -mkdir -p $(DESTDIR)$(libdir)
+ -$(LIBTOOL) --mode=install $(INSTALL) libsilc.la $(DESTDIR)$(libdir)/
+ -$(LIBTOOL) --mode=install $(INSTALL) libsilcclient.la $(DESTDIR)$(libdir)/
+ -rm -rf $(DESTDIR)$(libdir)/libsilc.a
+--- silc-client-1.1.8/lib/Makefile.in
++++ silc-client-1.1.8/lib/Makefile.in
+@@ -640,7 +640,7 @@
+ $(MAKE) remove $(SILCLIB) $(SILCSERVERLIB) $(SILCCLIENTLIB)
+
+ install-exec-hook:
+-@SILC_ENABLE_SHARED_TRUE@ -mkdir -p $(libdir)
++@SILC_ENABLE_SHARED_TRUE@ -mkdir -p $(DESTDIR)$(libdir)
+ @SILC_ENABLE_SHARED_TRUE@ -$(LIBTOOL) --mode=install $(INSTALL) libsilc.la $(DESTDIR)$(libdir)/
+ @SILC_ENABLE_SHARED_TRUE@ -$(LIBTOOL) --mode=install $(INSTALL) libsilcclient.la $(DESTDIR)$(libdir)/
+ @SILC_ENABLE_SHARED_TRUE@ -rm -rf $(DESTDIR)$(libdir)/libsilc.a
diff --git a/net-im/silc-client/silc-client-1.1.8.ebuild b/net-im/silc-client/silc-client-1.1.8.ebuild
index 23fdebee2c6a..95a59a88441d 100644
--- a/net-im/silc-client/silc-client-1.1.8.ebuild
+++ b/net-im/silc-client/silc-client-1.1.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/silc-client/silc-client-1.1.8.ebuild,v 1.3 2010/04/22 12:12:31 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/silc-client/silc-client-1.1.8.ebuild,v 1.4 2010/04/22 23:00:39 polynomial-c Exp $
EAPI=2
@@ -21,7 +21,8 @@ COMMONDEPEND="perl? ( dev-lang/perl )
!<=net-im/silc-toolkit-0.9.12-r1"
DEPEND="${COMMONDEPEND}
- dev-util/pkgconfig"
+ dev-util/pkgconfig
+ >=net-im/silc-toolkit-1.1.10"
RDEPEND="${COMMONDEPEND}
perl? (
@@ -33,6 +34,7 @@ src_prepare() {
sed -i -e "s:-g -O2:${CFLAGS}:g" configure
use amd64 && sed -i -e 's:felf\([^6]\):felf64\1:g' configure
epatch "${FILESDIR}/${PN}-1.1.8-docdir.patch"
+ epatch "${FILESDIR}/${P}-sandbox-errors-fix.patch"
}
src_configure() {