summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2013-09-14 23:05:48 +0000
committerHanno Böck <hanno@gentoo.org>2013-09-14 23:05:48 +0000
commitd294172ae7df098c838ee3540ce70151ce1afd9b (patch)
tree287a4eadbf0df42a7a7544db9575055fc0abc524 /net-im
parentAdd -fno-strict-aliasing for python2. (diff)
downloadgentoo-2-d294172ae7df098c838ee3540ce70151ce1afd9b.tar.gz
gentoo-2-d294172ae7df098c838ee3540ce70151ce1afd9b.tar.bz2
gentoo-2-d294172ae7df098c838ee3540ce70151ce1afd9b.zip
pymsn-t: various fixex, cleanup
(Portage version: 2.2.4/cvs/Linux x86_64, signed Manifest commit with key 0xA5880072BBB51E42)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/pymsn-t/ChangeLog10
-rw-r--r--net-im/pymsn-t/files/pymsn-t-0.11.3-imaging-pillow.patch12
-rw-r--r--net-im/pymsn-t/files/pymsn-t-0.11.3-twisted13.patch11
-rw-r--r--net-im/pymsn-t/files/pymsn-t-initd-r124
-rw-r--r--net-im/pymsn-t/pymsn-t-0.11.3-r4.ebuild57
5 files changed, 113 insertions, 1 deletions
diff --git a/net-im/pymsn-t/ChangeLog b/net-im/pymsn-t/ChangeLog
index 7857cd9aadcf..13a1fded6bf7 100644
--- a/net-im/pymsn-t/ChangeLog
+++ b/net-im/pymsn-t/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-im/pymsn-t
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pymsn-t/ChangeLog,v 1.27 2013/08/03 09:45:38 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pymsn-t/ChangeLog,v 1.28 2013/09/14 23:05:48 hanno Exp $
+
+*pymsn-t-0.11.3-r4 (14 Sep 2013)
+
+ 14 Sep 2013; <hanno@gentoo.org> +pymsn-t-0.11.3-r4.ebuild,
+ +files/pymsn-t-0.11.3-imaging-pillow.patch,
+ +files/pymsn-t-0.11.3-twisted13.patch, +files/pymsn-t-initd-r1:
+ Cleanup, new URL, port to new python eclass, fix for twisted 13.x, fix
+ deprecated PIL imports.
03 Aug 2013; Michał Górny <mgorny@gentoo.org> pymsn-t-0.11.3-r3.ebuild:
Move dev-python/twisted to dev-python/twisted-core.
diff --git a/net-im/pymsn-t/files/pymsn-t-0.11.3-imaging-pillow.patch b/net-im/pymsn-t/files/pymsn-t-0.11.3-imaging-pillow.patch
new file mode 100644
index 000000000000..7d17dae04f21
--- /dev/null
+++ b/net-im/pymsn-t/files/pymsn-t-0.11.3-imaging-pillow.patch
@@ -0,0 +1,12 @@
+diff -Naur pymsnt-0.11.3/src/utils.py pymsnt-0.11.3-1/src/utils.py
+--- pymsnt-0.11.3/src/utils.py 2008-02-08 14:55:07.000000000 +0100
++++ pymsnt-0.11.3-1/src/utils.py 2013-09-15 00:27:56.815633838 +0200
+@@ -25,7 +25,7 @@
+
+
+ try:
+- import Image
++ from PIL import Image
+ import StringIO
+
+ def convertToPNG(imageData):
diff --git a/net-im/pymsn-t/files/pymsn-t-0.11.3-twisted13.patch b/net-im/pymsn-t/files/pymsn-t-0.11.3-twisted13.patch
new file mode 100644
index 000000000000..aab9bad77b72
--- /dev/null
+++ b/net-im/pymsn-t/files/pymsn-t-0.11.3-twisted13.patch
@@ -0,0 +1,11 @@
+--- pymsnt-0.11.3/src/main.py 2008-02-08 14:55:07.000000000 +0100
++++ pymsnt-0.11.3-1/src/main.py 2013-09-15 00:57:20.297587280 +0200
+@@ -328,7 +328,7 @@
+
+ # Daemonise the process and write the PID file
+ if config.background and os.name == "posix":
+- twistd.daemonize()
++ twistd.daemonize(reactor,os)
+ if config.pid:
+ self.writePID()
+
diff --git a/net-im/pymsn-t/files/pymsn-t-initd-r1 b/net-im/pymsn-t/files/pymsn-t-initd-r1
new file mode 100644
index 000000000000..d7ba09a634ba
--- /dev/null
+++ b/net-im/pymsn-t/files/pymsn-t-initd-r1
@@ -0,0 +1,24 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/pymsn-t/files/pymsn-t-initd-r1,v 1.1 2013/09/14 23:05:48 hanno Exp $
+
+depend() {
+ need net
+ use jabber-server
+}
+
+start() {
+ ebegin "Starting MSN Jabber Transport"
+ checkpath -q -d -m 0755 -o jabber:jabber /var/run/jabber/
+ start-stop-daemon --start --pidfile /var/run/jabber/pymsn-t.pid -u jabber -g jabber \
+ --exec INSPATH/pymsn-t.py -- \
+ -b -c /etc/jabber/pymsn-t.xml -l /var/log/jabber/pymsn-t.log
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping MSN Jabber Transport"
+ start-stop-daemon --stop --quiet --pidfile /var/run/jabber/pymsn-t.pid
+ eend $?
+}
diff --git a/net-im/pymsn-t/pymsn-t-0.11.3-r4.ebuild b/net-im/pymsn-t/pymsn-t-0.11.3-r4.ebuild
new file mode 100644
index 000000000000..11ca5092637a
--- /dev/null
+++ b/net-im/pymsn-t/pymsn-t-0.11.3-r4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/pymsn-t/pymsn-t-0.11.3-r4.ebuild,v 1.1 2013/09/14 23:05:48 hanno Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+inherit eutils python-single-r1
+
+MY_P="${P/pymsn-t/pymsnt}"
+DESCRIPTION="Python based jabber transport for MSN"
+HOMEPAGE="http://delx.net.au/projects/pymsnt/"
+SRC_URI="http://delx.net.au/projects/pymsnt/tarballs/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="net-im/jabber-base"
+RDEPEND="${DEPEND}
+ dev-python/twisted-core[${PYTHON_USEDEP}]
+ dev-python/twisted-words[${PYTHON_USEDEP}]
+ dev-python/twisted-web[${PYTHON_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-protocol-version.patch"
+ epatch "${FILESDIR}/${P}-unexpected-xfr.patch"
+ epatch "${FILESDIR}/${P}-remove-pid.patch"
+ epatch "${FILESDIR}/${P}-delete-reactor.patch"
+ epatch "${FILESDIR}/${P}-use-non-deprecated-hashlib.patch"
+ epatch "${FILESDIR}/${P}-imaging-pillow.patch"
+ epatch "${FILESDIR}/${P}-twisted13.patch"
+}
+
+src_install() {
+ python_moduleinto ${PN}
+ cp PyMSNt.py ${PN}.py
+ python_domodule ${PN}.py data src
+
+ insinto /etc/jabber
+ newins config-example.xml ${PN}.xml
+ fperms 600 /etc/jabber/${PN}.xml
+ fowners jabber:jabber /etc/jabber/${PN}.xml
+ fperms 755 "$(python_get_sitedir)/${PN}/${PN}.py"
+ sed -i \
+ -e "s:<!-- <spooldir>[^\<]*</spooldir> -->:<spooldir>/var/spool/jabber</spooldir>:" \
+ -e "s:<pid>[^\<]*</pid>:<pid>/var/run/jabber/${PN}.pid</pid>:" \
+ -e "s:<host>[^\<]*</host>:<host>example.org</host>:" \
+ -e "s:<jid>msn</jid>:<jid>msn.example.org</jid>:" \
+ "${ED}/etc/jabber/${PN}.xml"
+
+ newinitd "${FILESDIR}/${PN}-initd-r1" ${PN}
+ sed -i -e "s:INSPATH:$(python_get_sitedir)/${PN}:" "${ED}/etc/init.d/${PN}"
+ python_fix_shebang "${D}$(python_get_sitedir)/${PN}"
+}