summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-07-24 17:43:28 +0000
committerPacho Ramos <pacho@gentoo.org>2012-07-24 17:43:28 +0000
commite56034d15e8733b54f1fb283ea5b4a2980e4da8e (patch)
treeb56d8c9c75e30f8db8a3d27520aec9e9f01d8ad6 /net-im
parentFix init script warnings (diff)
downloadgentoo-2-e56034d15e8733b54f1fb283ea5b4a2980e4da8e.tar.gz
gentoo-2-e56034d15e8733b54f1fb283ea5b4a2980e4da8e.tar.bz2
gentoo-2-e56034d15e8733b54f1fb283ea5b4a2980e4da8e.zip
Version bump, also fix gcc-4.7 and glib-2.32 compilation, and create user/group properly (#343219 by fulax).
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/minbif/ChangeLog12
-rw-r--r--net-im/minbif/files/minbif-1.0.5-gcc47.patch76
-rw-r--r--net-im/minbif/files/minbif-1.0.5-glib-single-includes.patch26
-rw-r--r--net-im/minbif/minbif-1.0.5.ebuild80
4 files changed, 191 insertions, 3 deletions
diff --git a/net-im/minbif/ChangeLog b/net-im/minbif/ChangeLog
index ca2aa8b349b1..cd86373d7357 100644
--- a/net-im/minbif/ChangeLog
+++ b/net-im/minbif/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/minbif
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/minbif/ChangeLog,v 1.9 2011/02/25 19:41:41 cedk Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/minbif/ChangeLog,v 1.10 2012/07/24 17:43:28 pacho Exp $
+
+*minbif-1.0.5 (24 Jul 2012)
+
+ 24 Jul 2012; Pacho Ramos <pacho@gentoo.org> +files/minbif-1.0.5-gcc47.patch,
+ +files/minbif-1.0.5-glib-single-includes.patch, +minbif-1.0.5.ebuild:
+ Version bump, also fix gcc-4.7 and glib-2.32 compilation, and create
+ user/group properly (#343219 by fulax).
*minbif-1.0.4 (25 Feb 2011)
@@ -39,4 +46,3 @@
24 Nov 2009; Cédric Krier <cedk@gentoo.org> +minbif-1.0.ebuild,
+files/minbif.initd, +metadata.xml:
New ebuild
-
diff --git a/net-im/minbif/files/minbif-1.0.5-gcc47.patch b/net-im/minbif/files/minbif-1.0.5-gcc47.patch
new file mode 100644
index 000000000000..dc49878ea1e3
--- /dev/null
+++ b/net-im/minbif/files/minbif-1.0.5-gcc47.patch
@@ -0,0 +1,76 @@
+commit fe71fd989a4501c77314b2906756f4e9a328ff31
+Author: Romain Bignon <romain@symlink.me>
+Date: Tue May 8 16:46:35 2012 +0200
+
+ fixes for gcc 4.7
+
+diff --git a/src/im/account.cpp b/src/im/account.cpp
+index f155334..21baa5f 100644
+--- a/src/im/account.cpp
++++ b/src/im/account.cpp
+@@ -18,6 +18,7 @@
+
+ #include <cassert>
+ #include <cstring>
++#include <unistd.h>
+ #ifdef HAVE_IMLIB
+ #include <Imlib2.h>
+ #endif /* HAVE_IMLIB */
+diff --git a/src/im/request.cpp b/src/im/request.cpp
+index e72cbc9..a247e3b 100644
+--- a/src/im/request.cpp
++++ b/src/im/request.cpp
+@@ -18,6 +18,7 @@
+
+ #include <errno.h>
+ #include <string.h>
++#include <unistd.h>
+
+ #include "request.h"
+ #include "buddy.h"
+diff --git a/src/irc/dcc.cpp b/src/irc/dcc.cpp
+index 6d05034..231122c 100644
+--- a/src/irc/dcc.cpp
++++ b/src/irc/dcc.cpp
+@@ -23,6 +23,7 @@
+ #include <string.h>
+ #include <sys/types.h>
+ #include <netinet/in.h>
++#include <unistd.h>
+
+ #include "dcc.h"
+ #include "nick.h"
+diff --git a/src/irc/irc.cpp b/src/irc/irc.cpp
+index 5d28acb..116d9db 100644
+--- a/src/irc/irc.cpp
++++ b/src/irc/irc.cpp
+@@ -246,7 +246,7 @@ Nick* IRC::getNick(string nickname, bool case_sensitive) const
+ Buddy* IRC::getNick(const im::Buddy& buddy) const
+ {
+ map<string, Nick*>::const_iterator it;
+- Buddy* nb;
++ Buddy* nb = NULL;
+ for(it = users.begin();
+ it != users.end() && (!(nb = dynamic_cast<Buddy*>(it->second)) || nb->getBuddy() != buddy);
+ ++it)
+@@ -261,7 +261,7 @@ Buddy* IRC::getNick(const im::Buddy& buddy) const
+ ConvNick* IRC::getNick(const im::Conversation& conv) const
+ {
+ map<string, Nick*>::const_iterator it;
+- ConvNick* n;
++ ConvNick* n = NULL;
+ for(it = users.begin();
+ it != users.end() && (!(n = dynamic_cast<ConvNick*>(it->second)) || n->getConversation() != conv);
+ ++it)
+diff --git a/src/server_poll/inetd.cpp b/src/server_poll/inetd.cpp
+index 4f3023d..f747e74 100644
+--- a/src/server_poll/inetd.cpp
++++ b/src/server_poll/inetd.cpp
+@@ -18,6 +18,7 @@
+
+ #include <cassert>
+ #include <glib.h>
++#include <unistd.h>
+
+ #include "inetd.h"
+ #include "irc/irc.h"
diff --git a/net-im/minbif/files/minbif-1.0.5-glib-single-includes.patch b/net-im/minbif/files/minbif-1.0.5-glib-single-includes.patch
new file mode 100644
index 000000000000..599355eb502c
--- /dev/null
+++ b/net-im/minbif/files/minbif-1.0.5-glib-single-includes.patch
@@ -0,0 +1,26 @@
+Index: minbif-1.0.5/src/server_poll/daemon_fork.cpp
+===================================================================
+--- minbif-1.0.5.orig/src/server_poll/daemon_fork.cpp
++++ minbif-1.0.5/src/server_poll/daemon_fork.cpp
+@@ -20,7 +20,7 @@
+ #include <cassert>
+ #include <cstring>
+ #include <cerrno>
+-#include <glib/gmain.h>
++#include <glib.h>
+ #include <sys/socket.h>
+ #include <sys/stat.h>
+ #include <arpa/inet.h>
+Index: minbif-1.0.5/src/server_poll/inetd.cpp
+===================================================================
+--- minbif-1.0.5.orig/src/server_poll/inetd.cpp
++++ minbif-1.0.5/src/server_poll/inetd.cpp
+@@ -17,7 +17,7 @@
+ */
+
+ #include <cassert>
+-#include <glib/gmain.h>
++#include <glib.h>
+
+ #include "inetd.h"
+ #include "irc/irc.h"
diff --git a/net-im/minbif/minbif-1.0.5.ebuild b/net-im/minbif/minbif-1.0.5.ebuild
new file mode 100644
index 000000000000..55785879eabb
--- /dev/null
+++ b/net-im/minbif/minbif-1.0.5.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/minbif/minbif-1.0.5.ebuild,v 1.1 2012/07/24 17:43:28 pacho Exp $
+
+EAPI=4
+inherit cmake-utils eutils
+
+DESCRIPTION="an IRC gateway to IM networks"
+HOMEPAGE="https://symlink.me/projects/minbif/wiki/"
+SRC_URI="https://symlink.me/attachments/download/148/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="gnutls +imlib +libcaca pam video xinetd"
+REQUIRED_USE="video? ( libcaca )"
+
+DEPEND=">=net-im/pidgin-2.6
+ video? ( >=net-im/pidgin-2.6[gstreamer] net-libs/farsight2 )
+ libcaca? ( media-libs/libcaca media-libs/imlib2 )
+ imlib? ( media-libs/imlib2 )
+ pam? ( sys-libs/pam )
+ gnutls? ( net-libs/gnutls )"
+RDEPEND="${DEPEND}
+ virtual/logger
+ xinetd? ( sys-apps/xinetd )"
+
+pkg_setup() {
+ enewgroup minbif
+ enewuser minbif -1 -1 /var/lib/minbif minbif
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.0.5-glib-single-includes.patch"
+ epatch "${FILESDIR}/${PN}-1.0.5-gcc47.patch"
+
+ sed -i "s/-Werror//g" CMakeLists.txt || die "sed failed"
+
+ sed -i "s#share/doc/minbif#share/doc/${P}#" \
+ CMakeLists.txt || die "sed failed"
+
+ if use xinetd; then
+ sed -i "s/type\s=\s[0-9]/type = 0/" \
+ minbif.conf || die "sed failed"
+ fi
+}
+
+src_configure() {
+ local mycmakeargs
+ mycmakeargs="${mycmakeargs}
+ -DCONF_PREFIX=${PREFIX:-/etc/minbif}
+ $(cmake-utils_use_enable libcaca CACA)
+ $(cmake-utils_use_enable video VIDEO)
+ $(cmake-utils_use_enable imlib IMLIB)
+ $(cmake-utils_use_enable pam PAM)
+ $(cmake-utils_use_enable gnutls TLS)"
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ keepdir /var/lib/minbif
+ fperms 700 /var/lib/minbif
+ fowners minbif:minbif /var/lib/minbif
+
+ dodoc ChangeLog README
+ doman man/minbif.8
+
+ if use xinetd; then
+ insinto /etc/xinetd.d
+ newins doc/minbif.xinetd minbif
+ fi
+
+ newinitd "${FILESDIR}"/minbif.initd minbif
+
+ dodir /usr/share/minbif
+ insinto /usr/share/minbif
+ doins -r scripts
+}