summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Phillip Brink <binki@gentoo.org>2011-09-30 03:38:22 +0000
committerNathan Phillip Brink <binki@gentoo.org>2011-09-30 03:38:22 +0000
commita62735da28e6025451fcadc2aae29fbd8c3bac77 (patch)
tree624f6849798a34d412161ce1d2bc0c0eb75d3653 /net-irc/atheme-services
parent[dev-db/mariadb] Bumped to 5.2.9 release. (diff)
downloadgentoo-2-a62735da28e6025451fcadc2aae29fbd8c3bac77.tar.gz
gentoo-2-a62735da28e6025451fcadc2aae29fbd8c3bac77.tar.bz2
gentoo-2-a62735da28e6025451fcadc2aae29fbd8c3bac77.zip
Bump to atheme-services-7.0.0_alpha7 with patches pulled from git allowing it to compile.
(Portage version: 2.2.0_alpha55-r1/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/atheme-services')
-rw-r--r--net-irc/atheme-services/ChangeLog11
-rw-r--r--net-irc/atheme-services/atheme-services-7.0.0_alpha7.ebuild111
-rw-r--r--net-irc/atheme-services/files/atheme-services-7.0.0_alpha7-mowgli-strl.patch51
-rw-r--r--net-irc/atheme-services/files/atheme-services-7.0.0_alpha7-xmlrpc-mowgli-string.patch82
4 files changed, 254 insertions, 1 deletions
diff --git a/net-irc/atheme-services/ChangeLog b/net-irc/atheme-services/ChangeLog
index 9fab8b66c597..3db74f65a824 100644
--- a/net-irc/atheme-services/ChangeLog
+++ b/net-irc/atheme-services/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-irc/atheme-services
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/atheme-services/ChangeLog,v 1.10 2011/07/27 15:11:36 binki Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/atheme-services/ChangeLog,v 1.11 2011/09/30 03:38:22 binki Exp $
+
+*atheme-services-7.0.0_alpha7 (30 Sep 2011)
+
+ 30 Sep 2011; Nathan Phillip Brink <binki@gentoo.org>
+ +atheme-services-7.0.0_alpha7.ebuild,
+ +files/atheme-services-7.0.0_alpha7-mowgli-strl.patch,
+ +files/atheme-services-7.0.0_alpha7-xmlrpc-mowgli-string.patch:
+ Bump to atheme-services-7.0.0_alpha7 with patches pulled from git allowing it
+ to compile.
*atheme-services-7.0.0_alpha6 (27 Jul 2011)
diff --git a/net-irc/atheme-services/atheme-services-7.0.0_alpha7.ebuild b/net-irc/atheme-services/atheme-services-7.0.0_alpha7.ebuild
new file mode 100644
index 000000000000..5e24f1f56404
--- /dev/null
+++ b/net-irc/atheme-services/atheme-services-7.0.0_alpha7.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/atheme-services/atheme-services-7.0.0_alpha7.ebuild,v 1.1 2011/09/30 03:38:22 binki Exp $
+
+EAPI=4
+
+inherit eutils flag-o-matic perl-module prefix
+
+MY_P=${P/_/-}
+
+DESCRIPTION="A portable and secure set of open-source and modular IRC services"
+HOMEPAGE="http://atheme.net/"
+SRC_URI="http://atheme.net/downloads/${MY_P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86 ~x86-fbsd ~amd64-linux"
+IUSE="largenet ldap nls +pcre perl profile ssl"
+
+RDEPEND=">=dev-libs/libmowgli-0.9.90
+ ldap? ( net-nds/openldap )
+ nls? ( sys-devel/gettext )
+ perl? ( dev-lang/perl )
+ pcre? ( dev-libs/libpcre )
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ # the dependency calculation puts all of the .c files together and
+ # overwhelms cc1 with this flag :-(
+ filter-flags -combine
+
+ if use profile; then
+ # bug #371119
+ ewarn "USE=\"profile\" is incompatible with the hardened profile's -pie flag."
+ ewarn "Disabling PIE. Please ignore any warning messages about -nopie being invalid."
+ append-flags -nopie
+ fi
+
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/atheme ${PN}
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-mowgli-strl.patch \
+ "${FILESDIR}"/${P}-xmlrpc-mowgli-string.patch
+
+ # fix docdir
+ sed -i -e 's/\(^DOCDIR.*=.\)@DOCDIR@/\1@docdir@/' extra.mk.in || die
+
+ # basic logging config directive fix
+ sed -i -e '/^logfile/s;var/\(.*\.log\);'"${EPREFIX}"'/var/log/atheme/\1;g' dist/* || die
+
+ # QA against bundled libs
+ rm -rf libmowgli || die
+
+ # Get useful information into build.log
+ sed -i -e '/^\.SILENT:$/d' buildsys.mk.in || die
+}
+
+src_configure() {
+ econf \
+ atheme_cv_c_gcc_w_error_implicit_function_declaration=no \
+ --sysconfdir="${EPREFIX}"/etc/${PN} \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --localstatedir="${EPREFIX}"/var \
+ --enable-fhs-paths \
+ --disable-warnings \
+ --enable-contrib \
+ $(use_enable largenet large-net) \
+ $(use_with ldap) \
+ $(use_with nls) \
+ $(use_enable profile) \
+ $(use_with perl) \
+ $(use_with pcre) \
+ $(use_enable ssl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ insinto /etc/${PN}
+ for conf in dist/*.example; do
+ # The .cron file isn't meant to live in /etc/${PN}, so only
+ # install a .example version.
+ [[ ${conf} == *cron* ]] && continue
+
+ newins ${conf} $(basename ${conf} .example)
+ done
+
+ fowners -R 0:${PN} /etc/${PN}
+ keepdir /var/{lib,log}/atheme
+ fowners ${PN}:${PN} /var/{lib,log,run}/atheme
+ fperms -R go-w,o-rx /etc/${PN}
+ fperms 750 /etc/${PN} /var/{lib,log,run}/atheme
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+
+ # contributed scripts and such:
+ insinto /usr/share/doc/${PF}/contrib
+ doins contrib/*.{c,pl,php,py,rb}
+
+ if use perl; then
+ perlinfo
+ insinto "${VENDOR_LIB#${EPREFIX}}"
+ doins -r contrib/Atheme{,.pm}
+ fi
+}
diff --git a/net-irc/atheme-services/files/atheme-services-7.0.0_alpha7-mowgli-strl.patch b/net-irc/atheme-services/files/atheme-services-7.0.0_alpha7-mowgli-strl.patch
new file mode 100644
index 000000000000..b9a1b8317748
--- /dev/null
+++ b/net-irc/atheme-services/files/atheme-services-7.0.0_alpha7-mowgli-strl.patch
@@ -0,0 +1,51 @@
+From e933fc04fea4636325fbe60c769e1e20da74496c Mon Sep 17 00:00:00 2001
+From: JD Horelick <jdhore1@gmail.com>
+Date: Wed, 31 Aug 2011 03:09:11 -0400
+Subject: [PATCH] hostserv|rpgserv: Change some code in headers to use mowgli_strlcpy() and mowgli_strlcat().
+
+---
+ modules/hostserv/hostserv.h | 2 +-
+ modules/rpgserv/prettyprint.h | 6 +++---
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/modules/hostserv/hostserv.h b/modules/hostserv/hostserv.h
+index 10ec4de..953105a 100644
+--- a/modules/hostserv/hostserv.h
++++ b/modules/hostserv/hostserv.h
+@@ -31,7 +31,7 @@ static inline void do_sethost(user_t *u, char *host)
+ return;
+
+ svs = service_find("hostserv");
+- strlcpy(u->vhost, host ? host : u->host, HOSTLEN);
++ mowgli_strlcpy(u->vhost, host ? host : u->host, HOSTLEN);
+ user_sethost(svs->me, u, u->vhost);
+ }
+
+diff --git a/modules/rpgserv/prettyprint.h b/modules/rpgserv/prettyprint.h
+index e643608..362eef6 100644
+--- a/modules/rpgserv/prettyprint.h
++++ b/modules/rpgserv/prettyprint.h
+@@ -70,7 +70,7 @@ static inline const char *rs_prettyprint_keywords(metadata_t *md, const char **k
+
+ *ppbuf = '\0';
+
+- strlcpy(parsebuf, md->value, BUFSIZE);
++ mowgli_strlcpy(parsebuf, md->value, BUFSIZE);
+
+ keyword = strtok_r(parsebuf, " ", &pos);
+ if (keyword == NULL)
+@@ -85,9 +85,9 @@ static inline const char *rs_prettyprint_keywords(metadata_t *md, const char **k
+ if (!strcasecmp(keyword, keys[i]))
+ {
+ if (*ppbuf != '\0')
+- strlcat(ppbuf, ", ", BUFSIZE);
++ mowgli_strlcat(ppbuf, ", ", BUFSIZE);
+
+- strlcat(ppbuf, values[i], BUFSIZE);
++ mowgli_strlcat(ppbuf, values[i], BUFSIZE);
+ }
+ }
+ }
+--
+1.7.3.4
+
diff --git a/net-irc/atheme-services/files/atheme-services-7.0.0_alpha7-xmlrpc-mowgli-string.patch b/net-irc/atheme-services/files/atheme-services-7.0.0_alpha7-xmlrpc-mowgli-string.patch
new file mode 100644
index 000000000000..ca584161d90f
--- /dev/null
+++ b/net-irc/atheme-services/files/atheme-services-7.0.0_alpha7-xmlrpc-mowgli-string.patch
@@ -0,0 +1,82 @@
+From 7759002d4f84301541e8b6e5eb4c7a20d559d98d Mon Sep 17 00:00:00 2001
+From: William Pitcock <nenolod@dereferenced.org>
+Date: Wed, 31 Aug 2011 00:57:22 -0500
+Subject: [PATCH] transport/xmlrpc: unbreak build
+
+---
+ modules/transport/xmlrpc/xmlrpclib.c | 17 ++++++++++-------
+ 1 files changed, 10 insertions(+), 7 deletions(-)
+
+diff --git a/modules/transport/xmlrpc/xmlrpclib.c b/modules/transport/xmlrpc/xmlrpclib.c
+index c708985..11e3b7a 100644
+--- a/modules/transport/xmlrpc/xmlrpclib.c
++++ b/modules/transport/xmlrpc/xmlrpclib.c
+@@ -315,7 +315,7 @@ void xmlrpc_generic_error(int code, const char *string)
+ {
+ char buf[1024];
+ const char *ss;
+- mowgli_string_t *s = mowgli_string_create(XMLRPC_BUFSIZE);
++ mowgli_string_t *s = mowgli_string_create();
+ char *s2;
+ int len;
+
+@@ -353,7 +353,8 @@ void xmlrpc_generic_error(int code, const char *string)
+ }
+ else
+ xmlrpc.setbuffer(s->str, len);
+- s->delete(s);
++
++ s->destroy(s);
+ }
+
+ /*************************************************************************/
+@@ -387,7 +388,7 @@ void xmlrpc_send(int argc, ...)
+ int len;
+ char buf[1024];
+ const char *ss;
+- mowgli_string_t *s = mowgli_string_create(XMLRPC_BUFSIZE);
++ mowgli_string_t *s = mowgli_string_create();
+ char *s2;
+ char *header;
+
+@@ -438,7 +439,8 @@ void xmlrpc_send(int argc, ...)
+ free(xmlrpc.encode);
+ xmlrpc.encode = NULL;
+ }
+- s->delete(s);
++
++ s->destroy(s);
+ }
+
+ /*************************************************************************/
+@@ -448,7 +450,7 @@ void xmlrpc_send_string(const char *value)
+ int len;
+ char buf[1024];
+ const char *ss;
+- mowgli_string_t *s = mowgli_string_create(XMLRPC_BUFSIZE);
++ mowgli_string_t *s = mowgli_string_create();
+ char *s2;
+ char *header;
+
+@@ -493,7 +495,8 @@ void xmlrpc_send_string(const char *value)
+ free(xmlrpc.encode);
+ xmlrpc.encode = NULL;
+ }
+- s->delete(s);
++
++ s->destroy(s);
+ }
+
+ /*************************************************************************/
+@@ -736,7 +739,7 @@ void xmlrpc_char_encode(char *outbuffer, const char *s1)
+ long unsigned int i;
+ unsigned char c;
+ char buf2[15];
+- mowgli_string_t *s = mowgli_string_create(XMLRPC_BUFSIZE);
++ mowgli_string_t *s = mowgli_string_create();
+ *buf2 = '\0';
+ *outbuffer = '\0';
+
+--
+1.7.3.4
+