summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Horelick <jdhore@gentoo.org>2013-01-02 00:26:39 +0000
committerJeff Horelick <jdhore@gentoo.org>2013-01-02 00:26:39 +0000
commit557076fddadf4d5c89bed07e1757dcab7f62aaba (patch)
treec725bf8ee2d64339baf7deef55f9ac2f9e12701c /net-irc/bitchx
parentVersion bump; add a readline USE flag for the new optional dependency. (diff)
downloadgentoo-2-557076fddadf4d5c89bed07e1757dcab7f62aaba.tar.gz
gentoo-2-557076fddadf4d5c89bed07e1757dcab7f62aaba.tar.bz2
gentoo-2-557076fddadf4d5c89bed07e1757dcab7f62aaba.zip
Version bump
(Portage version: 2.2.0_alpha149/cvs/Linux i686, signed Manifest commit with key 23E9E900)
Diffstat (limited to 'net-irc/bitchx')
-rw-r--r--net-irc/bitchx/ChangeLog10
-rw-r--r--net-irc/bitchx/bitchx-1.2.ebuild76
-rw-r--r--net-irc/bitchx/files/bitchx-1.2-build.patch65
3 files changed, 149 insertions, 2 deletions
diff --git a/net-irc/bitchx/ChangeLog b/net-irc/bitchx/ChangeLog
index c17f0ef6be09..a07daf40b0f4 100644
--- a/net-irc/bitchx/ChangeLog
+++ b/net-irc/bitchx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/bitchx
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bitchx/ChangeLog,v 1.70 2011/12/21 19:52:31 binki Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bitchx/ChangeLog,v 1.71 2013/01/02 00:26:39 jdhore Exp $
+
+*bitchx-1.2 (02 Jan 2013)
+
+ 02 Jan 2013; Jeff Horelick <jdhore@gentoo.org> +bitchx-1.2.ebuild,
+ +files/bitchx-1.2-build.patch:
+ Version bump
21 Dec 2011; Nathan Phillip Brink <binki@gentoo.org> bitchx-1.1-r4.ebuild:
Update SRC_URI to point to tarball's new home.
diff --git a/net-irc/bitchx/bitchx-1.2.ebuild b/net-irc/bitchx/bitchx-1.2.ebuild
new file mode 100644
index 000000000000..8dd90a2a35d8
--- /dev/null
+++ b/net-irc/bitchx/bitchx-1.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bitchx/bitchx-1.2.ebuild,v 1.1 2013/01/02 00:26:39 jdhore Exp $
+
+EAPI=4
+
+inherit flag-o-matic eutils
+
+MY_PN=BitchX
+MY_P=${MY_PN}-${PV}-final
+S=${WORKDIR}/${MY_PN}-${PV}
+DESCRIPTION="An IRC Client"
+HOMEPAGE="http://www.bitchx.ca/"
+SRC_URI="http://bitchx.ca/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ipv6 ssl"
+
+DEPEND="sys-libs/ncurses
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e "s/#undef LATIN1/#define LATIN1 ON/;" \
+ include/config.h
+
+ epatch ${FILESDIR}/${P}-build.patch
+ # Do epatch_user since even BX-1.2 has A LOT of patches and A LOT
+ # of behaviour controlled by manually editing config.h
+ epatch_user
+}
+
+src_configure() {
+ # Disable CDROM or else it will take over your CDROM drive
+ local myconf="--disable-cdrom --disable-sound --without-gtk"
+
+ econf \
+ --with-plugins \
+ $(use_with ssl) \
+ $(use_enable ipv6) \
+ ${myconf}
+}
+
+src_compile() {
+ replace-flags -O[3-9] -O2
+ append-flags -fno-strict-aliasing
+
+ emake
+ emake -C contrib vh1
+}
+
+src_install () {
+ einstall
+ dobin contrib/vh1
+ dosym BitchX /usr/bin/bitchx
+
+ cd "${S}"
+ dodoc bugs Changelog README* IPv6-support
+
+ cd "${S}"/doc
+ insinto /usr/include/X11/bitmaps
+ doins BitchX.xpm
+ dodoc *.txt */*.txt
+ dohtml -r *
+
+ cd "${S}"/dll
+ docinto plugins
+ dodoc nap/README.nap
+ newdoc acro/README README.acro
+ newdoc arcfour/README README.arcfour
+ newdoc blowfish/README README.blowfish
+ newdoc qbx/README README.qbx
+}
diff --git a/net-irc/bitchx/files/bitchx-1.2-build.patch b/net-irc/bitchx/files/bitchx-1.2-build.patch
new file mode 100644
index 000000000000..3335bde25b7b
--- /dev/null
+++ b/net-irc/bitchx/files/bitchx-1.2-build.patch
@@ -0,0 +1,65 @@
+commit 4c0f8ad621f892ca92d7f2312cc7e0f01798346d
+Author: Jeff Horelick <jdhore@gentoo.org>
+Date: Tue Jan 1 19:16:46 2013 -0500
+
+ dll/aim/Makefile.in: Fix parallel building
+
+ dll/hint/Makefile.in: BitchX.hints is a data file, not a plugin
+
+ dll/Makefile.in: Let portage do the stripping
+
+ Makefile.in: Let portage do the compression
+
+diff --git a/Makefile.in b/Makefile.in
+index af85e87..1195894 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -284,8 +284,6 @@ installman: installdirs
+ done; \
+ fi; \
+ )
+- (find $(DESTDIR)$(mandir)/man1/BitchX.1 -type f ! -name '*.bz2' ! -name '*.gz' | \
+- (xargs bzip2 -9f || xargs gzip -9f) || :) 2>/dev/null
+
+ installdirs:
+ umask 022 && $(top_srcdir)/mkinstalldirs $(DESTDIR)$(bindir) $(DESTDIR)$(IRCLIB) \
+diff --git a/dll/Makefile.in b/dll/Makefile.in
+index 7034394..3ef4e46 100644
+--- a/dll/Makefile.in
++++ b/dll/Makefile.in
+@@ -201,12 +201,6 @@ install: all
+ || case "$$makeflags" in *=*) exit 1;; *k*) ;; *) exit 1;; esac; \
+ done; \
+ )
+- @( \
+- if test x"$(PLUGINS)" != x""; then \
+- strip --strip-unneeded $(DESTDIR)$(PLUGINDIR)/*$(SHLIB_SUFFIX) || :; \
+- echo Your plugins [$(PLUGINS)] are now located in $(PLUGINDIR);\
+- fi; \
+- )
+
+ install_local: all
+ $(INSTALL) -d $(local_dir)/.BitchX/plugins
+diff --git a/dll/aim/Makefile.in b/dll/aim/Makefile.in
+index 52f8afb..c77ca8f 100644
+--- a/dll/aim/Makefile.in
++++ b/dll/aim/Makefile.in
+@@ -179,7 +179,7 @@ cmd.o: $(srcdir)/cmd.c
+ aim.o: $(srcdir)/aim.c
+ $(CC) $(AIMDEFS) $(SHLIB_CFLAGS) $(CFLAGS) -c $(srcdir)/aim.c
+
+-aim$(SHLIB_SUFFIX): $(OBJS)
++aim$(SHLIB_SUFFIX): $(OBJS) toc
+ $(SHLIB_LD) $(OBJS) $(SHLIB_CFLAGS) -o aim$(SHLIB_SUFFIX) -Ltoc -ltoc
+
+ dummy:
+diff --git a/dll/hint/Makefile.in b/dll/hint/Makefile.in
+index 83b4fd9..00d7059 100644
+--- a/dll/hint/Makefile.in
++++ b/dll/hint/Makefile.in
+@@ -173,4 +173,4 @@ distclean: clean
+
+ install:
+ $(INSTALL) $(PLUGIN_NAME)$(SHLIB_SUFFIX) $(DESTDIR)$(PLUGINDIR)
+- $(INSTALL) $(srcdir)/BitchX.hints $(DESTDIR)$(PLUGINDIR)/@HINT_FILE@
++ $(INSTALL_DATA) $(srcdir)/BitchX.hints $(DESTDIR)$(PLUGINDIR)/@HINT_FILE@