summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-04-03 21:41:12 +0000
committerSven Wegener <swegener@gentoo.org>2005-04-03 21:41:12 +0000
commit98a94b9336471cd89ede0114547e79a204998e29 (patch)
tree0758b0279935fafa79b273f4b6299c169df7cd8f /net-irc/bnc
parentFix arts detection (#62304). Cleanup. (diff)
downloadgentoo-2-98a94b9336471cd89ede0114547e79a204998e29.tar.gz
gentoo-2-98a94b9336471cd89ede0114547e79a204998e29.tar.bz2
gentoo-2-98a94b9336471cd89ede0114547e79a204998e29.zip
Two revision bumps. One for distributing the fix for bug #87463. And the other one for testing the ssl USE flag.
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-irc/bnc')
-rw-r--r--net-irc/bnc/ChangeLog10
-rw-r--r--net-irc/bnc/bnc-2.9.3-r1.ebuild (renamed from net-irc/bnc/bnc-2.9.3.ebuild)9
-rw-r--r--net-irc/bnc/bnc-2.9.3-r2.ebuild41
-rw-r--r--net-irc/bnc/files/digest-bnc-2.9.3-r1 (renamed from net-irc/bnc/files/digest-bnc-2.9.3)0
-rw-r--r--net-irc/bnc/files/digest-bnc-2.9.3-r21
5 files changed, 58 insertions, 3 deletions
diff --git a/net-irc/bnc/ChangeLog b/net-irc/bnc/ChangeLog
index 0b1fcda2d363..6c026946896a 100644
--- a/net-irc/bnc/ChangeLog
+++ b/net-irc/bnc/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-irc/bnc
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bnc/ChangeLog,v 1.22 2005/01/29 04:04:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bnc/ChangeLog,v 1.23 2005/04/03 21:41:12 swegener Exp $
+
+*bnc-2.9.3-r2 (03 Apr 2005)
+*bnc-2.9.3-r1 (03 Apr 2005)
+
+ 03 Apr 2005; Sven Wegener <swegener@gentoo.org> -bnc-2.9.3.ebuild,
+ +bnc-2.9.3-r1.ebuild, +bnc-2.9.3-r2.ebuild:
+ Two revision bumps. One for distributing the fix for bug #87463. And the
+ other one for testing the ssl USE flag.
*bnc-2.9.3 (28 Jan 2005)
diff --git a/net-irc/bnc/bnc-2.9.3.ebuild b/net-irc/bnc/bnc-2.9.3-r1.ebuild
index 5daa66330c96..48b76a5f1c92 100644
--- a/net-irc/bnc/bnc-2.9.3.ebuild
+++ b/net-irc/bnc/bnc-2.9.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bnc/bnc-2.9.3.ebuild,v 1.1 2005/01/29 04:04:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bnc/bnc-2.9.3-r1.ebuild,v 1.1 2005/04/03 21:41:12 swegener Exp $
inherit eutils
@@ -18,6 +18,11 @@ DEPEND="virtual/libc"
S=${WORKDIR}/${MY_P}
+src_unpack() {
+ unpack ${A}
+ sed -i -e s:./mkpasswd:/usr/bin/bncmkpasswd: ${S}/bncsetup || die
+}
+
src_compile() {
econf || die "econf failed"
emake CFLAGS="${CFLAGS}" || die "emake failed"
@@ -26,7 +31,7 @@ src_compile() {
src_install() {
dobin bnc bncchk bncsetup bncmkpasswd || die "dobin failed"
- dodoc CHANGES README example.conf motd
+ dodoc ChangeLog README example.conf motd
}
pkg_postinst() {
diff --git a/net-irc/bnc/bnc-2.9.3-r2.ebuild b/net-irc/bnc/bnc-2.9.3-r2.ebuild
new file mode 100644
index 000000000000..35581f7743d8
--- /dev/null
+++ b/net-irc/bnc/bnc-2.9.3-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bnc/bnc-2.9.3-r2.ebuild,v 1.1 2005/04/03 21:41:12 swegener Exp $
+
+inherit eutils
+
+MY_P=${P/-/}
+DESCRIPTION="BNC (BouNCe) is used as a gateway to an IRC Server"
+HOMEPAGE="http://gotbnc.com/"
+SRC_URI="http://gotbnc.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~sparc ~x86"
+IUSE="ssl"
+
+DEPEND="virtual/libc
+ ssl? ( dev-libs/openssl )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e s:./mkpasswd:/usr/bin/bncmkpasswd: ${S}/bncsetup || die
+}
+
+src_compile() {
+ econf $(use_with ssl) || die "econf failed"
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+ mv mkpasswd bncmkpasswd
+}
+
+src_install() {
+ dobin bnc bncchk bncsetup bncmkpasswd || die "dobin failed"
+ dodoc ChangeLog README example.conf motd
+}
+
+pkg_postinst() {
+ einfo "You can find an example motd/conf file here:"
+ einfo " /usr/share/doc/${PF}/{example.conf,motd}.gz"
+}
diff --git a/net-irc/bnc/files/digest-bnc-2.9.3 b/net-irc/bnc/files/digest-bnc-2.9.3-r1
index 268bc6745273..268bc6745273 100644
--- a/net-irc/bnc/files/digest-bnc-2.9.3
+++ b/net-irc/bnc/files/digest-bnc-2.9.3-r1
diff --git a/net-irc/bnc/files/digest-bnc-2.9.3-r2 b/net-irc/bnc/files/digest-bnc-2.9.3-r2
new file mode 100644
index 000000000000..268bc6745273
--- /dev/null
+++ b/net-irc/bnc/files/digest-bnc-2.9.3-r2
@@ -0,0 +1 @@
+MD5 5012f3eb112f0fda545b1aaf66a06150 bnc2.9.3.tar.gz 75251