summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-02-19 17:02:09 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-02-19 17:02:09 +0000
commitec4963564560ac1dc2942c73bead5ec4cf4f7b50 (patch)
treeda53ea648a443ec302f37d242bdf68bc47246c5a /net-irc/bobotpp/bobotpp-2.2.2.ebuild
parentStable on ppc wrt bug 152483 (diff)
downloadgentoo-2-ec4963564560ac1dc2942c73bead5ec4cf4f7b50.tar.gz
gentoo-2-ec4963564560ac1dc2942c73bead5ec4cf4f7b50.tar.bz2
gentoo-2-ec4963564560ac1dc2942c73bead5ec4cf4f7b50.zip
Version bump, drop old and regenerate digest in Manifest2 format
(Portage version: 2.1.2-r9)
Diffstat (limited to 'net-irc/bobotpp/bobotpp-2.2.2.ebuild')
-rw-r--r--net-irc/bobotpp/bobotpp-2.2.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-irc/bobotpp/bobotpp-2.2.2.ebuild b/net-irc/bobotpp/bobotpp-2.2.2.ebuild
new file mode 100644
index 000000000000..fea7ed345d4f
--- /dev/null
+++ b/net-irc/bobotpp/bobotpp-2.2.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bobotpp/bobotpp-2.2.2.ebuild,v 1.1 2007/02/19 17:02:09 armin76 Exp $
+
+DESCRIPTION="A flexible IRC bot scriptable in scheme"
+HOMEPAGE="http://unknownlamer.org/code/bobot.html"
+SRC_URI="http://savannah.nongnu.org/download/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="guile"
+
+DEPEND="guile? ( dev-scheme/guile )"
+
+src_compile() {
+ econf $(use_enable guile scripting) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+
+ dosym bobot++.info /usr/share/info/bobotpp.info || die "dosym failed"
+
+ dodoc AUTHORS ChangeLog NEWS README SCRIPTING TODO || die "dodoc failed"
+ dohtml doc/index.html || die "dohtml failed"
+
+ docinto example-config
+ dodoc examples/{bot.*,scripts.load} || die "dodoc failed"
+
+ docinto example-scripts
+ dodoc scripts/{boulet,country,eval,hello,log.scm,tamere,uname,uptime} || die "dodoc failed"
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You can find a sample configuration file set in"
+ einfo "/usr/share/doc/${PF}/example-config"
+ einfo
+}