summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2008-06-22 20:30:22 +0000
committerTony Vroon <chainsaw@gentoo.org>2008-06-22 20:30:22 +0000
commit72490e54acc301361f0490a766385525a3616ec7 (patch)
tree13554e81bbf3efc0db7b7eee9cdbd2bfb4d0b02c /net-irc/conspire
parentMove xfce4-icon-theme from xfce-extra to x11-themes. (diff)
downloadgentoo-2-72490e54acc301361f0490a766385525a3616ec7.tar.gz
gentoo-2-72490e54acc301361f0490a766385525a3616ec7.tar.bz2
gentoo-2-72490e54acc301361f0490a766385525a3616ec7.zip
Version bump. This beta boasts a shiny new treeview and STARTTLS support.
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-rc7-dirty x86_64)
Diffstat (limited to 'net-irc/conspire')
-rw-r--r--net-irc/conspire/ChangeLog7
-rw-r--r--net-irc/conspire/conspire-0.20_beta2.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/net-irc/conspire/ChangeLog b/net-irc/conspire/ChangeLog
index f201427b9cfb..650e7daffb96 100644
--- a/net-irc/conspire/ChangeLog
+++ b/net-irc/conspire/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/conspire
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/conspire/ChangeLog,v 1.5 2008/06/08 03:50:11 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/conspire/ChangeLog,v 1.6 2008/06/22 20:30:22 chainsaw Exp $
+
+*conspire-0.20_beta2 (22 Jun 2008)
+
+ 22 Jun 2008; <chainsaw@gentoo.org> +conspire-0.20_beta2.ebuild:
+ Version bump. This beta boasts a shiny new treeview and STARTTLS support.
*conspire-0.20_beta1 (08 Jun 2008)
diff --git a/net-irc/conspire/conspire-0.20_beta2.ebuild b/net-irc/conspire/conspire-0.20_beta2.ebuild
new file mode 100644
index 000000000000..e31450459066
--- /dev/null
+++ b/net-irc/conspire/conspire-0.20_beta2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/conspire/conspire-0.20_beta2.ebuild,v 1.1 2008/06/22 20:30:22 chainsaw Exp $
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="A high quality IRC client which uses a multitude of interfaces"
+HOMEPAGE="http://www.nenolod.net/conspire/"
+SRC_URI="http://distfiles.atheme.org/${MY_P}.tbz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~sparc ~x86"
+IUSE="python gnutls ipv6 nls mmx socks5 dbus"
+DEPEND="nls? ( dev-util/intltool )"
+RDEPEND=">=dev-libs/libmowgli-0.6.0
+ >=x11-libs/gtk+-2.10
+ >=dev-libs/glib-2.14
+ x11-libs/libsexy
+ dbus? ( >=dev-libs/dbus-glib-0.60 )
+ python? ( >=dev-lang/python-2.2 )"
+
+src_compile() {
+ econf \
+ $(use_enable socks5 socks) \
+ $(use_enable ipv6) \
+ $(use_enable gnutls) \
+ $(use_enable python) \
+ $(use_enable mmx) \
+ $(use_enable nls) \
+ $(use_enable dbus) \
+ --enable-spell=libsexy \
+ --enable-regex \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc NEWS TODO
+}