summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Phillip Brink <binki@gentoo.org>2011-12-02 01:14:31 +0000
committerNathan Phillip Brink <binki@gentoo.org>2011-12-02 01:14:31 +0000
commit467672330b2857c73ebe3644d938e32f56ed5c4d (patch)
tree7df38e40506b0641fced44c2d3b4825b594c1d84 /net-irc/irc-client
parentVersion bump. (diff)
downloadgentoo-2-467672330b2857c73ebe3644d938e32f56ed5c4d.tar.gz
gentoo-2-467672330b2857c73ebe3644d938e32f56ed5c4d.tar.bz2
gentoo-2-467672330b2857c73ebe3644d938e32f56ed5c4d.zip
Add blocker against net-irc/ircii for bug #247987. Add missing `|| die', misc shell style change (remove backticks). Fix compilation error caused by disagreement between ${CHOST} and ./config.guess with patch.
(Portage version: 2.2.0_alpha78-r1/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/irc-client')
-rw-r--r--net-irc/irc-client/ChangeLog10
-rw-r--r--net-irc/irc-client/files/irc-client-2.10.3_p7-amd64-chost.patch29
-rw-r--r--net-irc/irc-client/irc-client-2.10.3_p7.ebuild20
3 files changed, 53 insertions, 6 deletions
diff --git a/net-irc/irc-client/ChangeLog b/net-irc/irc-client/ChangeLog
index 90bfac60f1b8..450849d65d70 100644
--- a/net-irc/irc-client/ChangeLog
+++ b/net-irc/irc-client/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/irc-client
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/irc-client/ChangeLog,v 1.14 2009/09/23 18:44:17 patrick Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irc-client/ChangeLog,v 1.15 2011/12/02 01:14:31 binki Exp $
+
+ 02 Dec 2011; Nathan Phillip Brink <binki@gentoo.org>
+ irc-client-2.10.3_p7.ebuild, +files/irc-client-2.10.3_p7-amd64-chost.patch:
+ Add blocker against net-irc/ircii for bug #247987. Add missing `|| die', misc
+ shell style change (remove backticks). Fix compilation error caused by
+ disagreement between ${CHOST} and ./config.guess with patch.
23 Sep 2009; Patrick Lauer <patrick@gentoo.org>
irc-client-2.10.3_p7.ebuild:
diff --git a/net-irc/irc-client/files/irc-client-2.10.3_p7-amd64-chost.patch b/net-irc/irc-client/files/irc-client-2.10.3_p7-amd64-chost.patch
new file mode 100644
index 000000000000..7761a3e5e76d
--- /dev/null
+++ b/net-irc/irc-client/files/irc-client-2.10.3_p7-amd64-chost.patch
@@ -0,0 +1,29 @@
+From: Nathan Phillip Brink <binki@gentoo.org>
+Subject: Do not ignore the --host argument passed to the fake ./configure.
+
+--- a/configure
++++ b/configure
+@@ -10,6 +10,7 @@
+ -version | --version | --versio | --versi | --vers)
+ quick_fwd=yes
+ break ;;
++ --host=*)
++ rev=$(expr "${arg}" : '[^=]*=\(.*\)')
++ ;;
+- *)
+- break ;;
+ esac
+@@ -18,8 +21,10 @@
+ then
+ support/configure $*
+ else
+- echo "retrieving the system name, type and OS release..."
+- rev=`support/config.guess`
++ if ! test "${rev}"; then
++ echo "retrieving the system name, type and OS release..."
++ rev=`support/config.guess`
++ fi
+ if test "${rev}" # test for no output
+ then
+ echo " your system seems to be ${rev}."
+
diff --git a/net-irc/irc-client/irc-client-2.10.3_p7.ebuild b/net-irc/irc-client/irc-client-2.10.3_p7.ebuild
index 0ae322839513..b600e0fcd0c2 100644
--- a/net-irc/irc-client/irc-client-2.10.3_p7.ebuild
+++ b/net-irc/irc-client/irc-client-2.10.3_p7.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/irc-client/irc-client-2.10.3_p7.ebuild,v 1.6 2009/09/23 18:44:17 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irc-client/irc-client-2.10.3_p7.ebuild,v 1.7 2011/12/02 01:14:31 binki Exp $
+
+inherit eutils
MY_P=irc${PV/_/}
DESCRIPTION="A simplistic RFC compliant IRC client"
@@ -14,12 +16,22 @@ IUSE="ipv6"
DEPEND="sys-libs/ncurses
sys-libs/zlib"
+# This and irc-client both install /usr/bin/irc #247987
+RDEPEND="${DEPEND}
+ !net-irc/irc-client"
S=${WORKDIR}/${MY_P}
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}" || die
+ epatch "${FILESDIR}"/${P}-amd64-chost.patch
+}
+
src_compile () {
econf \
- `use_with ipv6 ip6` \
+ $(use_with ipv6 ip6) \
--sysconfdir=/etc/ircd \
--localstatedir=/var/run/ircd \
|| die "econf failed"
@@ -31,5 +43,5 @@ src_install() {
prefix=${D}/usr \
client_man_dir=${D}/usr/share/man/man1 \
install-client || die "client installed failed"
- dodoc doc/Etiquette doc/alt-irc-faq doc/rfc*
+ dodoc doc/Etiquette doc/alt-irc-faq doc/rfc* || die
}