summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-03-24 15:44:46 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-03-24 15:44:46 +0000
commit4892f2967783c0769eda64457146a286a71f511e (patch)
treef82f5b309274047859ec2cf2412bf30cd6a7913b /net-irc
parentAdd ~ia64 (diff)
downloadgentoo-2-4892f2967783c0769eda64457146a286a71f511e.tar.gz
gentoo-2-4892f2967783c0769eda64457146a286a71f511e.tar.bz2
gentoo-2-4892f2967783c0769eda64457146a286a71f511e.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/ngircd/ChangeLog7
-rw-r--r--net-irc/ngircd/ngircd-0.11.1.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/net-irc/ngircd/ChangeLog b/net-irc/ngircd/ChangeLog
index 34f9da0e96f9..89c98092a7a0 100644
--- a/net-irc/ngircd/ChangeLog
+++ b/net-irc/ngircd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/ngircd
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/ngircd/ChangeLog,v 1.39 2008/02/26 18:48:57 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ngircd/ChangeLog,v 1.40 2008/03/24 15:44:46 armin76 Exp $
+
+*ngircd-0.11.1 (24 Mar 2008)
+
+ 24 Mar 2008; Raúl Porcel <armin76@gentoo.org> +ngircd-0.11.1.ebuild:
+ Version bump
26 Feb 2008; nixnut <nixnut@gentoo.org> ngircd-0.11.0.ebuild:
Stable on ppc wrt bug 211388
diff --git a/net-irc/ngircd/ngircd-0.11.1.ebuild b/net-irc/ngircd/ngircd-0.11.1.ebuild
new file mode 100644
index 000000000000..c80104fcd5de
--- /dev/null
+++ b/net-irc/ngircd/ngircd-0.11.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ngircd/ngircd-0.11.1.ebuild,v 1.1 2008/03/24 15:44:46 armin76 Exp $
+
+inherit eutils
+
+DESCRIPTION="A IRC server written from scratch."
+HOMEPAGE="http://ngircd.barton.de/"
+SRC_URI="ftp://ftp.berlios.de/${PN}/${P}.tar.gz
+ ftp://ngircd.barton.de/pub//${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="zlib tcpd debug ident"
+RESTRICT="test"
+
+DEPEND="virtual/libc
+ zlib? ( sys-libs/zlib )
+ ident? ( net-libs/libident )
+ tcpd? ( sys-apps/tcp-wrappers )
+ >=sys-apps/sed-4"
+
+src_compile() {
+ econf \
+ --sysconfdir=/etc/ngircd \
+ $(use_with zlib) \
+ $(use_with tcpd tcp-wrappers) \
+ $(use_with ident ) \
+ $(use_enable debug) \
+ $(use_enable debug sniffer) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ sed -i \
+ -e "s:/usr/local/etc/ngircd.motd:/etc/ngircd/ngircd.motd:" \
+ -e "s:;ServerUID = 65534:ServerUID = ngircd:" \
+ -e "s:;ServerGID = 65534:ServerGID = nogroup:" \
+ doc/sample-ngircd.conf
+
+ make \
+ DESTDIR="${D}" \
+ docdir=/usr/share/doc/${PF} \
+ install || die "make install failed"
+
+ newinitd "${FILESDIR}"/ngircd.init.d ngircd
+}
+
+pkg_postinst() {
+ enewuser ngircd
+ chown ngircd "${ROOT}"/etc/ngircd/ngircd.conf
+}