summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2009-01-21 08:39:39 +0000
committerMarkus Ullmann <jokey@gentoo.org>2009-01-21 08:39:39 +0000
commit8f71fef83f1a6981d11f0492be9ab7e8382e27f8 (patch)
tree92d15fe6e67763fc8c7af458adebf0213c6233cd /net-irc
parentAppend fno-stack-protector on all ARCHes for CXX only. Bugs 253639, 253737. (diff)
downloadgentoo-2-8f71fef83f1a6981d11f0492be9ab7e8382e27f8.tar.gz
gentoo-2-8f71fef83f1a6981d11f0492be9ab7e8382e27f8.tar.bz2
gentoo-2-8f71fef83f1a6981d11f0492be9ab7e8382e27f8.zip
Fix monolithic flag to be enabled only when actually using it and drop old
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/quassel/ChangeLog9
-rw-r--r--net-irc/quassel/metadata.xml7
-rw-r--r--net-irc/quassel/quassel-0.3.1-r1.ebuild120
-rw-r--r--net-irc/quassel/quassel-0.3.1-r4.ebuild (renamed from net-irc/quassel/quassel-0.3.1-r3.ebuild)14
-rw-r--r--net-irc/quassel/quassel-0.3.1.ebuild125
-rw-r--r--net-irc/quassel/quassel-9999.ebuild5
6 files changed, 21 insertions, 259 deletions
diff --git a/net-irc/quassel/ChangeLog b/net-irc/quassel/ChangeLog
index 8b236cf307b8..979f83a36346 100644
--- a/net-irc/quassel/ChangeLog
+++ b/net-irc/quassel/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-irc/quassel
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/ChangeLog,v 1.41 2009/01/18 19:44:40 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/ChangeLog,v 1.42 2009/01/21 08:39:39 jokey Exp $
+
+*quassel-0.3.1-r4 (21 Jan 2009)
+
+ 21 Jan 2009; <jokey@gentoo.org> metadata.xml, -quassel-0.3.1.ebuild,
+ -quassel-0.3.1-r1.ebuild, -quassel-0.3.1-r3.ebuild,
+ +quassel-0.3.1-r4.ebuild, quassel-9999.ebuild:
+ Fix monolithic flag to be enabled only when actually using it and drop old
*quassel-0.3.1-r3 (18 Jan 2009)
diff --git a/net-irc/quassel/metadata.xml b/net-irc/quassel/metadata.xml
index c334815f58db..147c175d516c 100644
--- a/net-irc/quassel/metadata.xml
+++ b/net-irc/quassel/metadata.xml
@@ -11,9 +11,10 @@
</maintainer>
<use>
<flag name="monolithic">
- Build monolitic client. Only useful if one don't want to use
- quassels client/server model. The server and X flags are probably
- not needed but it is possible to enable them tooy.
+ Build Standalone client with integrated core, no external
+ quasselcore needed. Only useful if one don't want to use quassels
+ client/server model. The server and X flags are not needed in this
+ case but it is possible to enable them too.
</flag>
<flag name="phonon">
Build client with phonon backend support. This enables sound
diff --git a/net-irc/quassel/quassel-0.3.1-r1.ebuild b/net-irc/quassel/quassel-0.3.1-r1.ebuild
deleted file mode 100644
index 78f20e7907a9..000000000000
--- a/net-irc/quassel/quassel-0.3.1-r1.ebuild
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-0.3.1-r1.ebuild,v 1.1 2008/11/28 21:11:49 patrick Exp $
-
-EAPI=1
-
-inherit cmake-utils eutils
-
-MY_P="${P/_/-}"
-
-DESCRIPTION="Core/client IRC client."
-HOMEPAGE="http://quassel-irc.org/"
-SRC_URI="http://quassel-irc.org/pub/${MY_P}.tar.bz2"
-
-LICENSE="GPL-3"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-IUSE="+dbus debug +server +ssl +X"
-
-LANGS="nb_NO da de fr ru"
-for l in ${LANGS}; do
- IUSE="${IUSE} linguas_${l}"
-done
-
-RDEPEND="x11-libs/qt-core:4
- server? (
- x11-libs/qt-sql:4
- x11-libs/qt-script:4
- )
- X? (
- x11-libs/qt-gui:4
- x11-libs/qt-webkit:4 )
- dbus? ( x11-libs/qt-dbus:4 )
- ssl? ( dev-libs/openssl )"
-DEPEND="${RDEPEND}
- >=dev-util/cmake-2.6"
-
-DOCS="AUTHORS ChangeLog README"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- if ! use server && ! use X ; then
- eerror "You have to build one or both of quassel client or server."
- die "Both server and X USE flags unset."
- fi
-
- if use server && ! built_with_use x11-libs/qt-sql sqlite ; then
- eerror "Please rebuild x11-libs/qt-sql:4 with sqlite USE flag enabled."
- die "Missing sqlite support in x11-libs/qt-sql:4"
- fi
-
- if use ssl && ! built_with_use x11-libs/qt-core ssl ; then
- eerror "Please rebuild x11-libs/qt-core:4 with ssl USE flag enabled."
- die "Missing ssl support in x11-libs/qt-core:4"
- fi
-}
-
-src_compile() {
-# Comment this out and invoke _common_configure_code, cmake and cmake-utils_src_make
-# manually until cmake-utils.eclass supports space separated strings as arguments for cmake
-# options. Until now multiple languages are not passed to -DLINGUAS and only the first
-# language is considered.
-#
-# local mycmakeargs=(
-# "$(cmake-utils_use_want server CORE)"
-# "$(cmake-utils_use_want X QTCLIENT)"
-# "$(cmake-utils_use_with dbus DBUS)"
-# "$(cmake-utils_use_with ssl OPENSSL)"
-# "-DLINGUAS=\"${LINGUAS}\""
-# '-DWANT_MONO=OFF' )
-#
-# cmake-utils_src_compile
-
- _common_configure_code
-
- cmake -C "${TMPDIR}/gentoo_common_config.cmake" \
- $(cmake-utils_use_want server CORE) $(cmake-utils_use_want X QTCLIENT) \
- $(cmake-utils_use_with X WEBKIT) $(cmake-utils_use_with dbus DBUS) \
- $(cmake-utils_use_with ssl OPENSSL) -DLINGUAS="${LINGUAS}" \
- -DOXYGEN_ICONS=Builtin -DLINGUAS="${LINGUAS}" -DWANT_MONO=OFF \
- "${S}" || die "Cmake failed"
-
- cmake-utils_src_make
-}
-
-src_install() {
- cmake-utils_src_install
- if use server ; then
- newinitd "${FILESDIR}"/quasselcore.init quasselcore || die "newinitd failed"
- newconfd "${FILESDIR}"/quasselcore.conf quasselcore || die "newconfd failed"
-
- insinto /usr/share/doc/${PF}
- doins "${S}"/scripts/manageusers.py || die "installing manageusers.py failed"
- fi
-}
-
-pkg_postinst() {
- if use server ; then
- ewarn
- ewarn "In order to use the quassel init script you must set the"
- ewarn "QUASSEL_USER variable in /etc/conf.d/quasselcore to your username."
- ewarn "Note: This is the user who runs the quasselcore and is independent"
- ewarn "from the users you set up in the quasselclient."
- elog
- elog "Adding more than one user or changing username/password is not"
- elog "possible via the quasselclient yet. If you need to do these things"
- elog "you have to use the manageusers.py script, which has been installed in"
- elog "/usr/share/doc/${PF}".
- elog "Please make sure that the quasselcore is stopped before adding more users."
- fi
-
- if use server && use ssl ; then
- elog
- elog "To enable SSL support for client/core connections the quasselcore needs"
- elog "a PEM certificate which needs to be stored in ~/.quassel/quasselCert.pem."
- elog "To create the certificate use the following command:"
- elog "openssl req -x509 -nodes -days 365 -newkey rsa:1024 -keyout ~/.quassel/quasselCert.pem -out ~/.quassel/quasselCert.pem"
- fi
-}
diff --git a/net-irc/quassel/quassel-0.3.1-r3.ebuild b/net-irc/quassel/quassel-0.3.1-r4.ebuild
index ffb57a99d96c..0221fb17bc3e 100644
--- a/net-irc/quassel/quassel-0.3.1-r3.ebuild
+++ b/net-irc/quassel/quassel-0.3.1-r4.ebuild
@@ -1,19 +1,19 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-0.3.1-r3.ebuild,v 1.1 2009/01/18 19:44:40 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-0.3.1-r4.ebuild,v 1.1 2009/01/21 08:39:39 jokey Exp $
-EAPI=2
+EAPI="2"
inherit cmake-utils eutils
-DESCRIPTION="Core/client IRC client."
+DESCRIPTION="Qt4/KDE4 IRC client suppporting a remote daemon for 24/7 connectivity."
HOMEPAGE="http://quassel-irc.org/"
SRC_URI="http://quassel-irc.org/pub/${P}.tar.bz2"
LICENSE="GPL-3"
KEYWORDS="~amd64 ~x86"
SLOT="0"
-IUSE="+dbus debug monolithic +server +ssl +X"
+IUSE="dbus debug monolithic +server +ssl +X"
LANGS="nb_NO da de fr ru"
for l in ${LANGS}; do
@@ -57,15 +57,14 @@ pkg_setup() {
fi
}
-src_compile() {
+src_configure() {
# Comment this out and invoke _common_configure_code and cmake manually until cmake-utils.eclass
# supports space separated strings as arguments for cmake options or quassel changes the
# separator. Until now multiple languages are not passed to -DLINGUAS and only the first
# language is considered.
-
local mycmakeargs="$(cmake-utils_use_want server CORE)
$(cmake-utils_use_want X QTCLIENT)
- $(cmake-utils_use_want X MONO)
+ $(cmake-utils_use_want monolithic MONO)
$(cmake-utils_use_with X WEBKIT)
$(cmake-utils_use_with dbus DBUS)
$(cmake-utils_use_with ssl OPENSSL)
@@ -85,6 +84,7 @@ src_compile() {
src_install() {
cmake-utils_src_install
+
if use server ; then
newinitd "${FILESDIR}"/quasselcore.init quasselcore || die "newinitd failed"
newconfd "${FILESDIR}"/quasselcore.conf quasselcore || die "newconfd failed"
diff --git a/net-irc/quassel/quassel-0.3.1.ebuild b/net-irc/quassel/quassel-0.3.1.ebuild
deleted file mode 100644
index c56fed5db81d..000000000000
--- a/net-irc/quassel/quassel-0.3.1.ebuild
+++ /dev/null
@@ -1,125 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-0.3.1.ebuild,v 1.1 2008/11/27 18:34:50 patrick Exp $
-
-EAPI=1
-
-inherit cmake-utils eutils
-
-MY_P="${P/_/-}"
-
-DESCRIPTION="Core/client IRC client."
-HOMEPAGE="http://quassel-irc.org/"
-SRC_URI="http://quassel-irc.org/pub/${MY_P}.tar.bz2"
-
-LICENSE="GPL-3"
-KEYWORDS="~amd64 ~sparc ~x86"
-SLOT="0"
-IUSE="+dbus debug +server +ssl +X"
-
-LANGS="nb_NO da de fr"
-for l in ${LANGS}; do
- IUSE="${IUSE} linguas_${l}"
-done
-
-RDEPEND="x11-libs/qt-core:4
- server? (
- x11-libs/qt-sql:4
- x11-libs/qt-script:4
- )
- X? ( x11-libs/qt-gui:4 )
- dbus? ( x11-libs/qt-dbus )
- ssl? ( dev-libs/openssl )"
-DEPEND="${RDEPEND}
- >=dev-util/cmake-2.4.7"
-
-DOCS="AUTHORS ChangeLog README README.Qtopia"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- if ! use server && ! use X ; then
- eerror "You have to build one or both of quassel client or server."
- die "Both server and X USE flags unset."
- fi
-
- if use server && ! built_with_use x11-libs/qt-sql sqlite ; then
- eerror "Please rebuild x11-libs/qt-sql:4 with sqlite USE flag enabled."
- die "Missing sqlite support in x11-libs/qt-sql:4"
- fi
-
- if use ssl && ! built_with_use x11-libs/qt-core ssl ; then
- eerror "Please rebuild x11-libs/qt-core:4 with ssl USE flag enabled."
- die "Missing ssl support in x11-libs/qt-core:4"
- fi
-}
-
-src_compile() {
-# Comment this out and invoke _common_configure_code, cmake and cmake-utils_src_make
-# manually until cmake-utils.eclass supports space separated strings as arguments for cmake
-# options. Until now multiple languages are not passed to -DLINGUAS and only the first
-# language is considered.
-#
-# local mycmakeargs=(
-# "$(cmake-utils_use_want server CORE)"
-# "$(cmake-utils_use_want X QTCLIENT)"
-# "$(cmake-utils_use_with dbus DBUS)"
-# "$(cmake-utils_use_with ssl OPENSSL)"
-# "-DLINGUAS=\"${LINGUAS}\""
-# '-DWANT_MONO=OFF' )
-#
-# cmake-utils_src_compile
-
- _common_configure_code
-
- cmake -C "${TMPDIR}/gentoo_common_config.cmake" \
- $(cmake-utils_use_want server CORE) $(cmake-utils_use_want X QTCLIENT) \
- $(cmake-utils_use_with dbus DBUS) $(cmake-utils_use_with ssl OPENSSL) \
- -DLINGUAS="${LINGUAS}" -DWANT_MONO=OFF \
- "${S}" || die "Cmake failed"
-
- cmake-utils_src_make
-}
-
-src_install() {
- cmake-utils_src_install
-
- # Only install the icons if the X client was installed
- if use X ; then
- insinto /usr/share/icons/hicolor
- # avoid the connected/ directory, get only the ${size}x${size}
- doins -r "${S}"/src/icons/quassel/*x* || die "installing quassel icons failed"
- fi
-
- if use server ; then
- newinitd "${FILESDIR}"/quasselcore.init quasselcore || die "newinitd failed"
- newconfd "${FILESDIR}"/quasselcore.conf quasselcore || die "newconfd failed"
-
- insinto /usr/share/doc/${PF}
- doins "${S}"/scripts/manageusers.py || die "installing manageusers.py failed"
- fi
-}
-
-pkg_postinst() {
- if use server ; then
- ewarn
- ewarn "In order to use the quassel init script you must set the"
- ewarn "QUASSEL_USER variable in /etc/conf.d/quasselcore to your username."
- ewarn "Note: This is the user who runs the quasselcore and is independent"
- ewarn "from the users you set up in the quasselclient."
- elog
- elog "Adding more than one user or changing username/password is not"
- elog "possible via the quasselclient yet. If you need to do these things"
- elog "you have to use the manageusers.py script, which has been installed in"
- elog "/usr/share/doc/${PF}".
- elog "Please make sure that the quasselcore is stopped before adding more users."
- fi
-
- if use server && use ssl ; then
- elog
- elog "To enable SSL support for client/core connections the quasselcore needs"
- elog "a PEM certificate which needs to be stored in ~/.quassel/quasselCert.pem."
- elog "To create the certificate use the following command:"
- elog "openssl req -x509 -nodes -days 365 -newkey rsa:1024 -keyout ~/.quassel/quasselCert.pem -out ~/.quassel/quasselCert.pem"
- fi
-}
diff --git a/net-irc/quassel/quassel-9999.ebuild b/net-irc/quassel/quassel-9999.ebuild
index d10293daa3e8..07d2291fcc41 100644
--- a/net-irc/quassel/quassel-9999.ebuild
+++ b/net-irc/quassel/quassel-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-9999.ebuild,v 1.16 2009/01/19 00:27:05 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-9999.ebuild,v 1.17 2009/01/21 08:39:39 jokey Exp $
EAPI="2"
@@ -9,7 +9,7 @@ inherit cmake-utils eutils git
EGIT_REPO_URI="git://git.quassel-irc.org/quassel.git"
EGIT_BRANCH="master"
-DESCRIPTION="Core/client IRC client."
+DESCRIPTION="Qt4/KDE4 IRC client suppporting a remote daemon for 24/7 connectivity."
HOMEPAGE="http://quassel-irc.org/"
LICENSE="GPL-3"
@@ -94,7 +94,6 @@ src_configure() {
${mycmakeargs} \
-DLINGUAS="${LINGUAS}" \
"${S}" || die "Cmake failed"
-
}
src_install() {