summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2009-09-21 00:07:34 +0000
committerJesus Rivero <neurogeek@gentoo.org>2009-09-21 00:07:34 +0000
commit9acb171b5984b0371df16b2875e9b4a9e2c95627 (patch)
tree6d30efdb43a09d56894b7a68d6f04d5b993c9916 /net-irc
parentpolicycoreutils: Update rlpkg for ext4 and btrfs. (diff)
downloadgentoo-2-9acb171b5984b0371df16b2875e9b4a9e2c95627.tar.gz
gentoo-2-9acb171b5984b0371df16b2875e9b4a9e2c95627.tar.bz2
gentoo-2-9acb171b5984b0371df16b2875e9b4a9e2c95627.zip
Added twisted USE flag, dev-python/twisted-names as DEP wrt bug #225657
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/supybot/ChangeLog8
-rw-r--r--net-irc/supybot/metadata.xml3
-rw-r--r--net-irc/supybot/supybot-0.83.4.1-r1.ebuild50
3 files changed, 60 insertions, 1 deletions
diff --git a/net-irc/supybot/ChangeLog b/net-irc/supybot/ChangeLog
index dc42672421c1..873b69c7adb5 100644
--- a/net-irc/supybot/ChangeLog
+++ b/net-irc/supybot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/supybot
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/supybot/ChangeLog,v 1.30 2009/08/05 21:19:00 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/supybot/ChangeLog,v 1.31 2009/09/21 00:07:34 neurogeek Exp $
+
+*supybot-0.83.4.1-r1 (21 Sep 2009)
+
+ 21 Sep 2009; Jesus Rivero <neurogeek@gentoo.org>
+ +supybot-0.83.4.1-r1.ebuild:
+ Added twisted USE flag, dev-python/twisted-names as DEP wrt bug #225657
05 Aug 2009; Markus Meier <maekke@gentoo.org> supybot-0.83.4.1.ebuild:
x86 stable, bug #279404
diff --git a/net-irc/supybot/metadata.xml b/net-irc/supybot/metadata.xml
index 301d2207cc29..cafe1d60a97e 100644
--- a/net-irc/supybot/metadata.xml
+++ b/net-irc/supybot/metadata.xml
@@ -2,4 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>python</herd>
+ <use>
+ <flag name="twisted">Allows supybot to use <pkg>dev-python/twisted</pkg> as driver</flag>
+ </use>
</pkgmetadata>
diff --git a/net-irc/supybot/supybot-0.83.4.1-r1.ebuild b/net-irc/supybot/supybot-0.83.4.1-r1.ebuild
new file mode 100644
index 000000000000..02d8888d311d
--- /dev/null
+++ b/net-irc/supybot/supybot-0.83.4.1-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/supybot/supybot-0.83.4.1-r1.ebuild,v 1.1 2009/09/21 00:07:34 neurogeek Exp $
+
+EAPI="2"
+NEED_PYTHON=2.4
+
+inherit distutils
+
+MY_P=${P/supybot/Supybot}
+MY_P=${MY_P/_rc/rc}
+
+DESCRIPTION="Python based extensible IRC infobot and channel bot"
+HOMEPAGE="http://supybot.sf.net/"
+SRC_URI="mirror://sourceforge/supybot/${MY_P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="sqlite twisted"
+
+DEPEND="twisted? ( >=dev-python/twisted-8.1.0[crypt]
+ >=dev-python/twisted-names-8.1.0 )
+ sqlite? ( <dev-python/pysqlite-1.1 )
+ !<net-irc/supybot-plugins-20060723-r1"
+
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="ACKS RELNOTES docs/*"
+
+src_install() {
+ distutils_src_install
+ doman docs/man/*
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ elog "Use supybot-wizard to create a configuration file"
+ use sqlite || \
+ elog "Some plugins may require emerge with USE=\"sqlite\" to work."
+ use twisted && \
+ elog "If you want to use Twisted as your supybot.driver, add it to your"
+ elog "config file: supybot.drivers.module = Twisted."
+ elog "You will need this for SSL connections"
+ use twisted || \
+ elog "To allow supybot to use Twisted as driver, re-emerge with"
+ elog "USE=\"twisted\" flag. You will need this for SSL Connections"
+}