summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2009-05-22 19:45:29 +0000
committerJim Ramsay <lack@gentoo.org>2009-05-22 19:45:29 +0000
commitc8ecfbce490dedbe43d00e474f9c06cf5049981d (patch)
treed7eddb9604d8a4fe07672ba0c9b4abf907554175 /net-irc
parentUpdate to version 2.5.9; finally respect flags (if apxs allows to..), have a ... (diff)
downloadgentoo-2-c8ecfbce490dedbe43d00e474f9c06cf5049981d.tar.gz
gentoo-2-c8ecfbce490dedbe43d00e474f9c06cf5049981d.tar.bz2
gentoo-2-c8ecfbce490dedbe43d00e474f9c06cf5049981d.zip
Fixed collision with net-irc/supybot-0.83.4
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/supybot-plugins/ChangeLog10
-rw-r--r--net-irc/supybot-plugins/supybot-plugins-20060723-r1.ebuild48
2 files changed, 56 insertions, 2 deletions
diff --git a/net-irc/supybot-plugins/ChangeLog b/net-irc/supybot-plugins/ChangeLog
index 6ad1eeae9299..85390fec5f70 100644
--- a/net-irc/supybot-plugins/ChangeLog
+++ b/net-irc/supybot-plugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/supybot-plugins
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/supybot-plugins/ChangeLog,v 1.2 2008/05/29 17:42:55 hawking Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/supybot-plugins/ChangeLog,v 1.3 2009/05/22 19:45:29 lack Exp $
+
+*supybot-plugins-20060723-r1 (22 May 2009)
+
+ 22 May 2009; Jim Ramsay <lack@gentoo.org>
+ +supybot-plugins-20060723-r1.ebuild:
+ Fixed collision with supybot-0.83.4
29 May 2008; Ali Polatel <hawking@gentoo.org>
supybot-plugins-20060723.ebuild:
diff --git a/net-irc/supybot-plugins/supybot-plugins-20060723-r1.ebuild b/net-irc/supybot-plugins/supybot-plugins-20060723-r1.ebuild
new file mode 100644
index 000000000000..917d63e19416
--- /dev/null
+++ b/net-irc/supybot-plugins/supybot-plugins-20060723-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/supybot-plugins/supybot-plugins-20060723-r1.ebuild,v 1.1 2009/05/22 19:45:29 lack Exp $
+
+inherit python multilib
+
+MY_PNAME="Supybot-plugins"
+MY_P="${MY_PNAME}-${PV}"
+
+DESCRIPTION="Official set of extra plugins for Supybot"
+HOMEPAGE="http://supybot.com"
+SRC_URI="mirror://sourceforge/supybot/${MY_P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=net-irc/supybot-0.83.4"
+
+src_install() {
+ cd "${WORKDIR}"/${MY_P}
+ python_version
+ PLUGIN_BASE="/usr/$(get_libdir)/python${PYVER}/site-packages/supybot/plugins"
+ for plugin in *; do
+ case $plugin in
+ BadWords|Dunno|Success)
+ # These plugins are part of supybot-0.83.4 now, so skip them
+ # here.
+ continue
+ ;;
+ *)
+ ;;
+ esac
+ insinto ${PLUGIN_BASE}/${plugin}
+ doins $plugin/* || die "Install failed"
+ done
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/supybot/plugins
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/supybot/plugins
+}