summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-01-11 15:33:43 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-01-11 15:33:43 +0000
commitfdb39bdcf4e2ca01f27e35659bf09e28f813cd51 (patch)
treee64ddfb4e2c19829f3d952aa114d9005f08da0db /net-irc
parentAdded hackish fix for the bash / portage circular dependency problem. (diff)
downloadgentoo-2-fdb39bdcf4e2ca01f27e35659bf09e28f813cd51.tar.gz
gentoo-2-fdb39bdcf4e2ca01f27e35659bf09e28f813cd51.tar.bz2
gentoo-2-fdb39bdcf4e2ca01f27e35659bf09e28f813cd51.zip
security update (problem was not exploitable in 1.8.x with default settings)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat/files/digest-xchat-1.8.71
-rw-r--r--net-irc/xchat/xchat-1.8.7.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/net-irc/xchat/files/digest-xchat-1.8.7 b/net-irc/xchat/files/digest-xchat-1.8.7
new file mode 100644
index 000000000000..6db9ad7c1df6
--- /dev/null
+++ b/net-irc/xchat/files/digest-xchat-1.8.7
@@ -0,0 +1 @@
+MD5 2bdcf2b77f6bf1385bc63a17dcafbe90 xchat-1.8.7.tar.bz2 700416
diff --git a/net-irc/xchat/xchat-1.8.7.ebuild b/net-irc/xchat/xchat-1.8.7.ebuild
new file mode 100644
index 000000000000..572da43e0629
--- /dev/null
+++ b/net-irc/xchat/xchat-1.8.7.ebuild
@@ -0,0 +1,65 @@
+# Copyrigth 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-1.8.7.ebuild,v 1.1 2002/01/11 15:33:43 blocke Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="X-Chat is an IRC client for UNIX operating systems."
+SRC_URI="http://www.xchat.org/files/source/1.8/${P}.tar.bz2"
+HOMEPAGE="http://www.xchat.org/"
+
+DEPEND=">=x11-libs/gtk+-1.2.10-r4
+ perl? ( sys-devel/perl )
+ python? ( >=dev-lang/python-2.0-r4 )
+ nls? ( >=sys-devel/gettext-0.10.38 )
+ gnome? ( >=gnome-base/gnome-core-1.4.0.4-r1
+ >=media-libs/gdk-pixbuf-0.11.0-r1 )
+ ssl? ( >=dev-libs/openssl-0.9.6a )"
+
+RDEPEND=">=x11-libs/gtk+-1.2.10-r4
+ gnome? ( >=gnome-base/gnome-core-1.4.0.4-r1
+ >=media-libs/gdk-pixbuf-0.11.0-r1 )
+ ssl? ( >=dev-libs/openssl-0.9.6a )"
+
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ cp configure configure.orig
+ if [ "`use python`" ]
+ then
+ local mylibs=`/usr/bin/python-config`
+ sed -e 's:PY_LIBS=".*":PY_LIBS="'"$mylibs"'":' configure.orig > configure
+ fi
+}
+
+src_compile() {
+
+ local myopts myflags
+ use gnome && myopts="--enable-gnome --enable-panel"
+ use gnome || myopts="--enable-gtkfe --disable-gnome --disable-gdk-pixbuf --disable-zvt"
+ use ssl && myopts="$myopts --enable-openssl"
+ use perl || myopts="$myopts --disable-perl"
+ use python && myflags="`python-config`"
+ use python || myopts="$myopts --disable-python"
+ use nls || myopts="$myopts --disable-nls"
+ use mmx && myopts="$myopts --enable-mmx"
+
+ CFLAGS="$CFLAGS -I/usr/include/orbit-1.0"
+
+ ./configure --prefix=/usr \
+ --host=${CHOST} \
+ --enable-ipv6 \
+ ${myopts} || die
+
+ emake || die
+}
+
+src_install() {
+
+ make prefix=${D}/usr install || die
+
+ dodoc AUTHORS COPYING ChangeLog README
+}