summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-02-21 23:32:05 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-02-21 23:32:05 +0000
commit0af7e6c5dbe6570d9d39f395bad04dd7fe83f330 (patch)
tree65d8fbcc659c05e835ec9b07333cccf49fa35602 /net-libs/c-client
parentClean up all old versions. (diff)
downloadgentoo-2-0af7e6c5dbe6570d9d39f395bad04dd7fe83f330.tar.gz
gentoo-2-0af7e6c5dbe6570d9d39f395bad04dd7fe83f330.tar.bz2
gentoo-2-0af7e6c5dbe6570d9d39f395bad04dd7fe83f330.zip
Clean up all repoman warnings.
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-libs/c-client')
-rw-r--r--net-libs/c-client/ChangeLog5
-rw-r--r--net-libs/c-client/c-client-2004g.ebuild12
2 files changed, 10 insertions, 7 deletions
diff --git a/net-libs/c-client/ChangeLog b/net-libs/c-client/ChangeLog
index 100e6c2a33f0..6a4a8ed8aefc 100644
--- a/net-libs/c-client/ChangeLog
+++ b/net-libs/c-client/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-libs/c-client
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/c-client/ChangeLog,v 1.42 2008/02/21 23:30:17 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/c-client/ChangeLog,v 1.43 2008/02/21 23:32:05 robbat2 Exp $
+
+ 21 Feb 2008; Robin H. Johnson <robbat2@gentoo.org> c-client-2004g.ebuild:
+ Clean up all repoman warnings.
21 Feb 2008; Robin H. Johnson <robbat2@gentoo.org> -c-client-2002d.ebuild,
-c-client-2002d-r1.ebuild, -c-client-2002e.ebuild,
diff --git a/net-libs/c-client/c-client-2004g.ebuild b/net-libs/c-client/c-client-2004g.ebuild
index 7229a82c38ae..3d665219f736 100644
--- a/net-libs/c-client/c-client-2004g.ebuild
+++ b/net-libs/c-client/c-client-2004g.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/c-client/c-client-2004g.ebuild,v 1.12 2008/02/21 23:28:53 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/c-client/c-client-2004g.ebuild,v 1.13 2008/02/21 23:32:05 robbat2 Exp $
inherit flag-o-matic eutils libtool
@@ -27,13 +27,13 @@ src_unpack() {
unpack ${A}
# Tarball packed with bad file perms
- chmod -R ug+w ${S}
+ chmod -R ug+w "${S}"
# lots of things need -fPIC, including various platforms, and this library
# generally should be built with it anyway.
append-flags -fPIC
- cd ${S}
+ cd "${S}"
# Modifications so we can build it optimally and correctly
sed \
@@ -47,11 +47,11 @@ src_unpack() {
-i src/osdep/unix/Makefile || die "Makefile sex fixing failed for FreeBSD"
# Apply a patch to only build the stuff we need for c-client
- epatch ${FILESDIR}/2002d-Makefile.patch || die "epatch failed"
+ epatch "${FILESDIR}"/2002d-Makefile.patch || die "epatch failed"
# Apply patch to add the compilation of a .so for PHP
# This was previously conditional, but is more widely useful.
- epatch ${FILESDIR}/${PN}-2004a-amd64-so-fix.patch
+ epatch "${FILESDIR}"/${PN}-2004a-amd64-so-fix.patch
# Remove the pesky checks about SSL stuff
sed -e '/read.*exit/d' -i Makefile
@@ -67,7 +67,7 @@ src_compile() {
target=bsf
fi
# no parallel builds supported!
- make $target SSLTYPE=${ssltype} EXTRACFLAGS="${CFLAGS}" || die "make failed"
+ emake -j1 $target SSLTYPE=${ssltype} EXTRACFLAGS="${CFLAGS}" || die "make failed"
}
src_install() {