summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorScott W Taylor <swtaylor@gentoo.org>2004-11-20 12:04:33 +0000
committerScott W Taylor <swtaylor@gentoo.org>2004-11-20 12:04:33 +0000
commitdc3d8a590661e61c5ff6bbce37279baa84cd3783 (patch)
tree1a77b3713736020494e4faeef06e1a6c01924177 /net-libs/courier-authlib
parentAdd ~sparc keyword, Bug 71769 --- internal tests & my application are fine. (... (diff)
downloadgentoo-2-dc3d8a590661e61c5ff6bbce37279baa84cd3783.tar.gz
gentoo-2-dc3d8a590661e61c5ff6bbce37279baa84cd3783.tar.bz2
gentoo-2-dc3d8a590661e61c5ff6bbce37279baa84cd3783.zip
work in progress
Diffstat (limited to 'net-libs/courier-authlib')
-rw-r--r--net-libs/courier-authlib/ChangeLog6
-rw-r--r--net-libs/courier-authlib/courier-authlib-0.50.20041116.ebuild48
-rw-r--r--net-libs/courier-authlib/files/configure-db4.patch68
3 files changed, 112 insertions, 10 deletions
diff --git a/net-libs/courier-authlib/ChangeLog b/net-libs/courier-authlib/ChangeLog
index d51e9bf055e5..d5f66678c057 100644
--- a/net-libs/courier-authlib/ChangeLog
+++ b/net-libs/courier-authlib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/courier-authlib
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/courier-authlib/ChangeLog,v 1.1 2004/11/20 00:28:36 swtaylor Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/courier-authlib/ChangeLog,v 1.2 2004/11/20 12:04:33 swtaylor Exp $
+
+ 20 Nov 2004; Scott W Taylor <swtaylor@gentoo.org>
+ +files/configure-db4.patch, courier-authlib-0.50.20041116.ebuild:
+ work in progress. merging stuff from imap
*courier-authlib-0.50.20041116 (19 Nov 2004)
diff --git a/net-libs/courier-authlib/courier-authlib-0.50.20041116.ebuild b/net-libs/courier-authlib/courier-authlib-0.50.20041116.ebuild
index cf550265fcc7..9d6c542c44aa 100644
--- a/net-libs/courier-authlib/courier-authlib-0.50.20041116.ebuild
+++ b/net-libs/courier-authlib/courier-authlib-0.50.20041116.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/courier-authlib/courier-authlib-0.50.20041116.ebuild,v 1.1 2004/11/20 00:28:36 swtaylor Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/courier-authlib/courier-authlib-0.50.20041116.ebuild,v 1.2 2004/11/20 12:04:33 swtaylor Exp $
-inherit eutils
+inherit eutils gnuconfig
DESCRIPTION="courier authentication library"
[ -z "${PV/?.??/}" ] && SRC_URI="mirror://sourceforge/courier-authlib/${P}.tar.bz2" || SRC_URI="http://www.courier-mta.org/beta/courier-authlib/${P}.tar.bz2"
@@ -12,26 +12,50 @@ SLOT="0"
LICENSE="GPL-2"
#KEYWORDS="~x86 ~alpha ~ppc ~sparc ~amd64"
KEYWORDS="-*"
-IUSE="postgres ldap mysql gdbm pam crypt uclibc debug"
+IUSE="postgres ldap mysql berkdb gdbm pam crypt uclibc debug"
-DEPEND="virtual/libc"
+DEPEND="virtual/libc
+ gdbm? ( sys-libs/gdbm )
+ !gdbm? ( >=sys-devel/autoconf-2.5 sys-libs/db )"
-RDEPEND="${DEPEND}"
+RDEPEND="virtual/libc
+ gdbm? ( sys-libs/gdbm )
+ !gdbm? ( sys-libs/db )"
src_unpack() {
if ! has_version 'dev-tcltk/expect' ; then
- einfo 'The dev-tcltk/expect package is not installed.'
+ ewarn 'The dev-tcltk/expect package is not installed.'
+ einfo 'This only limits using webmail to change authpam passwords.'
fi
unpack ${A}
cd ${S}
sed -e"s|^chk_file .* |&\${DESTDIR}|g" -i.orig authmigrate.in
use uclibc && sed -i -e 's:linux-gnu\*:linux-gnu\*\ \|\ linux-uclibc:' config.sub
+ if ! use gdbm ; then
+ epatch ${FILESDIR}/configure-db4.patch
+ export WANT_AUTOCONF="2.5"
+ gnuconfig_update
+ ebegin "Recreating configure"
+ autoconf || die "recreate configure failed"
+ eend $?
+ cd ${S}/bdbobj
+ ebegin "Recreating bdbobj/configure"
+ autoconf || die "recreate bdbobj/configure failed"
+ eend $?
+ fi
}
src_compile() {
local myconf
myconf="`use_with pam authpam` `use_with ldap authldap`"
+
+ if use berkdb ; then
+ use gdbm && \
+ einfo "Both gdbm and berkdb selected. Using gdbm." || \
+ myconf="${myconf} --with-db=db"
+ fi
use gdbm && myconf="${myconf} --with-db=gdbm"
+
if [ -f /var/vpopmail/etc/lib_deps ]; then
myconf="${myconf} --with-authvchkpw --without-authmysql --without-authpgsql"
@@ -49,29 +73,35 @@ ewarn "${myconf}"
--prefix=/usr \
--mandir=/usr/share/man \
--sysconfdir=/etc/courier \
- --libexecdir=/usr/lib/courier \
--datadir=/usr/share/courier \
- --sharedstatedir=/var/lib/courier/com \
+ --libexecdir=/usr/lib/courier \
--localstatedir=/var/lib/courier \
+ --sharedstatedir=/var/lib/courier/com \
--with-authdaemonvar=/var/lib/courier/authdaemon \
+ --without-redhat \
--with-mailuser=mail \
--with-mailgroup=mail \
--cache-file=${S}/configuring.cache \
+ --build=${CHOST} \
--host=${CHOST} ${myconf} || die "bad ./configure"
emake || die "Compile problem"
}
src_install() {
- dodir /etc/courier/authlib
dodir /var/lib/courier
+ dodir /etc/courier/authlib
+ dodir /etc/init.d
emake install DESTDIR="${D}" || die "install"
emake install-migrate DESTDIR="${D}" || die "migrate"
emake install-configure DESTDIR="${D}" || die "configure"
rm ${D}/etc/courier/authlib/*.bak
+ chown mail:mail ${D}/etc/courier/authlib/*
dodoc AUTHORS COPYING ChangeLog* INSTALL NEWS README
dohtml README.html README_authlib.html NEWS.html INSTALL.html README.authdebug.html
use ldap && dodoc authldap.schema
use mysql && ( dodoc README.authmysql.myownquery ; dohtml README.authmysql.html )
use postgres && dohtml README.authpostgres.html
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/courier-authlib-initd courier-authlib || die "init.d failed"
}
diff --git a/net-libs/courier-authlib/files/configure-db4.patch b/net-libs/courier-authlib/files/configure-db4.patch
new file mode 100644
index 000000000000..18b32f88f998
--- /dev/null
+++ b/net-libs/courier-authlib/files/configure-db4.patch
@@ -0,0 +1,68 @@
+--- configure.in.orig 2004-11-02 14:46:22.000000000 -0800
++++ configure.in 2004-11-02 14:51:02.531958000 -0800
+@@ -26,7 +26,6 @@
+ AC_PROG_CPP
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
+-AC_PROG_SYSCONFTOOL
+ AC_SUBST(LTDLINCL)
+ AC_SUBST(LIBLTDL)
+ AC_LIBTOOL_DLOPEN
+@@ -284,15 +283,17 @@
+
+ if test "$db" != "gdbm"
+ then
+- AC_CHECK_LIB(db, dbopen, [ LIBDB=-ldb ; LIBS="-ldb $LIBS" ],
+- [ AC_CHECK_LIB(db, db_open, [ LIBDB=-ldb ; LIBS="-ldb $LIBS"],
+- [ AC_CHECK_LIB(db, db_env_create,
+- [ LIBDB=-ldb; LIBS="-ldb $LIBS"]) ]
+- )])
+-
+- AC_CHECK_FUNC(dbopen, HAVE_BDB=1)
+- AC_CHECK_FUNC(db_open, HAVE_BDB=1)
+- AC_CHECK_FUNC(db_env_create, HAVE_BDB=1)
++ for dbname in db-4.2 db4.2 db42 db-4.1 db4.1 db41 db-4.0 db4.0 db-4 db40 db4 db
++ do
++ AC_CHECK_LIB($dbname, db_create_4002, [ LIBDB=-l$dbname ; LIBS="-l$dbname $LIBS"; break ],
++ AC_CHECK_LIB($dbname, db_create_4001, [ LIBDB=-l$dbname ; LIBS="-l$dbname $LIBS"; break ],
++ AC_CHECK_LIB($dbname, db_create_4000, [ LIBDB=-l$dbname ; LIBS="-l$dbname $LIBS"; break ],
++ AC_CHECK_LIB($dbname, db_create, [ LIBDB=-l$dbname ; LIBS="-l$dbname $LIBS"; break ]))))
++ done
++ AC_CHECK_FUNC(db_create_4002, HAVE_BDB=1)
++ AC_CHECK_FUNC(db_create_4001, HAVE_BDB=1)
++ AC_CHECK_FUNC(db_create_4000, HAVE_BDB=1)
++ AC_CHECK_FUNC(db_create, HAVE_BDB=1)
+ fi
+
+ LIBS="$saveLIBS"
+--- bdbobj/configure.in 2001-09-18 18:26:28.000000000 -0700
++++ bdbobj/configure.in 2004-08-14 16:15:08.469316646 -0700
+@@ -21,15 +21,19 @@
+ dnl Checks for libraries.
+
+ saveLIBS="$LIBS"
+-AC_CHECK_LIB(db, dbopen, [ LIBDB=-ldb ; LIBS="-ldb $LIBS" ],
+- AC_CHECK_LIB(db, db_open, [ LIBDB=-ldb ; LIBS="-ldb $LIBS"],
+- AC_CHECK_LIB(db, db_env_create, [ LIBDB=-ldb; LIBS="-ldb $LIBS"])
+- ))
+-
+-FOUND_DB=0
+-AC_CHECK_FUNC(dbopen, FOUND_DB=1)
+-AC_CHECK_FUNC(db_open, FOUND_DB=1)
+-AC_CHECK_FUNC(db_env_create, FOUND_DB=1)
++for dbname in db-4.2 db4.2 db42 db-4.1 db4.1 db41 db-4.0 db4.0 db-4 db40 db4 db
++ do
++ AC_CHECK_LIB($dbname, db_create_4002, [ LIBDB=-l$dbname ; LIBS="-l$dbname $LIBS"; break ],
++ AC_CHECK_LIB($dbname, db_create_4001, [ LIBDB=-l$dbname ; LIBS="-l$dbname $LIBS"; break ],
++ AC_CHECK_LIB($dbname, db_create_4000, [ LIBDB=-l$dbname ; LIBS="-l$dbname $LIBS"; break ],
++ AC_CHECK_LIB($dbname, db_create, [ LIBDB=-l$dbname ; LIBS="-l$dbname $LIBS"; break ]))))
++
++ done
++FOUND_DB=0
++AC_CHECK_FUNC(db_create_4002, FOUND_DB=1)
++AC_CHECK_FUNC(db_create_4001, FOUND_DB=1)
++AC_CHECK_FUNC(db_create_4000, FOUND_DB=1)
++AC_CHECK_FUNC(db_create, FOUND_DB=1)
+
+ LIBS="$saveLIBS"
+