summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2010-10-01 16:13:30 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2010-10-01 16:13:30 +0000
commit246a9f26451d76b24611b78b50ada6711070716b (patch)
tree4096416da3dcc4c7b8f8cb04af411d0d4d2d5426 /net-libs/gupnp-av
parentCleanup latest to use python eclass for depend. Stabilize latest on amd64 and... (diff)
downloadgentoo-2-246a9f26451d76b24611b78b50ada6711070716b.tar.gz
gentoo-2-246a9f26451d76b24611b78b50ada6711070716b.tar.bz2
gentoo-2-246a9f26451d76b24611b78b50ada6711070716b.zip
Bump to 0.6.1. Stable release - adds some fixes and documentation updates over 0.5.7. DLNA media support moved to media-libs/gupnp-dlna.
(Portage version: 2.2_rc88/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/gupnp-av')
-rw-r--r--net-libs/gupnp-av/ChangeLog9
-rw-r--r--net-libs/gupnp-av/gupnp-av-0.6.1.ebuild33
2 files changed, 41 insertions, 1 deletions
diff --git a/net-libs/gupnp-av/ChangeLog b/net-libs/gupnp-av/ChangeLog
index 25b80fc8b769..663b8198c660 100644
--- a/net-libs/gupnp-av/ChangeLog
+++ b/net-libs/gupnp-av/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/gupnp-av
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-av/ChangeLog,v 1.8 2010/07/21 10:52:55 ford_prefect Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-av/ChangeLog,v 1.9 2010/10/01 16:13:30 ford_prefect Exp $
+
+*gupnp-av-0.6.1 (01 Oct 2010)
+
+ 01 Oct 2010; Arun Raghavan <ford_prefect@gentoo.org>
+ +gupnp-av-0.6.1.ebuild:
+ Bump to 0.6.1. Stable release - adds some fixes and documentation updates
+ over 0.5.7. DLNA media support moved to media-libs/gupnp-dlna.
21 Jul 2010; Arun Raghavan <ford_prefect@gentoo.org>
-gupnp-av-0.5.1.ebuild:
diff --git a/net-libs/gupnp-av/gupnp-av-0.6.1.ebuild b/net-libs/gupnp-av/gupnp-av-0.6.1.ebuild
new file mode 100644
index 000000000000..b44bbb72cb7c
--- /dev/null
+++ b/net-libs/gupnp-av/gupnp-av-0.6.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-av/gupnp-av-0.6.1.ebuild,v 1.1 2010/10/01 16:13:30 ford_prefect Exp $
+
+EAPI=2
+
+DESCRIPTION="a small utility library that aims to ease the handling UPnP A/V profiles."
+HOMEPAGE="http://gupnp.org/"
+SRC_URI="http://gupnp.org/sites/all/files/sources/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+introspection"
+
+RDEPEND=">=dev-libs/glib-2.16:2
+ >=net-libs/gupnp-0.13[introspection?]"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable introspection) \
+ --disable-dependency-tracking \
+ --disable-gtk-doc \
+ --disable-gtk-doc-html \
+ --disable-gtk-doc-pdf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+}