summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-26 19:31:10 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-26 19:31:10 +0000
commit16cf78467336601f5ca7a2ed8fb97e041783fa90 (patch)
treeb09ed1d45d6a4b28424f65b4286274e6288dd7bc /net-libs/gupnp-igd
parentdepend virtual/jpeg (diff)
downloadgentoo-2-16cf78467336601f5ca7a2ed8fb97e041783fa90.tar.gz
gentoo-2-16cf78467336601f5ca7a2ed8fb97e041783fa90.tar.bz2
gentoo-2-16cf78467336601f5ca7a2ed8fb97e041783fa90.zip
Use Python 2 (bug #356579).
(Portage version: 2.2.0_alpha25_p8/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/gupnp-igd')
-rw-r--r--net-libs/gupnp-igd/ChangeLog6
-rw-r--r--net-libs/gupnp-igd/gupnp-igd-0.1.7.ebuild15
2 files changed, 17 insertions, 4 deletions
diff --git a/net-libs/gupnp-igd/ChangeLog b/net-libs/gupnp-igd/ChangeLog
index e049842722cd..2d893455e35e 100644
--- a/net-libs/gupnp-igd/ChangeLog
+++ b/net-libs/gupnp-igd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/gupnp-igd
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-igd/ChangeLog,v 1.25 2011/02/26 19:20:38 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-igd/ChangeLog,v 1.26 2011/02/26 19:31:10 arfrever Exp $
+
+ 26 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ gupnp-igd-0.1.7.ebuild:
+ Use Python 2 (bug #356579).
26 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
-gupnp-igd-0.1.3.ebuild, -gupnp-igd-0.1.6.ebuild:
diff --git a/net-libs/gupnp-igd/gupnp-igd-0.1.7.ebuild b/net-libs/gupnp-igd/gupnp-igd-0.1.7.ebuild
index 027f07592f46..c230056ff444 100644
--- a/net-libs/gupnp-igd/gupnp-igd-0.1.7.ebuild
+++ b/net-libs/gupnp-igd/gupnp-igd-0.1.7.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-igd/gupnp-igd-0.1.7.ebuild,v 1.9 2011/02/26 18:05:33 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-igd/gupnp-igd-0.1.7.ebuild,v 1.10 2011/02/26 19:31:10 arfrever Exp $
-EAPI=2
-inherit autotools eutils
+EAPI="3"
+PYTHON_DEPEND="python? 2:2.5"
+
+inherit autotools eutils python
DESCRIPTION="This is a library to handle UPnP IGD port mapping for GUPnP."
HOMEPAGE="http://gupnp.org"
@@ -22,6 +24,13 @@ DEPEND="${RDEPEND}
sys-devel/gettext
dev-util/gtk-doc-am"
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
src_prepare() {
epatch "${FILESDIR}"/${P}-make-382.patch
eautoreconf