summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-05-11 16:40:31 +0000
committerMichał Górny <mgorny@gentoo.org>2015-05-11 16:40:31 +0000
commit900e2a74ab78467ff22ccd51062428780e548bfd (patch)
treee26dff1de9c56ea25ee4d0f46e65237d3fc2a2df /net-libs/http-parser
parentVersion bump #538948 by Andrew John Hughes. (diff)
downloadgentoo-2-900e2a74ab78467ff22ccd51062428780e548bfd.tar.gz
gentoo-2-900e2a74ab78467ff22ccd51062428780e548bfd.tar.bz2
gentoo-2-900e2a74ab78467ff22ccd51062428780e548bfd.zip
Version bump. https://github.com/gentoo/gentoo-portage-rsync-mirror/pull/109 by jbergstroem.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'net-libs/http-parser')
-rw-r--r--net-libs/http-parser/ChangeLog8
-rw-r--r--net-libs/http-parser/http-parser-2.5.0.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/net-libs/http-parser/ChangeLog b/net-libs/http-parser/ChangeLog
index 7af0a62d9419..6b3a318e51d8 100644
--- a/net-libs/http-parser/ChangeLog
+++ b/net-libs/http-parser/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/http-parser
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/http-parser/ChangeLog,v 1.13 2015/03/28 21:55:40 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/http-parser/ChangeLog,v 1.14 2015/05/11 16:40:31 mgorny Exp $
+
+*http-parser-2.5.0 (11 May 2015)
+
+ 11 May 2015; Michał Górny <mgorny@gentoo.org> +http-parser-2.5.0.ebuild:
+ Version bump. https://github.com/gentoo/gentoo-portage-rsync-mirror/pull/109
+ by jbergstroem.
*http-parser-2.4.2 (28 Mar 2015)
diff --git a/net-libs/http-parser/http-parser-2.5.0.ebuild b/net-libs/http-parser/http-parser-2.5.0.ebuild
new file mode 100644
index 000000000000..54358e71a6b3
--- /dev/null
+++ b/net-libs/http-parser/http-parser-2.5.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/http-parser/http-parser-2.5.0.ebuild,v 1.1 2015/05/11 16:40:31 mgorny Exp $
+
+EAPI=5
+
+SONAME="libhttp_parser.so.${PV}"
+
+inherit eutils toolchain-funcs multilib multilib-minimal
+
+DESCRIPTION="http request/response parser for c"
+HOMEPAGE="https://github.com/joyent/http-parser"
+SRC_URI="https://github.com/joyent/http-parser/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="static-libs"
+
+src_prepare() {
+ sed -i -e 's: -Werror::' \
+ -e 's:-O3 ::' \
+ Makefile || die
+ tc-export CC AR
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ emake library
+ use static-libs && emake package
+}
+
+multilib_src_install() {
+ doheader http_parser.h
+ dolib.so ${SONAME}
+ dosym ${SONAME} /usr/$(get_libdir)/libhttp_parser.so
+ use static-libs && dolib.a libhttp_parser.a
+}
+
+multilib_src_install_all() {
+ dodoc README.md
+}