summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2014-05-13 11:55:30 +0000
committerTony Vroon <chainsaw@gentoo.org>2014-05-13 11:55:30 +0000
commit6a81cef133b27f67388725e39990251e873eacfb (patch)
treee97a3dd45e7a86c1295dbdaef954d61f8d67cb89 /net-libs/iax
parentsys-kernel/aufs-sources: Drop old (diff)
downloadgentoo-2-6a81cef133b27f67388725e39990251e873eacfb.tar.gz
gentoo-2-6a81cef133b27f67388725e39990251e873eacfb.tar.bz2
gentoo-2-6a81cef133b27f67388725e39990251e873eacfb.zip
Stop trying to tiptoe around the autotools eclass and just use it correctly. This instills LDFLAGS respect, which was flagged up by Diego Elio "Flameeyes" Pettenò in bug #337357.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB5058F9A)
Diffstat (limited to 'net-libs/iax')
-rw-r--r--net-libs/iax/ChangeLog12
-rw-r--r--net-libs/iax/files/0.2.2-sandbox.patch19
-rw-r--r--net-libs/iax/iax-0.2.2-r2.ebuild32
3 files changed, 61 insertions, 2 deletions
diff --git a/net-libs/iax/ChangeLog b/net-libs/iax/ChangeLog
index 385b26b20953..f80c1240196d 100644
--- a/net-libs/iax/ChangeLog
+++ b/net-libs/iax/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-libs/iax
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/iax/ChangeLog,v 1.12 2013/10/27 09:38:21 pacho Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/iax/ChangeLog,v 1.13 2014/05/13 11:55:30 chainsaw Exp $
+
+*iax-0.2.2-r2 (13 May 2014)
+
+ 13 May 2014; Tony Vroon <chainsaw@gentoo.org> +iax-0.2.2-r2.ebuild,
+ +files/0.2.2-sandbox.patch:
+ Stop trying to tiptoe around the autotools eclass and just use it correctly.
+ This instills LDFLAGS respect, which was flagged up by Diego Elio "Flameeyes"
+ Pettenò in bug #337357.
27 Oct 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due voip herd removal:
diff --git a/net-libs/iax/files/0.2.2-sandbox.patch b/net-libs/iax/files/0.2.2-sandbox.patch
new file mode 100644
index 000000000000..2dc141a73b18
--- /dev/null
+++ b/net-libs/iax/files/0.2.2-sandbox.patch
@@ -0,0 +1,19 @@
+diff -uNr iax-0.2.2.ORIG/src/Makefile.am iax-0.2.2/src/Makefile.am
+--- iax-0.2.2.ORIG/src/Makefile.am 2014-05-13 12:45:58.343755528 +0100
++++ iax-0.2.2/src/Makefile.am 2014-05-13 12:46:30.044757107 +0100
+@@ -9,10 +9,9 @@
+ EXTRA_DIST = md5.h frame.h iax-client.h iax.h
+
+ install:
+- mkdir -p $(includedir)/iax
+- install -m 644 md5.h $(includedir)/iax
+- install -m 644 frame.h $(includedir)/iax
+- install -m 644 iax.h $(includedir)/iax
+- install -m 644 iax-client.h $(includedir)/iax
+- /sbin/ldconfig
++ mkdir -p $(DESTDIR)$(includedir)/iax
++ install -m 644 md5.h $(DESTDIR)$(includedir)/iax
++ install -m 644 frame.h $(DESTDIR)$(includedir)/iax
++ install -m 644 iax.h $(DESTDIR)$(includedir)/iax
++ install -m 644 iax-client.h $(DESTDIR)$(includedir)/iax
+
diff --git a/net-libs/iax/iax-0.2.2-r2.ebuild b/net-libs/iax/iax-0.2.2-r2.ebuild
new file mode 100644
index 000000000000..4e4442fab705
--- /dev/null
+++ b/net-libs/iax/iax-0.2.2-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/iax/iax-0.2.2-r2.ebuild,v 1.1 2014/05/13 11:55:30 chainsaw Exp $
+
+EAPI="5"
+
+inherit autotools eutils
+
+DESCRIPTION="IAX (Inter Asterisk eXchange) Library"
+HOMEPAGE="http://www.asterisk.org/"
+SRC_URI="http://downloads.asterisk.org/pub/telephony/libiax/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug snomhack"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-sandbox.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug extreme-debug) \
+ $(use_enable snomhack)
+}
+
+src_install () {
+ default
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+}