summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-10-26 08:01:52 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-10-26 08:01:52 +0000
commit319848d191e421e496e0c237b08e7ee5154bb143 (patch)
tree5f6d35727022b63b759cc944107c74b78223a906 /net-libs/libasyncns
parentVersion bump requests to 2.0.1 (bug 489388). (diff)
downloadgentoo-2-319848d191e421e496e0c237b08e7ee5154bb143.tar.gz
gentoo-2-319848d191e421e496e0c237b08e7ee5154bb143.tar.bz2
gentoo-2-319848d191e421e496e0c237b08e7ee5154bb143.zip
convert to multilib, by Reinis Danne, bug #488278
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'net-libs/libasyncns')
-rw-r--r--net-libs/libasyncns/ChangeLog9
-rw-r--r--net-libs/libasyncns/libasyncns-0.8-r3.ebuild60
2 files changed, 67 insertions, 2 deletions
diff --git a/net-libs/libasyncns/ChangeLog b/net-libs/libasyncns/ChangeLog
index 4af7ecb84869..2d8f3cd6c7a8 100644
--- a/net-libs/libasyncns/ChangeLog
+++ b/net-libs/libasyncns/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libasyncns
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libasyncns/ChangeLog,v 1.34 2012/12/20 17:40:53 hasufell Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libasyncns/ChangeLog,v 1.35 2013/10/26 08:01:52 aballier Exp $
+
+*libasyncns-0.8-r3 (26 Oct 2013)
+
+ 26 Oct 2013; Alexis Ballier <aballier@gentoo.org> +libasyncns-0.8-r3.ebuild:
+ convert to multilib, by Reinis Danne, bug #488278
20 Dec 2012; Julian Ospald <hasufell@gentoo.org> libasyncns-0.8-r2.ebuild:
fix missing doc compression wrt #447936
diff --git a/net-libs/libasyncns/libasyncns-0.8-r3.ebuild b/net-libs/libasyncns/libasyncns-0.8-r3.ebuild
new file mode 100644
index 000000000000..3d1262488b41
--- /dev/null
+++ b/net-libs/libasyncns/libasyncns-0.8-r3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libasyncns/libasyncns-0.8-r3.ebuild,v 1.1 2013/10/26 08:01:52 aballier Exp $
+
+EAPI=5
+inherit eutils flag-o-matic libtool multilib multilib-minimal
+
+DESCRIPTION="C library for executing name service queries asynchronously."
+HOMEPAGE="http://0pointer.de/lennart/projects/libasyncns/"
+SRC_URI="http://0pointer.de/lennart/projects/libasyncns/${P}.tar.gz"
+
+SLOT="0"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="doc debug"
+
+RDEPEND=""
+DEPEND="doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ # fix libdir in pkgconfig file
+ epatch "${FILESDIR}/${P}-libdir.patch"
+ elibtoolize
+}
+
+multilib_src_configure() {
+ # libasyncns uses assert()
+ use debug || append-cppflags -DNDEBUG
+
+ ECONF_SOURCE=${S} \
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ --disable-dependency-tracking \
+ --disable-lynx \
+ --disable-static
+}
+
+multilib_src_compile() {
+ emake || die "emake failed"
+
+ if multilib_is_native_abi && use doc; then
+ doxygen doxygen/doxygen.conf || die "doxygen failed"
+ fi
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ if multilib_is_native_abi && use doc; then
+ docinto apidocs
+ dohtml html/*
+ fi
+}
+
+multilib_src_install_all() {
+ find "${D}" -name '*.la' -delete
+}