summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-09-02 19:14:52 +0000
committerMike Frysinger <vapier@gentoo.org>2011-09-02 19:14:52 +0000
commit560c666069c4d49b677c91850a3c66527bf6fb40 (patch)
tree4d8634ad3af6781551dcdf25b360d18f43d899d2 /net-libs/libgssglue
parent[bump] dev-perl/HTTP-BrowserDetect-1.290.0 (diff)
downloadgentoo-2-560c666069c4d49b677c91850a3c66527bf6fb40.tar.gz
gentoo-2-560c666069c4d49b677c91850a3c66527bf6fb40.tar.bz2
gentoo-2-560c666069c4d49b677c91850a3c66527bf6fb40.zip
Version bump.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libgssglue')
-rw-r--r--net-libs/libgssglue/ChangeLog8
-rw-r--r--net-libs/libgssglue/files/libgssglue-0.3-protos.patch15
-rw-r--r--net-libs/libgssglue/libgssglue-0.3.ebuild37
3 files changed, 59 insertions, 1 deletions
diff --git a/net-libs/libgssglue/ChangeLog b/net-libs/libgssglue/ChangeLog
index 0fcce219086d..747f8566fd97 100644
--- a/net-libs/libgssglue/ChangeLog
+++ b/net-libs/libgssglue/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libgssglue
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libgssglue/ChangeLog,v 1.12 2011/02/06 12:22:30 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libgssglue/ChangeLog,v 1.13 2011/09/02 19:14:52 vapier Exp $
+
+*libgssglue-0.3 (02 Sep 2011)
+
+ 02 Sep 2011; Mike Frysinger <vapier@gentoo.org> +libgssglue-0.3.ebuild,
+ +files/libgssglue-0.3-protos.patch:
+ Version bump.
06 Feb 2011; Mart Raudsepp <leio@gentoo.org> libgssglue-0.1-r1.ebuild:
Drop to ~mips
diff --git a/net-libs/libgssglue/files/libgssglue-0.3-protos.patch b/net-libs/libgssglue/files/libgssglue-0.3-protos.patch
new file mode 100644
index 000000000000..5aaf6d03aaac
--- /dev/null
+++ b/net-libs/libgssglue/files/libgssglue-0.3-protos.patch
@@ -0,0 +1,15 @@
+add missing prototype to header
+
+--- a/src/mglueP.h
++++ b/src/mglueP.h
+@@ -477,6 +477,10 @@ OM_uint32 generic_gss_str_to_oid
+ gss_OID * /* oid */
+ );
+
++OM_uint32
++generic_gss_copy_oid_set(OM_uint32 *minor_status,
++ const gss_OID_set_desc * const oidset,
++ gss_OID_set *new_oidset);
+
+ gss_OID gss_find_mechanism_from_name_type (gss_OID); /* name_type */
+
diff --git a/net-libs/libgssglue/libgssglue-0.3.ebuild b/net-libs/libgssglue/libgssglue-0.3.ebuild
new file mode 100644
index 000000000000..6991113ad7ba
--- /dev/null
+++ b/net-libs/libgssglue/libgssglue-0.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libgssglue/libgssglue-0.3.ebuild,v 1.1 2011/09/02 19:14:52 vapier Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="exports a gssapi interface which calls other random gssapi libraries"
+HOMEPAGE="http://www.citi.umich.edu/projects/nfsv4/linux/"
+SRC_URI="http://www.citi.umich.edu/projects/nfsv4/linux/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="!app-crypt/libgssapi"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.3-protos.patch
+}
+
+src_configure() {
+ # No need to install static libraries, as it uses libdl
+ econf --disable-static
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ find "${D}" -name '*.la' -delete || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+
+ insinto /etc
+ doins doc/gssapi_mech.conf || die
+}