summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2013-06-11 02:57:58 +0000
committerRick Farina <zerochaos@gentoo.org>2013-06-11 02:57:58 +0000
commit772bdc2926ed49c8047abfa9489b566df5808f99 (patch)
tree19ef4485358a96bba8508aefd29b4067e1a5eee7 /net-libs/libhackrf/libhackrf-9999.ebuild
parentAdd upstream CPE tag (security info) from ChromiumOS. (diff)
downloadgentoo-2-772bdc2926ed49c8047abfa9489b566df5808f99.tar.gz
gentoo-2-772bdc2926ed49c8047abfa9489b566df5808f99.tar.bz2
gentoo-2-772bdc2926ed49c8047abfa9489b566df5808f99.zip
stable version added, ebuild cleanup
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'net-libs/libhackrf/libhackrf-9999.ebuild')
-rw-r--r--net-libs/libhackrf/libhackrf-9999.ebuild27
1 files changed, 16 insertions, 11 deletions
diff --git a/net-libs/libhackrf/libhackrf-9999.ebuild b/net-libs/libhackrf/libhackrf-9999.ebuild
index 516ff581284d..3db1df5ea353 100644
--- a/net-libs/libhackrf/libhackrf-9999.ebuild
+++ b/net-libs/libhackrf/libhackrf-9999.ebuild
@@ -1,24 +1,29 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libhackrf/libhackrf-9999.ebuild,v 1.2 2013/05/28 05:08:42 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libhackrf/libhackrf-9999.ebuild,v 1.3 2013/06/11 02:57:58 zerochaos Exp $
EAPI=5
-inherit cmake-utils git-2
+inherit cmake-utils
DESCRIPTION="library for communicating with HackRF SDR platform"
-HOMEPAGE="https://github.com/mossmann/hackrf"
-EGIT_REPO_URI="https://github.com/mossmann/hackrf.git"
-SRC_URI=""
+HOMEPAGE="http://greatscottgadgets.com/hackrf/"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/mossmann/hackrf.git"
+ inherit git-2
+ KEYWORDS=""
+ EGIT_SOURCEDIR="${WORKDIR}/hackrf"
+ S="${WORKDIR}/hackrf/host/libhackrf"
+else
+ S="${WORKDIR}/hackrf-${PV}/host/libhackrf"
+ SRC_URI="mirror://sourceforge/hackrf/hackrf-${PV}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~ppc ~x86"
+fi
LICENSE="BSD"
-SLOT="0"
-KEYWORDS=""
-#KEYWORDS="~amd64 ~arm ~x86"
+SLOT="0/${PV}"
IUSE=""
DEPEND="virtual/libusb:1"
RDEPEND="${DEPEND}"
-
-EGIT_SOURCEDIR="${WORKDIR}/${P}"
-S="${WORKDIR}/${P}/host/libhackrf"