summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-10-29 19:04:09 +0000
committerJohannes Huber <johu@gentoo.org>2013-10-29 19:04:09 +0000
commite1b60cdd8f54f843e22a203698aa0be67ea7ed7c (patch)
tree97a4c499056e91152887abbc173850a945a02398 /net-libs/libkpeople/libkpeople-0.1.0.ebuild
parentFix setuptools sandbox issue (bug #489726) and remove old. (diff)
downloadgentoo-2-e1b60cdd8f54f843e22a203698aa0be67ea7ed7c.tar.gz
gentoo-2-e1b60cdd8f54f843e22a203698aa0be67ea7ed7c.tar.bz2
gentoo-2-e1b60cdd8f54f843e22a203698aa0be67ea7ed7c.zip
New package. Import from kde overlay. Will be required for KDE Telepathy 0.7.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'net-libs/libkpeople/libkpeople-0.1.0.ebuild')
-rw-r--r--net-libs/libkpeople/libkpeople-0.1.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-libs/libkpeople/libkpeople-0.1.0.ebuild b/net-libs/libkpeople/libkpeople-0.1.0.ebuild
new file mode 100644
index 000000000000..530032d10586
--- /dev/null
+++ b/net-libs/libkpeople/libkpeople-0.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libkpeople/libkpeople-0.1.0.ebuild,v 1.1 2013/10/29 19:04:09 johu Exp $
+
+EAPI=5
+
+VIRTUALX_REQUIRED="test"
+KDE_LINGUAS="cs da de hu nl pt pt_BR sk sv uk"
+inherit kde4-base
+
+if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="mirror://kde/unstable/${PN}/${PV}/src/${P}.tar.bz2"
+else
+ KEYWORDS=""
+fi
+
+DESCRIPTION="KDE contact person abstraction library"
+HOMEPAGE="https://projects.kde.org/projects/playground/network/libkpeople"
+
+LICENSE="LGPL-2.1"
+SLOT="4"
+IUSE="debug examples test"
+
+DEPEND="
+ dev-libs/shared-desktop-ontologies
+ dev-libs/soprano
+ $(add_kdebase_dep nepomuk-core)
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with examples)
+ )
+
+ kde4-base_src_configure
+}