summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2013-08-26 19:50:06 +0000
committerRick Farina <zerochaos@gentoo.org>2013-08-26 19:50:06 +0000
commit1e634eb93ae4f88961b8315c982c23b7972baac8 (patch)
treed295f4cecd811370eb0bc66f7438994664c008b5 /net-libs/libosmocore
parentUse configure features instead of sed. (diff)
downloadgentoo-2-1e634eb93ae4f88961b8315c982c23b7972baac8.tar.gz
gentoo-2-1e634eb93ae4f88961b8315c982c23b7972baac8.tar.bz2
gentoo-2-1e634eb93ae4f88961b8315c982c23b7972baac8.zip
version bump for bug 482236 and adding ~arm for me
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'net-libs/libosmocore')
-rw-r--r--net-libs/libosmocore/ChangeLog8
-rw-r--r--net-libs/libosmocore/libosmocore-0.6.2.ebuild4
-rw-r--r--net-libs/libosmocore/libosmocore-0.6.3.ebuild38
3 files changed, 47 insertions, 3 deletions
diff --git a/net-libs/libosmocore/ChangeLog b/net-libs/libosmocore/ChangeLog
index 5b6def3e8553..5c314a20dac0 100644
--- a/net-libs/libosmocore/ChangeLog
+++ b/net-libs/libosmocore/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libosmocore
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libosmocore/ChangeLog,v 1.8 2013/07/08 20:33:07 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libosmocore/ChangeLog,v 1.9 2013/08/26 19:50:06 zerochaos Exp $
+
+*libosmocore-0.6.3 (26 Aug 2013)
+
+ 26 Aug 2013; Rick Farina <zerochaos@gentoo.org> +libosmocore-0.6.3.ebuild,
+ libosmocore-0.6.2.ebuild:
+ version bump for bug 482236 and adding ~arm for me
*libosmocore-0.6.2 (08 Jul 2013)
diff --git a/net-libs/libosmocore/libosmocore-0.6.2.ebuild b/net-libs/libosmocore/libosmocore-0.6.2.ebuild
index 4329595955f6..35f531010131 100644
--- a/net-libs/libosmocore/libosmocore-0.6.2.ebuild
+++ b/net-libs/libosmocore/libosmocore-0.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libosmocore/libosmocore-0.6.2.ebuild,v 1.1 2013/07/08 20:33:07 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libosmocore/libosmocore-0.6.2.ebuild,v 1.2 2013/08/26 19:50:06 zerochaos Exp $
EAPI="4"
@@ -12,7 +12,7 @@ SRC_URI="http://cgit.osmocom.org/cgit/libosmocore/snapshot/${P}.tar.bz2"
LICENSE="GPL-2 LGPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~arm ~x86"
IUSE="embedded"
RDEPEND=""
diff --git a/net-libs/libosmocore/libosmocore-0.6.3.ebuild b/net-libs/libosmocore/libosmocore-0.6.3.ebuild
new file mode 100644
index 000000000000..1025a8b69d6f
--- /dev/null
+++ b/net-libs/libosmocore/libosmocore-0.6.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libosmocore/libosmocore-0.6.3.ebuild,v 1.1 2013/08/26 19:50:06 zerochaos Exp $
+
+EAPI="4"
+
+inherit autotools eutils
+
+DESCRIPTION="Utility functions for OsmocomBB, OpenBSC and related projects"
+HOMEPAGE="http://bb.osmocom.org/trac/wiki/libosmocore"
+SRC_URI="http://cgit.osmocom.org/cgit/libosmocore/snapshot/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="embedded"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-doc/doxygen"
+
+src_prepare() {
+ # set correct version in pkgconfig files
+ sed -i "s/UNKNOWN/${PV}/" git-version-gen || die
+
+ epatch "${FILESDIR}"/${PN}-0.6.0-automake-1.13.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable embedded)
+}
+
+src_install() {
+ default
+ # install to correct documentation directory
+ mv "${ED}"/usr/share/doc/${PN} "${ED}"/usr/share/doc/${PF} || die
+}