summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-12-23 23:24:14 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-12-23 23:24:14 +0000
commitf9f930016e6ab899d5e9d767232072a425a6a42f (patch)
treeb96bc1374625f5a77c23001ae4780f9914cc26fe /net-libs/libsoup/libsoup-2.24.3.ebuild
parentVersion bump. Binding addition, updates and fixes. (diff)
downloadgentoo-2-f9f930016e6ab899d5e9d767232072a425a6a42f.tar.gz
gentoo-2-f9f930016e6ab899d5e9d767232072a425a6a42f.tar.bz2
gentoo-2-f9f930016e6ab899d5e9d767232072a425a6a42f.zip
Restore latest stable on hppa.
(Portage version: 2.2_rc60/cvs/Linux i686, RepoMan options: --force)
Diffstat (limited to 'net-libs/libsoup/libsoup-2.24.3.ebuild')
-rw-r--r--net-libs/libsoup/libsoup-2.24.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-libs/libsoup/libsoup-2.24.3.ebuild b/net-libs/libsoup/libsoup-2.24.3.ebuild
new file mode 100644
index 000000000000..974001ec3408
--- /dev/null
+++ b/net-libs/libsoup/libsoup-2.24.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/libsoup-2.24.3.ebuild,v 1.12 2009/12/23 23:24:14 scarabeus Exp $
+
+inherit gnome2
+
+DESCRIPTION="An HTTP library implementation in C"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="2.4"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd"
+# Do NOT build with --disable-debug/--enable-debug=no - gnome2.eclass takes care of that
+IUSE="debug doc ssl"
+
+RDEPEND=">=dev-libs/glib-2.15.3
+ >=dev-libs/libxml2-2
+ ssl? ( >=net-libs/gnutls-1 )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_enable ssl) --disable-static"
+}