summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-19 01:23:34 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-19 01:23:34 +0000
commit9ca15048d26154a35dfe8459ebae018baba2e58c (patch)
tree716165a180623e47016a3615a7ec410075951911 /net-libs/libtorrent
parentVersion bump, use external GeoIP version now without patch; add instead a pat... (diff)
downloadgentoo-2-9ca15048d26154a35dfe8459ebae018baba2e58c.tar.gz
gentoo-2-9ca15048d26154a35dfe8459ebae018baba2e58c.tar.bz2
gentoo-2-9ca15048d26154a35dfe8459ebae018baba2e58c.zip
Replace -O2 with -O3 on x86 systems running GCC 4.1. Closes bug #151221.
(Portage version: 2.1.2_pre3-r3)
Diffstat (limited to 'net-libs/libtorrent')
-rw-r--r--net-libs/libtorrent/ChangeLog8
-rw-r--r--net-libs/libtorrent/files/digest-libtorrent-0.10.3-r13
-rw-r--r--net-libs/libtorrent/libtorrent-0.10.3-r1.ebuild45
3 files changed, 55 insertions, 1 deletions
diff --git a/net-libs/libtorrent/ChangeLog b/net-libs/libtorrent/ChangeLog
index 40a401f3eb80..10c241d748ae 100644
--- a/net-libs/libtorrent/ChangeLog
+++ b/net-libs/libtorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libtorrent
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.70 2006/10/05 15:02:45 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.71 2006/10/19 01:23:34 flameeyes Exp $
+
+*libtorrent-0.10.3-r1 (19 Oct 2006)
+
+ 19 Oct 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +libtorrent-0.10.3-r1.ebuild:
+ Replace -O2 with -O3 on x86 systems running GCC 4.1. Closes bug #151221.
*libtorrent-0.10.3 (05 Oct 2006)
diff --git a/net-libs/libtorrent/files/digest-libtorrent-0.10.3-r1 b/net-libs/libtorrent/files/digest-libtorrent-0.10.3-r1
new file mode 100644
index 000000000000..e1e2c5a6c663
--- /dev/null
+++ b/net-libs/libtorrent/files/digest-libtorrent-0.10.3-r1
@@ -0,0 +1,3 @@
+MD5 8697a637db74f42fa23acbee03fa1734 libtorrent-0.10.3.tar.gz 449091
+RMD160 daa0f367f24bf15886c14968045b2d771fb06483 libtorrent-0.10.3.tar.gz 449091
+SHA256 3f850d167d91895462b801069e562ddfc9c886299216b6fde9596795418d975a libtorrent-0.10.3.tar.gz 449091
diff --git a/net-libs/libtorrent/libtorrent-0.10.3-r1.ebuild b/net-libs/libtorrent/libtorrent-0.10.3-r1.ebuild
new file mode 100644
index 000000000000..8798ea4f8ce7
--- /dev/null
+++ b/net-libs/libtorrent/libtorrent-0.10.3-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.10.3-r1.ebuild,v 1.1 2006/10/19 01:23:34 flameeyes Exp $
+
+inherit eutils toolchain-funcs flag-o-matic libtool
+
+DESCRIPTION="LibTorrent is a BitTorrent library written in C++ for *nix."
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="debug"
+
+RDEPEND=">=dev-libs/libsigc++-2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.11"
+
+src_compile() {
+ replace-flags -Os -O2
+
+ if [[ $(tc-arch) = "x86" ]]; then
+ filter-flags -fomit-frame-pointer
+
+ # See bug #151221. It seems only to hit on GCC 4.1 and x86 architecture
+ # it could be safer to fallback to -O1, but with the high use of STL in
+ # rtorrent, that could make it too slow.
+ [[ $(gcc-major-version)$(gcc-minor-version) == "41" ]] && replace-flags -O2 -O3
+ fi
+
+ elibtoolize
+ econf \
+ $(use_enable debug) \
+ --disable-dependency-tracking \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}