summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-01-13 05:19:51 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-01-13 05:19:51 +0000
commitf25321c0b278342ea2a4e807148cf0164777ee1b (patch)
tree91f4e7596ba9120faf8751432a17ff22ff555d93 /net-libs/netwib/netwib-5.28.0.ebuild
parentfix quoting/tests (diff)
downloadgentoo-2-f25321c0b278342ea2a4e807148cf0164777ee1b.tar.gz
gentoo-2-f25321c0b278342ea2a4e807148cf0164777ee1b.tar.bz2
gentoo-2-f25321c0b278342ea2a4e807148cf0164777ee1b.zip
Version bump as per bug #75621
Diffstat (limited to 'net-libs/netwib/netwib-5.28.0.ebuild')
-rw-r--r--net-libs/netwib/netwib-5.28.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-libs/netwib/netwib-5.28.0.ebuild b/net-libs/netwib/netwib-5.28.0.ebuild
new file mode 100644
index 000000000000..0c63097b5592
--- /dev/null
+++ b/net-libs/netwib/netwib-5.28.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/netwib/netwib-5.28.0.ebuild,v 1.1 2005/01/13 05:19:51 dragonheart Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Library of Ethernet, IP, UDP, TCP, ICMP, ARP and RARP protocols"
+HOMEPAGE="http://www.laurentconstantin.com/en/netw/netwib/"
+SRC_URI="http://www.laurentconstantin.com/common/netw/netwib/download/v${PV/.*}/${P}-src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+IUSE=""
+
+DEPEND="net-libs/libpcap
+ >=net-libs/libnet-1.1.1"
+
+S=${WORKDIR}/${P}-src
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/src
+
+ sed -i \
+ -e 's:-ansi::' \
+ -e 's:/usr/local:/usr:g' \
+ -e "s:-O2:${CFLAGS}:" \
+ genemake config.dat
+ ./genemake || die "problem creating Makefile"
+}
+
+src_compile() {
+ cd src
+ emake CC=$(tc-getCC) || die "compile problem"
+}
+
+src_install() {
+ dodoc README.TXT doc/*.txt
+ cd src
+ emake install DESTDIR=${D} || die
+}