summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-09-04 15:21:14 +0000
committerPacho Ramos <pacho@gentoo.org>2014-09-04 15:21:14 +0000
commite8c1a4f4874dcc33329e90d1fbeb87688372c515 (patch)
tree4f3a8d8e17a3d981e42ec9ef94a57cc5127f9d68 /net-libs/rest
parentMigrate to EAPI 5. Add missing dependencies. Remove useless la files. Install... (diff)
downloadgentoo-2-e8c1a4f4874dcc33329e90d1fbeb87688372c515.tar.gz
gentoo-2-e8c1a4f4874dcc33329e90d1fbeb87688372c515.tar.bz2
gentoo-2-e8c1a4f4874dcc33329e90d1fbeb87688372c515.zip
Version bump, drop old
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-libs/rest')
-rw-r--r--net-libs/rest/ChangeLog8
-rw-r--r--net-libs/rest/rest-0.7.92.ebuild (renamed from net-libs/rest/rest-0.7.90.ebuild)31
2 files changed, 23 insertions, 16 deletions
diff --git a/net-libs/rest/ChangeLog b/net-libs/rest/ChangeLog
index 5415d08e0368..ddb54bea1b6d 100644
--- a/net-libs/rest/ChangeLog
+++ b/net-libs/rest/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/rest
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rest/ChangeLog,v 1.26 2014/08/07 18:25:58 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rest/ChangeLog,v 1.27 2014/09/04 15:21:14 pacho Exp $
+
+*rest-0.7.92 (04 Sep 2014)
+
+ 04 Sep 2014; Pacho Ramos <pacho@gentoo.org> +rest-0.7.92.ebuild,
+ -rest-0.7.90.ebuild:
+ Version bump, drop old
07 Aug 2014; Jeroen Roovers <jer@gentoo.org> rest-0.7.91.ebuild:
Stable for HPPA (bug #512012).
diff --git a/net-libs/rest/rest-0.7.90.ebuild b/net-libs/rest/rest-0.7.92.ebuild
index 2ea48bec20be..bc8bd01273bb 100644
--- a/net-libs/rest/rest-0.7.90.ebuild
+++ b/net-libs/rest/rest-0.7.92.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rest/rest-0.7.90.ebuild,v 1.10 2014/05/02 12:32:37 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rest/rest-0.7.92.ebuild,v 1.1 2014/09/04 15:21:14 pacho Exp $
EAPI="5"
GCONF_DEBUG="no"
@@ -9,38 +9,39 @@ GNOME2_LA_PUNT="yes"
inherit gnome2 virtualx
DESCRIPTION="Helper library for RESTful services"
-HOMEPAGE="http://live.gnome.org/Librest"
+HOMEPAGE="https://wiki.gnome.org/Projects/Librest"
LICENSE="LGPL-2.1"
SLOT="0.7"
IUSE="+gnome +introspection test"
-KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
# Coverage testing should not be enabled
-RDEPEND="app-misc/ca-certificates
+RDEPEND="
+ app-misc/ca-certificates
>=dev-libs/glib-2.24:2
dev-libs/libxml2:2
net-libs/libsoup:2.4
gnome? ( >=net-libs/libsoup-gnome-2.25.1:2.4 )
- introspection? ( >=dev-libs/gobject-introspection-0.6.7 )"
-
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7 )
+"
DEPEND="${RDEPEND}
>=dev-util/gtk-doc-am-1.13
>=dev-util/intltool-0.40
virtual/pkgconfig
- test? ( sys-apps/dbus )"
+ test? ( sys-apps/dbus )
+"
src_configure() {
- G2CONF="${G2CONF}
- --disable-static
- --disable-gcov
- --with-ca-certificates=${EPREFIX}/etc/ssl/certs/ca-certificates.crt
- $(use_with gnome)
- $(use_enable introspection)"
- gnome2_src_configure
+ gnome2_src_configure \
+ --disable-static \
+ --disable-gcov \
+ --with-ca-certificates="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt \
+ $(use_with gnome) \
+ $(use_enable introspection)
}
src_test() {
# Tests need dbus
- Xemake check || die
+ Xemake check
}