summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-05-25 21:54:38 +0000
committerPacho Ramos <pacho@gentoo.org>2015-05-25 21:54:38 +0000
commit2f7e5581777212d997ec00fcceee4fdfcbe30a41 (patch)
treef185d5b25893c060698b3abab9194ceaa3772944 /net-libs/webkit-gtk
parentVersion bump with quick fd leakage bugfix. (diff)
downloadgentoo-2-2f7e5581777212d997ec00fcceee4fdfcbe30a41.tar.gz
gentoo-2-2f7e5581777212d997ec00fcceee4fdfcbe30a41.tar.bz2
gentoo-2-2f7e5581777212d997ec00fcceee4fdfcbe30a41.zip
nvidia_check stuff can be dropped, tests look to run ok too
(Portage version: 2.2.19/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-libs/webkit-gtk')
-rw-r--r--net-libs/webkit-gtk/ChangeLog6
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.4.9-r200.ebuild42
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.4.9.ebuild42
3 files changed, 19 insertions, 71 deletions
diff --git a/net-libs/webkit-gtk/ChangeLog b/net-libs/webkit-gtk/ChangeLog
index cf2706f87cbb..903106c2ce84 100644
--- a/net-libs/webkit-gtk/ChangeLog
+++ b/net-libs/webkit-gtk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/webkit-gtk
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.318 2015/05/24 23:12:46 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.319 2015/05/25 21:54:38 pacho Exp $
+
+ 25 May 2015; Pacho Ramos <pacho@gentoo.org> webkit-gtk-2.4.9-r200.ebuild,
+ webkit-gtk-2.4.9.ebuild:
+ nvidia_check stuff can be dropped, tests look to run ok too
24 May 2015; Gilles Dartiguelongue <eva@gentoo.org> webkit-gtk-2.4.9.ebuild,
webkit-gtk-2.4.9-r200.ebuild, webkit-gtk-2.6.6.ebuild:
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.4.9-r200.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.4.9-r200.ebuild
index 91c689c6e696..9ccce8fb56e0 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.4.9-r200.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.4.9-r200.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-2.4.9-r200.ebuild,v 1.2 2015/05/24 23:12:46 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-2.4.9-r200.ebuild,v 1.3 2015/05/25 21:54:38 pacho Exp $
EAPI="5"
GCONF_DEBUG="no"
@@ -99,8 +99,6 @@ S="${WORKDIR}/${MY_P}"
CHECKREQS_DISK_BUILD="18G" # and even this might not be enough, bug #417307
pkg_pretend() {
- #nvidia_check || die #463960
-
if [[ ${MERGE_TYPE} != "binary" ]] && is-flagq "-g*" && ! is-flagq "-g*0" ; then
einfo "Checking for sufficient disk space to build ${PN} with debugging CFLAGS"
check-reqs_pkg_pretend
@@ -112,8 +110,6 @@ pkg_pretend() {
}
pkg_setup() {
- #nvidia_check || die #463960
-
# Check whether any of the debugging flags is enabled
if [[ ${MERGE_TYPE} != "binary" ]] && is-flagq "-g*" && ! is-flagq "-g*0" ; then
if is-flagq "-ggdb" && [[ ${WEBKIT_GTK_GGDB} != "yes" ]]; then
@@ -153,23 +149,16 @@ src_prepare() {
# * mimehandling test sometimes fails under Xvfb (works fine manually), bug #???
# * webdatasource test needs a network connection and intermittently fails with icedtea-web
# * webplugindatabase intermittently fails with icedtea-web, bug #????
- sed -e '/Programs\/TestWebKitAPI\/WebKitGtk\/testwebinspector/ d' \
- -e '/Programs\/TestWebKitAPI\/WebKitGtk\/testkeyevents/ d' \
- -e '/Programs\/TestWebKitAPI\/WebKitGtk\/testmimehandling/ d' \
- -e '/Programs\/TestWebKitAPI\/WebKitGtk\/testwebdatasource/ d' \
- -e '/Programs\/TestWebKitAPI\/WebKitGtk\/testwebplugindatabase/ d' \
- -i Tools/TestWebKitAPI/GNUmakefile.am || die
+# sed -e '/Programs\/TestWebKitAPI\/WebKitGtk\/testwebinspector/ d' \
+# -e '/Programs\/TestWebKitAPI\/WebKitGtk\/testkeyevents/ d' \
+# -e '/Programs\/TestWebKitAPI\/WebKitGtk\/testmimehandling/ d' \
+# -e '/Programs\/TestWebKitAPI\/WebKitGtk\/testwebdatasource/ d' \
+# -e '/Programs\/TestWebKitAPI\/WebKitGtk\/testwebplugindatabase/ d' \
+# -i Tools/TestWebKitAPI/GNUmakefile.am || die
# bug #459978, upstream bug #113397
epatch "${FILESDIR}"/${PN}-1.11.90-gtk-docize-fix.patch
- # Deadlock causing infinite compilations with nvidia-drivers:
- # https://bugs.gentoo.org/show_bug.cgi?id=463960
- # http://osdyson.org/issues/161
- # https://bugs.webkit.org/show_bug.cgi?id=125651
- # FIXME: it doesn't really work for us
- #epatch "${FILESDIR}"/${PN}-2.2.5-gir-nvidia-hangs.patch
-
# Debian patches to fix support for some arches
# https://bugs.webkit.org/show_bug.cgi?id=129540
epatch "${FILESDIR}"/${PN}-2.2.5-{hppa,ia64}-platform.patch
@@ -291,20 +280,3 @@ src_install() {
# bug #402699, https://bugs.webkit.org/show_bug.cgi?id=78134
rm -rf "${ED}usr/share/gtk-doc" || die
}
-
-#nvidia_check() {
-# if [[ ${MERGE_TYPE} != "binary" ]] &&
-# use introspection &&
-# has_version 'x11-drivers/nvidia-drivers' &&
-# [[ $(eselect opengl show 2> /dev/null) = "nvidia" ]]
-# then
-# eerror "${PN} freezes while compiling if x11-drivers/nvidia-drivers is"
-# eerror "used as the system OpenGL library. We are very sorry about that."
-# eerror "You should temporarily select Mesa as the system OpenGL library:"
-# eerror " # eselect opengl set xorg-x11"
-# eerror " and then run emerge again."
-# eerror "See https://bugs.gentoo.org/463960 for more details."
-# eerror
-# return 1
-# fi
-#}
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.4.9.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.4.9.ebuild
index d94854bdacd5..0707a97bc0d0 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.4.9.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.4.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-2.4.9.ebuild,v 1.2 2015/05/24 23:12:46 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-2.4.9.ebuild,v 1.3 2015/05/25 21:54:38 pacho Exp $
EAPI="5"
GCONF_DEBUG="no"
@@ -108,8 +108,6 @@ S="${WORKDIR}/${MY_P}"
CHECKREQS_DISK_BUILD="18G" # and even this might not be enough, bug #417307
pkg_pretend() {
- #nvidia_check || die #463960
-
if [[ ${MERGE_TYPE} != "binary" ]] && is-flagq "-g*" && ! is-flagq "-g*0" ; then
einfo "Checking for sufficient disk space to build ${PN} with debugging CFLAGS"
check-reqs_pkg_pretend
@@ -121,8 +119,6 @@ pkg_pretend() {
}
pkg_setup() {
- #nvidia_check || die #463960
-
# Check whether any of the debugging flags is enabled
if [[ ${MERGE_TYPE} != "binary" ]] && is-flagq "-g*" && ! is-flagq "-g*0" ; then
if is-flagq "-ggdb" && [[ ${WEBKIT_GTK_GGDB} != "yes" ]]; then
@@ -162,23 +158,16 @@ src_prepare() {
# * mimehandling test sometimes fails under Xvfb (works fine manually), bug #???
# * webdatasource test needs a network connection and intermittently fails with icedtea-web
# * webplugindatabase intermittently fails with icedtea-web, bug #????
- sed -e '/Programs\/TestWebKitAPI\/WebKitGtk\/testwebinspector/ d' \
- -e '/Programs\/TestWebKitAPI\/WebKitGtk\/testkeyevents/ d' \
- -e '/Programs\/TestWebKitAPI\/WebKitGtk\/testmimehandling/ d' \
- -e '/Programs\/TestWebKitAPI\/WebKitGtk\/testwebdatasource/ d' \
- -e '/Programs\/TestWebKitAPI\/WebKitGtk\/testwebplugindatabase/ d' \
- -i Tools/TestWebKitAPI/GNUmakefile.am || die
+# sed -e '/Programs\/TestWebKitAPI\/WebKitGtk\/testwebinspector/ d' \
+# -e '/Programs\/TestWebKitAPI\/WebKitGtk\/testkeyevents/ d' \
+# -e '/Programs\/TestWebKitAPI\/WebKitGtk\/testmimehandling/ d' \
+# -e '/Programs\/TestWebKitAPI\/WebKitGtk\/testwebdatasource/ d' \
+# -e '/Programs\/TestWebKitAPI\/WebKitGtk\/testwebplugindatabase/ d' \
+# -i Tools/TestWebKitAPI/GNUmakefile.am || die
# bug #459978, upstream bug #113397
epatch "${FILESDIR}"/${PN}-1.11.90-gtk-docize-fix.patch
- # Deadlock causing infinite compilations with nvidia-drivers:
- # https://bugs.gentoo.org/show_bug.cgi?id=463960
- # http://osdyson.org/issues/161
- # https://bugs.webkit.org/show_bug.cgi?id=125651
- # FIXME: it doesn't really work for us
- #epatch "${FILESDIR}"/${PN}-2.2.5-gir-nvidia-hangs.patch
-
# Debian patches to fix support for some arches
# https://bugs.webkit.org/show_bug.cgi?id=129540
epatch "${FILESDIR}"/${PN}-2.2.5-{hppa,ia64}-platform.patch
@@ -302,20 +291,3 @@ src_install() {
use jit && pax-mark m "${ED}usr/bin/jsc-3" "${ED}usr/libexec/WebKitWebProcess"
pax-mark m "${ED}usr/libexec/WebKitPluginProcess"
}
-
-#nvidia_check() {
-# if [[ ${MERGE_TYPE} != "binary" ]] &&
-# use introspection &&
-# has_version 'x11-drivers/nvidia-drivers' &&
-# [[ $(eselect opengl show 2> /dev/null) = "nvidia" ]]
-# then
-# eerror "${PN} freezes while compiling if x11-drivers/nvidia-drivers is"
-# eerror "used as the system OpenGL library. We are very sorry about that."
-# eerror "You should temporarily select Mesa as the system OpenGL library:"
-# eerror " # eselect opengl set xorg-x11"
-# eerror " and then run emerge again."
-# eerror "See https://bugs.gentoo.org/463960 for more details."
-# eerror
-# return 1
-# fi
-#}