summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2013-01-01 19:25:56 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2013-01-01 19:25:56 +0000
commit39af44c2f98f17c3829441f19ebdcd712e14cc9d (patch)
tree014c6e760342b6e1dc5eae09bd33a167deac9f3d /net-libs/webkit-gtk
parents390/sh stable wrt #446094 (diff)
downloadgentoo-2-39af44c2f98f17c3829441f19ebdcd712e14cc9d.tar.gz
gentoo-2-39af44c2f98f17c3829441f19ebdcd712e14cc9d.tar.bz2
gentoo-2-39af44c2f98f17c3829441f19ebdcd712e14cc9d.zip
Add webkit-gtk-1.10's build space check to 1.8.3.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'net-libs/webkit-gtk')
-rw-r--r--net-libs/webkit-gtk/ChangeLog6
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-1.8.3-r200.ebuild33
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-1.8.3-r300.ebuild33
3 files changed, 65 insertions, 7 deletions
diff --git a/net-libs/webkit-gtk/ChangeLog b/net-libs/webkit-gtk/ChangeLog
index 7228777910fc..70a070970ebe 100644
--- a/net-libs/webkit-gtk/ChangeLog
+++ b/net-libs/webkit-gtk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/webkit-gtk
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.189 2013/01/01 19:15:10 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.190 2013/01/01 19:25:56 tetromino Exp $
+
+ 01 Jan 2013; Alexandre Rostovtsev <tetromino@gentoo.org>
+ webkit-gtk-1.8.3-r200.ebuild, webkit-gtk-1.8.3-r300.ebuild:
+ Add webkit-gtk-1.10's build space check to 1.8.3.
01 Jan 2013; Alexandre Rostovtsev <tetromino@gentoo.org>
webkit-gtk-1.10.2-r300.ebuild:
diff --git a/net-libs/webkit-gtk/webkit-gtk-1.8.3-r200.ebuild b/net-libs/webkit-gtk/webkit-gtk-1.8.3-r200.ebuild
index 4104cb6cbffe..a8aa53d182bb 100644
--- a/net-libs/webkit-gtk/webkit-gtk-1.8.3-r200.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-1.8.3-r200.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-1.8.3-r200.ebuild,v 1.9 2012/12/08 21:35:36 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-1.8.3-r200.ebuild,v 1.10 2013/01/01 19:25:56 tetromino Exp $
EAPI="4"
# Don't define PYTHON_DEPEND: python only needed at build time
-inherit autotools eutils flag-o-matic gnome2-utils pax-utils python virtualx
+inherit autotools check-reqs eutils flag-o-matic gnome2-utils pax-utils python virtualx
MY_P="webkit-${PV}"
DESCRIPTION="Open source web browser engine"
@@ -65,7 +65,34 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
+CHECKREQS_DISK_BUILD="18G" # and even this might not be enough, bug #417307
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != "binary" ]] && is-flagq "-g*" ; then
+ einfo "Checking for sufficient disk space to build ${PN} with debugging CFLAGS"
+ check-reqs_pkg_pretend
+ fi
+}
+
pkg_setup() {
+ # Check whether any of the debugging flags is enabled
+ if [[ ${MERGE_TYPE} != "binary" ]] && is-flagq "-g*" ; then
+ if is-flagq "-ggdb" && [[ ${WEBKIT_GTK_GGDB} != "yes" ]]; then
+ replace-flags -ggdb -g
+ ewarn "Replacing \"-ggdb\" with \"-g\" in your CFLAGS."
+ ewarn "Building ${PN} with \"-ggdb\" produces binaries which are too"
+ ewarn "large for current binutils releases (bug #432784) and has very"
+ ewarn "high temporary build space and memory requirements."
+ ewarn "If you really want to build ${PN} with \"-ggdb\", add"
+ ewarn "WEBKIT_GTK_GGDB=yes"
+ ewarn "to your make.conf file."
+ fi
+ einfo "You need to have at least 18GB of temporary build space available"
+ einfo "to build ${PN} with debugging CFLAGS. Note that it might still"
+ einfo "not be enough, as the total space requirements depend on the flags"
+ einfo "(-ggdb vs -g1) and enabled features."
+ check-reqs_pkg_setup
+ fi
# Needed for CodeGeneratorInspector.py
python_set_active_version 2
python_pkg_setup
diff --git a/net-libs/webkit-gtk/webkit-gtk-1.8.3-r300.ebuild b/net-libs/webkit-gtk/webkit-gtk-1.8.3-r300.ebuild
index e883b20b8653..a40dea543a4b 100644
--- a/net-libs/webkit-gtk/webkit-gtk-1.8.3-r300.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-1.8.3-r300.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-1.8.3-r300.ebuild,v 1.9 2012/12/08 21:40:08 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-1.8.3-r300.ebuild,v 1.10 2013/01/01 19:25:56 tetromino Exp $
EAPI="4"
# Don't define PYTHON_DEPEND: python only needed at build time
-inherit autotools eutils flag-o-matic gnome2-utils pax-utils python virtualx
+inherit autotools check-reqs eutils flag-o-matic gnome2-utils pax-utils python virtualx
MY_P="webkit-${PV}"
DESCRIPTION="Open source web browser engine"
@@ -72,7 +72,34 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
+CHECKREQS_DISK_BUILD="18G" # and even this might not be enough, bug #417307
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != "binary" ]] && is-flagq "-g*" ; then
+ einfo "Checking for sufficient disk space to build ${PN} with debugging CFLAGS"
+ check-reqs_pkg_pretend
+ fi
+}
+
pkg_setup() {
+ # Check whether any of the debugging flags is enabled
+ if [[ ${MERGE_TYPE} != "binary" ]] && is-flagq "-g*" ; then
+ if is-flagq "-ggdb" && [[ ${WEBKIT_GTK_GGDB} != "yes" ]]; then
+ replace-flags -ggdb -g
+ ewarn "Replacing \"-ggdb\" with \"-g\" in your CFLAGS."
+ ewarn "Building ${PN} with \"-ggdb\" produces binaries which are too"
+ ewarn "large for current binutils releases (bug #432784) and has very"
+ ewarn "high temporary build space and memory requirements."
+ ewarn "If you really want to build ${PN} with \"-ggdb\", add"
+ ewarn "WEBKIT_GTK_GGDB=yes"
+ ewarn "to your make.conf file."
+ fi
+ einfo "You need to have at least 18GB of temporary build space available"
+ einfo "to build ${PN} with debugging CFLAGS. Note that it might still"
+ einfo "not be enough, as the total space requirements depend on the flags"
+ einfo "(-ggdb vs -g1) and enabled features."
+ check-reqs_pkg_setup
+ fi
# Needed for CodeGeneratorInspector.py
python_set_active_version 2
python_pkg_setup