summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2014-08-04 18:46:43 +0000
committerRaúl Porcel <armin76@gentoo.org>2014-08-04 18:46:43 +0000
commit05d994f9537cfac07db241a19a78f60f577d9921 (patch)
tree51e04f3bec83d8391278348b7a0d135efec9d959 /net-libs
parentAvoid default doc target as the ebuild uses precompiled documentation. #519004 (diff)
downloadgentoo-2-05d994f9537cfac07db241a19a78f60f577d9921.tar.gz
gentoo-2-05d994f9537cfac07db241a19a78f60f577d9921.tar.bz2
gentoo-2-05d994f9537cfac07db241a19a78f60f577d9921.zip
Add a patch that really makes ptlib respect C/CXXFLAGS, fixes build failure #464182, mark stable on sparc, bug #461842
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xF6AD3240)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/ptlib/ChangeLog7
-rw-r--r--net-libs/ptlib/files/ptlib-2.10.10-respect_cflags_cxxflags.patch14
-rw-r--r--net-libs/ptlib/ptlib-2.10.10.ebuild7
-rw-r--r--net-libs/ptlib/ptlib-2.10.11.ebuild7
4 files changed, 28 insertions, 7 deletions
diff --git a/net-libs/ptlib/ChangeLog b/net-libs/ptlib/ChangeLog
index 70697c23d7a3..528cce0ad5f8 100644
--- a/net-libs/ptlib/ChangeLog
+++ b/net-libs/ptlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/ptlib
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/ptlib/ChangeLog,v 1.54 2014/07/27 16:03:22 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ptlib/ChangeLog,v 1.55 2014/08/04 18:46:43 armin76 Exp $
+
+ 04 Aug 2014; Raúl Porcel <armin76@gentoo.org> ptlib-2.10.10.ebuild,
+ ptlib-2.10.11.ebuild, +files/ptlib-2.10.10-respect_cflags_cxxflags.patch:
+ Add a patch that really makes ptlib respect C/CXXFLAGS, fixes build failure
+ #464182, mark stable on sparc, bug #461842
27 Jul 2014; Rick Farina <zerochaos@gentoo.org> ptlib-2.10.10.ebuild,
ptlib-2.10.11.ebuild, ptlib-2.12.4.ebuild, ptlib-2.12.9.ebuild:
diff --git a/net-libs/ptlib/files/ptlib-2.10.10-respect_cflags_cxxflags.patch b/net-libs/ptlib/files/ptlib-2.10.10-respect_cflags_cxxflags.patch
new file mode 100644
index 000000000000..4442d333fcd1
--- /dev/null
+++ b/net-libs/ptlib/files/ptlib-2.10.10-respect_cflags_cxxflags.patch
@@ -0,0 +1,14 @@
+diff -ur ptlib-2.10.10.orig/make/ptbuildopts.mak.in ptlib-2.10.10/make/ptbuildopts.mak.in
+--- ptlib-2.10.10.orig/make/ptbuildopts.mak.in 2014-08-04 18:11:02.000000000 +0000
++++ ptlib-2.10.10/make/ptbuildopts.mak.in 2014-08-04 18:11:32.000000000 +0000
+@@ -15,8 +15,8 @@
+ OSTYPE = @OSTYPE@
+ OSRELEASE = @OSRELEASE@
+
+-STDCCFLAGS += @STDCCFLAGS@ @CPPFLAGS@
+-STDCXXFLAGS += @STDCXXFLAGS@ @CPPFLAGS@
++STDCCFLAGS += @STDCCFLAGS@ @CFLAGS@
++STDCXXFLAGS += @STDCXXFLAGS@ @CXXFLAGS@
+ OPTSTDCCFLAGS += @OPTSTDCCFLAGS@
+ LDFLAGS += @LDFLAGS@
+ ENDLDLIBS += @ENDLDLIBS@ \ No newline at end of file
diff --git a/net-libs/ptlib/ptlib-2.10.10.ebuild b/net-libs/ptlib/ptlib-2.10.10.ebuild
index d780969b9da0..bfe2ab48dd09 100644
--- a/net-libs/ptlib/ptlib-2.10.10.ebuild
+++ b/net-libs/ptlib/ptlib-2.10.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/ptlib/ptlib-2.10.10.ebuild,v 1.10 2014/07/27 16:03:22 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ptlib/ptlib-2.10.10.ebuild,v 1.11 2014/08/04 18:46:43 armin76 Exp $
EAPI="5"
@@ -13,7 +13,7 @@ SRC_URI="mirror://sourceforge/opalvoip/${P}.tar.bz2
LICENSE="MPL-1.0"
SLOT="0/${PV}"
-KEYWORDS="alpha ~arm amd64 ia64 ppc ppc64 ~sparc x86"
+KEYWORDS="alpha amd64 ~arm ia64 ppc ppc64 sparc x86"
# default enabled are features from 'minsize', the most used according to ptlib
IUSE="alsa +asn debug doc +dtmf examples ffmpeg ftp +http ipv6
jabber ldap lua mail odbc oss pch pulseaudio qos remote sasl sdl serial
@@ -60,6 +60,7 @@ src_prepare() {
epatch "${FILESDIR}/${PN}-2.10.9-svn_revision_override.patch"
epatch "${FILESDIR}/${PN}-2.10.9-pkgconfig_ldflags.patch"
epatch "${FILESDIR}/${PN}-2.10.9-respect_cxxflags.patch"
+ epatch "${FILESDIR}/${PN}-2.10.10-respect_cflags_cxxflags.patch"
if ! use telnet; then
epatch "${FILESDIR}/${PN}-2.10.9-disable-telnet-symbols.patch"
@@ -165,7 +166,7 @@ src_compile() {
use debug && makeopts="debug"
- emake ${makeopts} || die "emake failed"
+ emake ${makeopts} V=1 || die "emake failed"
}
src_install() {
diff --git a/net-libs/ptlib/ptlib-2.10.11.ebuild b/net-libs/ptlib/ptlib-2.10.11.ebuild
index b91ed1ee3caa..fb0fe945868b 100644
--- a/net-libs/ptlib/ptlib-2.10.11.ebuild
+++ b/net-libs/ptlib/ptlib-2.10.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/ptlib/ptlib-2.10.11.ebuild,v 1.3 2014/07/27 16:03:22 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ptlib/ptlib-2.10.11.ebuild,v 1.4 2014/08/04 18:46:43 armin76 Exp $
EAPI="5"
@@ -60,7 +60,8 @@ src_prepare() {
epatch "${FILESDIR}/${PN}-2.10.9-svn_revision_override.patch" \
"${FILESDIR}/${PN}-2.10.9-pkgconfig_ldflags.patch" \
"${FILESDIR}/${PN}-2.10.9-respect_cxxflags.patch" \
- "${FILESDIR}/${PN}-2.10.10-mga-bison-parameter.patch"
+ "${FILESDIR}/${PN}-2.10.10-mga-bison-parameter.patch" \
+ "${FILESDIR}/${PN}-2.10.10-respect_cflags_cxxflags.patch"
if ! use telnet; then
epatch "${FILESDIR}/${PN}-2.10.9-disable-telnet-symbols.patch"
@@ -166,7 +167,7 @@ src_compile() {
use debug && makeopts="debug"
- emake ${makeopts} || die "emake failed"
+ emake ${makeopts} V=1 || die "emake failed"
}
src_install() {