summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-09-08 23:03:43 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-09-08 23:03:43 +0000
commit1be1c683ef1b7e196d6e42da06c2422e9de0c58f (patch)
tree40e0a6a8c8df5db34e9499809f5ac1a09da4f380 /net-libs
parentDrastically improved autotools patch, now include more tests, less automagic.... (diff)
downloadgentoo-2-1be1c683ef1b7e196d6e42da06c2422e9de0c58f.tar.gz
gentoo-2-1be1c683ef1b7e196d6e42da06c2422e9de0c58f.tar.bz2
gentoo-2-1be1c683ef1b7e196d6e42da06c2422e9de0c58f.zip
Version bump. Remove old ebuilds
(Portage version: 2.2_rc77/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/rb_libtorrent/ChangeLog11
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.14.11.ebuild77
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.14.12.ebuild (renamed from net-libs/rb_libtorrent/rb_libtorrent-0.14.10.ebuild)2
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.15.3.ebuild (renamed from net-libs/rb_libtorrent/rb_libtorrent-0.15.2.ebuild)7
4 files changed, 12 insertions, 85 deletions
diff --git a/net-libs/rb_libtorrent/ChangeLog b/net-libs/rb_libtorrent/ChangeLog
index 53d5f358338c..1b68c99df52d 100644
--- a/net-libs/rb_libtorrent/ChangeLog
+++ b/net-libs/rb_libtorrent/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-libs/rb_libtorrent
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.90 2010/08/23 19:51:20 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.91 2010/09/08 23:03:43 hwoarang Exp $
+
+*rb_libtorrent-0.15.3 (08 Sep 2010)
+*rb_libtorrent-0.14.12 (08 Sep 2010)
+
+ 08 Sep 2010; Markos Chandras <hwoarang@gentoo.org>
+ -rb_libtorrent-0.14.10.ebuild, -rb_libtorrent-0.14.11.ebuild,
+ +rb_libtorrent-0.14.12.ebuild, -rb_libtorrent-0.15.2.ebuild,
+ +rb_libtorrent-0.15.3.ebuild:
+ Version bump. Remove old ebuilds
23 Aug 2010; Markus Meier <maekke@gentoo.org> rb_libtorrent-0.15.1.ebuild:
amd64/x86 stable, bug #333775
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.14.11.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.14.11.ebuild
deleted file mode 100644
index 07afc500becc..000000000000
--- a/net-libs/rb_libtorrent/rb_libtorrent-0.14.11.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.14.11.ebuild,v 1.1 2010/08/21 13:21:44 hwoarang Exp $
-
-EAPI="2"
-inherit autotools eutils flag-o-matic versionator
-
-MY_P=${P/rb_/}
-MY_P=${MY_P/torrent/torrent-rasterbar}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
-HOMEPAGE="http://www.rasterbar.com/products/libtorrent/"
-SRC_URI="http://libtorrent.googlecode.com/files/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
-IUSE="debug doc examples python test"
-RESTRICT="test"
-
-DEPEND="|| ( >=dev-libs/boost-1.35
- ( ~dev-libs/boost-1.34.1 dev-cpp/asio ) )
- python? ( >=dev-libs/boost-1.35.0-r5[python] dev-lang/python:2.6[threads] )
- =sys-devel/libtool-2.2*
- sys-libs/zlib
- examples? ( !net-p2p/mldonkey )" #292998
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.14.9-as-needed-fix.patch #276873
- epatch "${FILESDIR}"/${PN}-0.14.8-boost-detect.patch #295474
- rm ltmain.sh #298069
- eautoreconf
-}
-
-src_configure() {
- append-ldflags -pthread
-
- # use multi-threading versions of boost libs
- local BOOST_LIBS="--with-boost-system=boost_system-mt \
- --with-boost-asio=boost_system-mt \
- --with-boost-filesystem=boost_filesystem-mt \
- --with-boost-thread=boost_thread-mt \
- --with-boost-regex=boost_regex-mt \
- --with-boost-python=boost_python-mt \
- --with-boost-program_options=boost_program_options-mt"
-
- # detect boost version and location, bug 295474
- BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
- BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
- BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
- BOOST_INC="/usr/include/boost-${BOOST_VER}"
- BOOST_LIB="/usr/$(get_libdir)/boost-${BOOST_VER}"
-
- local LOGGING
- use debug && LOGGING="--with-logging=verbose"
-
- econf $(use_enable debug) \
- $(use_enable test tests) \
- $(use_enable examples) \
- $(use_enable python python-binding) \
- --with-zlib=system \
- --with-asio=system \
- ${LOGGING} \
- --with-boost=${BOOST_INC} \
- --with-boost-libdir=${BOOST_LIB} \
- ${BOOST_LIBS}
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die 'emake install failed'
- dodoc ChangeLog AUTHORS NEWS README || die 'dodoc failed'
- if use doc ; then
- dohtml docs/* || die "Could not install HTML documentation"
- fi
-}
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.14.10.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.14.12.ebuild
index f8c46a168b32..654c5d404c08 100644
--- a/net-libs/rb_libtorrent/rb_libtorrent-0.14.10.ebuild
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.14.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.14.10.ebuild,v 1.1 2010/04/10 15:29:18 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.14.12.ebuild,v 1.1 2010/09/08 23:03:43 hwoarang Exp $
EAPI="2"
inherit autotools eutils flag-o-matic versionator
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.15.2.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.15.3.ebuild
index f6593039564f..7e9615365b99 100644
--- a/net-libs/rb_libtorrent/rb_libtorrent-0.15.2.ebuild
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.15.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.15.2.ebuild,v 1.1 2010/08/21 13:21:44 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.15.3.ebuild,v 1.1 2010/09/08 23:03:43 hwoarang Exp $
EAPI="2"
WANT_AUTOMAKE="1.11.1"
@@ -28,11 +28,6 @@ DEPEND="|| ( >=dev-libs/boost-1.35
examples? ( !net-p2p/mldonkey )" #292998
RDEPEND="${DEPEND}"
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.15.1-ax_pthread_asneeded.patch
- eautoreconf
-}
-
src_configure() {
# use multi-threading versions of boost libs
local BOOST_LIBS="--with-boost-system=boost_system-mt \