summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-10-24 11:01:11 +0000
committerDonny Davies <woodchip@gentoo.org>2002-10-24 11:01:11 +0000
commit20b8f686947099dd98d51f03ae86b5cfb65b9360 (patch)
tree6f8a070795a36fd6dfb8b2badef8bca8acf07cdd /net-libs
parentget fixed pam into gcc3 profiles (diff)
downloadgentoo-2-20b8f686947099dd98d51f03ae86b5cfb65b9360.tar.gz
gentoo-2-20b8f686947099dd98d51f03ae86b5cfb65b9360.tar.bz2
gentoo-2-20b8f686947099dd98d51f03ae86b5cfb65b9360.zip
chase latest release
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/lcrzo/ChangeLog4
-rw-r--r--net-libs/lcrzo/files/digest-lcrzo-4.16.01
-rw-r--r--net-libs/lcrzo/lcrzo-4.16.0.ebuild52
3 files changed, 56 insertions, 1 deletions
diff --git a/net-libs/lcrzo/ChangeLog b/net-libs/lcrzo/ChangeLog
index 2cda020b16eb..2f75fcac78b6 100644
--- a/net-libs/lcrzo/ChangeLog
+++ b/net-libs/lcrzo/ChangeLog
@@ -1,6 +1,8 @@
# ChangeLog for net-libs/lcrzo
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-libs/lcrzo/ChangeLog,v 1.9 2002/06/06 19:18:27 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/lcrzo/ChangeLog,v 1.10 2002/10/24 11:00:48 woodchip Exp $
+
+*lcrzo-4.16.0 (24 Oct 2002)
*lcrzo-4.10 (6 Jun 2002)
diff --git a/net-libs/lcrzo/files/digest-lcrzo-4.16.0 b/net-libs/lcrzo/files/digest-lcrzo-4.16.0
new file mode 100644
index 000000000000..e1754fe48a26
--- /dev/null
+++ b/net-libs/lcrzo/files/digest-lcrzo-4.16.0
@@ -0,0 +1 @@
+MD5 3410a9676699f902172b6a4ad51d0f86 lcrzo-4.16.0-src.tgz 757847
diff --git a/net-libs/lcrzo/lcrzo-4.16.0.ebuild b/net-libs/lcrzo/lcrzo-4.16.0.ebuild
new file mode 100644
index 000000000000..df291d305ac4
--- /dev/null
+++ b/net-libs/lcrzo/lcrzo-4.16.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/lcrzo/lcrzo-4.16.0.ebuild,v 1.1 2002/10/24 11:00:48 woodchip Exp $
+
+S=${WORKDIR}/${P}-src
+DESCRIPTION="Library of Ethernet, IP, UDP, TCP, ICMP, ARP and RARP protocols"
+HOMEPAGE="http://www.laurentconstantin.com/en/lcrzo/"
+SRC_URI="http://www.laurentconstantin.com/common/${PN}/download/v4/${P}-src.tgz"
+
+DEPEND="virtual/glibc net-libs/libpcap"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 sparc sparc64"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}/src
+
+ # genemake checks that these directories exist...
+ mv genemake genemake.orig
+ sed -e "s:/usr/local/include:/usr/include:" \
+ -e "s:/usr/local/lib:/usr/lib:" \
+ -e "s:/usr/local/bin:/usr/bin:" \
+ -e "s:/usr/local/man/man1:/usr/share/man/man1:" \
+ -e "s:/usr/local/man/man3:/usr/share/man/man3:" \
+ genemake.orig > genemake
+
+ chmod 755 genemake
+ ./genemake || die "problem creating Makefile"
+
+ # plug in our CFLAGS and make it install into ${D}...
+ mv Makefile Makefile.orig
+ sed -e "s:^\(GCCOPT=\).*:\1${CFLAGS}:" \
+ -e "s:^\(GCCOPTL=\).*:\1${CFLAGS}:" \
+ -e "s:^\(GCCOPTP=\).*:\1${CFLAGS}:" \
+ -e "s:^\(INSTINCLUDE=\):\1${D}:" \
+ -e "s:^\(INSTLIB=\):\1${D}:" \
+ -e "s:^\(INSTBIN=\):\1${D}:" \
+ -e "s:^\(INSTMAN1=\):\1${D}:" \
+ -e "s:^\(INSTMAN3=\):\1${D}:" \
+ Makefile.orig > Makefile
+}
+
+src_compile() {
+ make -C src || die "compile problem"
+}
+
+src_install() {
+ dodir /usr/{bin,include,lib} /usr/share/man/{man1,man3}
+ make -C src install || die
+ dodoc doc/*.txt
+}