summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2007-04-04 19:59:17 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2007-04-04 19:59:17 +0000
commit3bd1568966a013bb17e2e85e3ebee9a4fdf8e707 (patch)
treeebce0ba026dbc38a26084e2b7761b16fa4edf126 /net-libs
parentadded ~alpha keyword (diff)
downloadgentoo-2-3bd1568966a013bb17e2e85e3ebee9a4fdf8e707.tar.gz
gentoo-2-3bd1568966a013bb17e2e85e3ebee9a4fdf8e707.tar.bz2
gentoo-2-3bd1568966a013bb17e2e85e3ebee9a4fdf8e707.zip
Version bump (thx to Flameeyes for reporting on irc)
(Portage version: 2.1.2.2)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libtorrent/ChangeLog8
-rw-r--r--net-libs/libtorrent/files/digest-libtorrent-0.11.43
-rw-r--r--net-libs/libtorrent/libtorrent-0.11.4.ebuild52
3 files changed, 62 insertions, 1 deletions
diff --git a/net-libs/libtorrent/ChangeLog b/net-libs/libtorrent/ChangeLog
index f3a925c0a0f9..7b8970c3c7ce 100644
--- a/net-libs/libtorrent/ChangeLog
+++ b/net-libs/libtorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libtorrent
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.94 2007/03/29 08:00:59 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.95 2007/04/04 19:59:17 drizzt Exp $
+
+*libtorrent-0.11.4 (04 Apr 2007)
+
+ 04 Apr 2007; Timothy Redaelli <drizzt@gentoo.org>
+ +libtorrent-0.11.4.ebuild:
+ Version bump (thx to Flameeyes for reporting on irc)
29 Mar 2007; Markus Rothe <corsair@gentoo.org> libtorrent-0.11.2.ebuild:
Stable on ppc64; bug #172469
diff --git a/net-libs/libtorrent/files/digest-libtorrent-0.11.4 b/net-libs/libtorrent/files/digest-libtorrent-0.11.4
new file mode 100644
index 000000000000..8724bb12c382
--- /dev/null
+++ b/net-libs/libtorrent/files/digest-libtorrent-0.11.4
@@ -0,0 +1,3 @@
+MD5 cdfe5a0d9ce5d8cd8985f3fa4bd82dfd libtorrent-0.11.4.tar.gz 513360
+RMD160 76fe310ee04205f432d1d55e8d4f131aef5a2d8e libtorrent-0.11.4.tar.gz 513360
+SHA256 779effbed38577f6dd408e35fae465d9352537a13bc2a68832d0e3e7ec9d076f libtorrent-0.11.4.tar.gz 513360
diff --git a/net-libs/libtorrent/libtorrent-0.11.4.ebuild b/net-libs/libtorrent/libtorrent-0.11.4.ebuild
new file mode 100644
index 000000000000..c6d18b960799
--- /dev/null
+++ b/net-libs/libtorrent/libtorrent-0.11.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.11.4.ebuild,v 1.1 2007/04/04 19:59:17 drizzt Exp $
+
+inherit eutils toolchain-funcs flag-o-matic libtool autotools
+
+DESCRIPTION="LibTorrent is a BitTorrent library written in C++ for *nix."
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="debug"
+
+RDEPEND=">=dev-libs/libsigc++-2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.11"
+
+#src_unpack() {
+# unpack ${A}
+# cd "${S}"
+
+# AT_M4DIR="scripts" eautoreconf
+#}
+
+src_compile() {
+ replace-flags -Os -O2
+
+ if [[ $(tc-arch) = "x86" ]]; then
+ filter-flags -fomit-frame-pointer -fforce-addr
+
+ # See bug #151221. It seems only to hit on GCC 4.1 and x86 architecture
+ # it could be safer to fallback to -O1, but with the high use of STL in
+ # rtorrent, that could make it too slow.
+ [[ $(gcc-major-version)$(gcc-minor-version) == "41" ]] && replace-flags -O2 -O3
+ fi
+
+ elibtoolize
+ econf \
+ $(use_enable debug) \
+ --disable-dependency-tracking \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}