summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-04-18 15:25:55 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-04-18 15:25:55 +0000
commit8577c6f92a63005ce2457d469a4d5dac7e9d087c (patch)
tree1284c2044c9d2a98dacac3e2404970f2445274b0 /net-libs
parentStable on alpha, bug #260484 (diff)
downloadgentoo-2-8577c6f92a63005ce2457d469a4d5dac7e9d087c.tar.gz
gentoo-2-8577c6f92a63005ce2457d469a4d5dac7e9d087c.tar.bz2
gentoo-2-8577c6f92a63005ce2457d469a4d5dac7e9d087c.zip
Bump to 1.1, EAPI2ified, modified ebuild by Tim Harder. Closes #265823
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libssh2/ChangeLog7
-rw-r--r--net-libs/libssh2/libssh2-1.1.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/net-libs/libssh2/ChangeLog b/net-libs/libssh2/ChangeLog
index 06cc93f8290b..a22c7f3db9dd 100644
--- a/net-libs/libssh2/ChangeLog
+++ b/net-libs/libssh2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libssh2
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh2/ChangeLog,v 1.18 2009/04/09 13:44:02 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh2/ChangeLog,v 1.19 2009/04/18 15:25:55 patrick Exp $
+
+*libssh2-1.1 (18 Apr 2009)
+
+ 18 Apr 2009; Patrick Lauer <patrick@gentoo.org> +libssh2-1.1.ebuild:
+ Bump to 1.1, EAPI2ified, modified ebuild by Tim Harder. Closes #265823
09 Apr 2009; Raúl Porcel <armin76@gentoo.org> libssh2-0.18.ebuild,
libssh2-1.0.ebuild:
diff --git a/net-libs/libssh2/libssh2-1.1.ebuild b/net-libs/libssh2/libssh2-1.1.ebuild
new file mode 100644
index 000000000000..cb402f986e6e
--- /dev/null
+++ b/net-libs/libssh2/libssh2-1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh2/libssh2-1.1.ebuild,v 1.1 2009/04/18 15:25:55 patrick Exp $
+
+EAPI="2"
+
+DESCRIPTION="Library implementing the SSH2 protocol"
+HOMEPAGE="http://www.libssh2.org/"
+SRC_URI="mirror://sourceforge/libssh2/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="libgcrypt zlib"
+
+DEPEND="!libgcrypt? ( dev-libs/openssl )
+ libgcrypt? ( dev-libs/libgcrypt )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myconf
+
+ if use libgcrypt ; then
+ myconf="--with-libgcrypt"
+ else
+ myconf="--with-openssl"
+ fi
+
+ econf \
+ $(use_with zlib libz) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README
+}