summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSantiago M. Mola <coldwind@gentoo.org>2008-12-28 21:35:27 +0000
committerSantiago M. Mola <coldwind@gentoo.org>2008-12-28 21:35:27 +0000
commit9267359108a0125d07a48fcce046a494b4ca35cb (patch)
tree9d66f3a1f13083b49a2cee97aac022fe98c749c6 /net-libs
parentRemoved dev-db/phppgadmin-4.2.1, added 4.2.2 in response to sec issue #250451. (diff)
downloadgentoo-2-9267359108a0125d07a48fcce046a494b4ca35cb.tar.gz
gentoo-2-9267359108a0125d07a48fcce046a494b4ca35cb.tar.bz2
gentoo-2-9267359108a0125d07a48fcce046a494b4ca35cb.zip
Version bump (bug #245731), thanks to Atman Sense <atman.sense@zise.de>. Closes bug #225931 too.
(Portage version: 2.2_rc19/cvs/Linux 2.6.27-gentoo-r2 x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/rb_libtorrent/ChangeLog10
-rw-r--r--net-libs/rb_libtorrent/files/rb_libtorrent-0.14.1-ax_python_path.patch21
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.14.1.ebuild62
3 files changed, 92 insertions, 1 deletions
diff --git a/net-libs/rb_libtorrent/ChangeLog b/net-libs/rb_libtorrent/ChangeLog
index a5db2289694f..82270cfb594f 100644
--- a/net-libs/rb_libtorrent/ChangeLog
+++ b/net-libs/rb_libtorrent/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-libs/rb_libtorrent
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.52 2008/08/09 16:59:27 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.53 2008/12/28 21:35:27 coldwind Exp $
+
+*rb_libtorrent-0.14.1 (28 Dec 2008)
+
+ 28 Dec 2008; Santiago M. Mola <coldwind@gentoo.org>
+ +files/rb_libtorrent-0.14.1-ax_python_path.patch,
+ +rb_libtorrent-0.14.1.ebuild:
+ Version bump (bug #245731), thanks to Atman Sense <atman.sense@zise.de>.
+ Closes bug #225931 too.
09 Aug 2008; Santiago M. Mola <coldwind@gentoo.org>
rb_libtorrent-0.13.ebuild:
diff --git a/net-libs/rb_libtorrent/files/rb_libtorrent-0.14.1-ax_python_path.patch b/net-libs/rb_libtorrent/files/rb_libtorrent-0.14.1-ax_python_path.patch
new file mode 100644
index 000000000000..0d1f48ef5310
--- /dev/null
+++ b/net-libs/rb_libtorrent/files/rb_libtorrent-0.14.1-ax_python_path.patch
@@ -0,0 +1,21 @@
+Source: Santiago M. Mola <coldwind@gentoo.org>
+Upstream: The 'locate' part is merged.
+Reason: Support Python 2.6 and stop using locate to find Python headers.
+--- libtorrent-rasterbar-0.14.1.orig/m4/ax_python.m4 2008-12-28 15:07:42.000000000 +0100
++++ libtorrent-rasterbar-0.14.1/m4/ax_python.m4 2008-12-28 18:48:54.000000000 +0100
+@@ -58,13 +58,13 @@
+ AC_DEFUN([AX_PYTHON],
+ [AC_MSG_CHECKING(for python build information)
+ AC_MSG_RESULT([])
+-for python in python2.5 python2.4 python2.3 python2.2 python2.1 python; do
++for python in python2.6 python2.5 python2.4 python2.3 python2.2 python2.1 python; do
+ AC_CHECK_PROGS(PYTHON_BIN, [$python])
+ ax_python_bin=$PYTHON_BIN
+ if test x$ax_python_bin != x; then
+ AC_CHECK_LIB($ax_python_bin, main, ax_python_lib=$ax_python_bin, ax_python_lib=no)
+ AC_CHECK_HEADER([$ax_python_bin/Python.h],
+- [[ax_python_header=`locate $ax_python_bin/Python.h | sed -e s,/Python.h,,`]],
++ [[ax_python_header=/usr/include/$ax_python_bin]],
+ ax_python_header=no)
+ if test $ax_python_lib != no; then
+ if test $ax_python_header != no; then
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.14.1.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.14.1.ebuild
new file mode 100644
index 000000000000..f21047f840cd
--- /dev/null
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.14.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.14.1.ebuild,v 1.1 2008/12/28 21:35:27 coldwind Exp $
+
+inherit eutils autotools
+
+MY_P=${P/rb_/}
+MY_P=${MY_P/torrent/torrent-rasterbar}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="BitTorrent library written in C++ for *nix."
+HOMEPAGE="http://www.rasterbar.com/products/libtorrent/"
+SRC_URI="mirror://sourceforge/libtorrent/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+
+IUSE="debug examples python test"
+
+DEPEND="
+ >=dev-libs/boost-1.34
+ || ( >=dev-libs/boost-1.35 dev-cpp/asio )
+ sys-libs/zlib
+ !net-libs/libtorrent"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-ax_python_path.patch
+ eautoreconf
+}
+
+src_compile() {
+ #use multi-threading versions of boost libs
+ local BOOST_LIBS="
+ --with-boost-system=boost_system-mt \
+ --with-boost-asio=boost_system-mt \
+ --with-boost-filesystem=boost_filesystem-mt \
+ --with-boost-thread=boost_thread-mt \
+ --with-boost-regex=boost_regex-mt \
+ --with-boost-python=boost_python-mt \
+ --with-boost-program_options=boost_program_options-mt"
+
+ #TODO: We might want to add 'use debug -> --with-logging=verbose
+ econf \
+ $(use_enable debug) \
+ $(use_enable test tests) \
+ $(use_enable examples) \
+ $(use_enable python python-binding) \
+ --with-zlib=system \
+ --with-asio=system \
+ ${BOOST_LIBS} \
+ LDFLAGS="${LDFLAGS} -pthread" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog AUTHORS NEWS README
+}