summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-07-21 12:01:39 +0000
committerPacho Ramos <pacho@gentoo.org>2012-07-21 12:01:39 +0000
commit975ecfee5912e500c90a820c53f529f1f7f8e741 (patch)
treee10c59d9258d9eeb6b0ab7e1038e0860b360b949 /net-libs
parentConvert documentation to eclass-manpages. (diff)
downloadgentoo-2-975ecfee5912e500c90a820c53f529f1f7f8e741.tar.gz
gentoo-2-975ecfee5912e500c90a820c53f529f1f7f8e741.tar.bz2
gentoo-2-975ecfee5912e500c90a820c53f529f1f7f8e741.zip
Version bump, drop old. Allow parallel installation again as upstream think it should be fixed and looks to work ok for me.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gtk-vnc/ChangeLog9
-rw-r--r--net-libs/gtk-vnc/gtk-vnc-0.5.1.ebuild (renamed from net-libs/gtk-vnc/gtk-vnc-0.4.4.ebuild)43
2 files changed, 30 insertions, 22 deletions
diff --git a/net-libs/gtk-vnc/ChangeLog b/net-libs/gtk-vnc/ChangeLog
index 65232fc50c92..865ed109946c 100644
--- a/net-libs/gtk-vnc/ChangeLog
+++ b/net-libs/gtk-vnc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/gtk-vnc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/ChangeLog,v 1.92 2012/07/15 18:14:28 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/ChangeLog,v 1.93 2012/07/21 12:01:39 pacho Exp $
+
+*gtk-vnc-0.5.1 (21 Jul 2012)
+
+ 21 Jul 2012; Pacho Ramos <pacho@gentoo.org> +gtk-vnc-0.5.1.ebuild,
+ -gtk-vnc-0.4.4.ebuild:
+ Version bump, drop old. Allow parallel installation again as upstream think it
+ should be fixed and looks to work ok for me.
15 Jul 2012; Raúl Porcel <armin76@gentoo.org> gtk-vnc-0.5.0-r1.ebuild:
alpha/ia64/sparc stable wrt #410611
diff --git a/net-libs/gtk-vnc/gtk-vnc-0.4.4.ebuild b/net-libs/gtk-vnc/gtk-vnc-0.5.1.ebuild
index 381dd2b41256..897e281e01b5 100644
--- a/net-libs/gtk-vnc/gtk-vnc-0.4.4.ebuild
+++ b/net-libs/gtk-vnc/gtk-vnc-0.5.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/gtk-vnc-0.4.4.ebuild,v 1.8 2012/05/05 02:54:31 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/gtk-vnc-0.5.1.ebuild,v 1.1 2012/07/21 12:01:39 pacho Exp $
-EAPI="3"
-GNOME_TARBALL_SUFFIX="xz"
+EAPI="4"
+PYTHON_DEPEND="python? 2"
inherit base eutils gnome.org python
@@ -12,13 +12,13 @@ HOMEPAGE="http://live.gnome.org/gtk-vnc"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="examples gtk3 +introspection python sasl vala"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="examples gtk3 +introspection pulseaudio python sasl vala"
# libview is used in examples/gvncviewer -- no need
+# glib-2.30.1 needed to avoid linking failure due to .la files (bug #399129)
# TODO: review nsplugin when it will be considered less experimental
-
-COMMON_DEPEND=">=dev-libs/glib-2.10:2
+COMMON_DEPEND=">=dev-libs/glib-2.30.1:2
>=dev-libs/libgcrypt-1.4.2
dev-libs/libgpg-error
>=net-libs/gnutls-1.4
@@ -27,6 +27,7 @@ COMMON_DEPEND=">=dev-libs/glib-2.10:2
x11-libs/libX11
gtk3? ( >=x11-libs/gtk+-2.91.3:3 )
introspection? ( >=dev-libs/gobject-introspection-0.9.4 )
+ pulseaudio? ( media-sound/pulseaudio )
python? ( >=dev-python/pygtk-2:2 )
sasl? ( dev-libs/cyrus-sasl )"
RDEPEND="${COMMON_DEPEND}"
@@ -36,15 +37,16 @@ DEPEND="${COMMON_DEPEND}
sys-devel/gettext
>=dev-util/intltool-0.40
vala? (
- dev-lang/vala:0.14[vapigen]
- >=dev-libs/gobject-introspection-0.9.4 )
-"
+ dev-lang/vala:0.16[vapigen]
+ >=dev-libs/gobject-introspection-0.9.4 )"
+# eautoreconf requires gnome-common
GTK2_BUILDDIR="${WORKDIR}/${P}_gtk2"
GTK3_BUILDDIR="${WORKDIR}/${P}_gtk3"
pkg_setup() {
python_set_active_version 2
+ python_pkg_setup
if use vala && ! use gtk3; then
ewarn "You must set USE=gtk3 to enable vala bindings support."
@@ -62,7 +64,7 @@ src_prepare() {
# they're generated files, not source files. Funny false dichotomy.
rm -vf "${S}"/src/{vncconnectionenums.[ch],vncdisplayenums.[ch]}
- # Fix incorrect codegendir check: h2def.py is in pygobject, not pygtk
+ # Fix incorrect codegendir check: h2def.py is in pygobject, not pygtk, upstream bug#????
sed -e 's/codegendir pygtk-2.0/codegendir pygobject-2.0/g' \
-i src/Makefile.* || die
}
@@ -72,6 +74,7 @@ src_configure() {
myconf="
$(use_with examples) \
$(use_enable introspection) \
+ $(use_with pulseaudio) \
$(use_with sasl) \
--with-coroutine=gthread \
--without-libview \
@@ -105,44 +108,42 @@ src_configure() {
src_compile() {
cd ${GTK2_BUILDDIR}
einfo "Running make in ${GTK2_BUILDDIR}"
- emake || die
+ emake
if use gtk3; then
cd ${GTK3_BUILDDIR}
einfo "Running make in ${GTK3_BUILDDIR}"
- emake || die
+ emake
fi
}
src_test() {
cd ${GTK2_BUILDDIR}
einfo "Running make check in ${GTK2_BUILDDIR}"
- emake check || die
+ emake check
if use gtk3; then
cd ${GTK3_BUILDDIR}
einfo "Running make check in ${GTK3_BUILDDIR}"
- emake check || die
+ emake check
fi
}
src_install() {
- dodoc AUTHORS ChangeLog NEWS README || die
+ dodoc AUTHORS ChangeLog NEWS README
cd ${GTK2_BUILDDIR}
einfo "Running make install in ${GTK2_BUILDDIR}"
- # bug #328273
- MAKEOPTS="${MAKEOPTS} -j1" base_src_install
+ base_src_install
if use gtk3; then
cd ${GTK3_BUILDDIR}
einfo "Running make install in ${GTK3_BUILDDIR}"
- # bug #328273
- MAKEOPTS="${MAKEOPTS} -j1" base_src_install
+ base_src_install
fi
python_clean_installation_image
# Remove .la files
- find "${ED}" -name '*.la' -exec rm -f '{}' + || die
+ find "${D}" -name '*.la' -exec rm -f '{}' + || die
}