summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2012-11-17 18:26:12 +0000
committerThomas Sachau <tommy@gentoo.org>2012-11-17 18:26:12 +0000
commitf7a5483a011140fc65717a8c4eacd16e7e0abe35 (patch)
treebbc9fbb368cbcfff5675a7b499159eac0957a8aa /net-libs
parentVersion bump. (diff)
downloadgentoo-2-f7a5483a011140fc65717a8c4eacd16e7e0abe35.tar.gz
gentoo-2-f7a5483a011140fc65717a8c4eacd16e7e0abe35.tar.bz2
gentoo-2-f7a5483a011140fc65717a8c4eacd16e7e0abe35.zip
Version bump
(Portage version: 2.2.0_alpha142-r1/cvs/Linux x86_64, signed Manifest commit with key 0x35899067)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/polarssl/ChangeLog8
-rw-r--r--net-libs/polarssl/files/polarssl-1.2.0-makefile.patch22
-rw-r--r--net-libs/polarssl/polarssl-1.1.3.ebuild4
-rw-r--r--net-libs/polarssl/polarssl-1.2.0.ebuild68
4 files changed, 99 insertions, 3 deletions
diff --git a/net-libs/polarssl/ChangeLog b/net-libs/polarssl/ChangeLog
index 3d78544cdfbe..62fc8f68018d 100644
--- a/net-libs/polarssl/ChangeLog
+++ b/net-libs/polarssl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/polarssl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/polarssl/ChangeLog,v 1.34 2012/08/28 18:05:16 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/polarssl/ChangeLog,v 1.35 2012/11/17 18:26:11 tommy Exp $
+
+*polarssl-1.2.0 (17 Nov 2012)
+
+ 17 Nov 2012; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ +polarssl-1.2.0.ebuild, +files/polarssl-1.2.0-makefile.patch:
+ Version bump
28 Aug 2012; Raúl Porcel <armin76@gentoo.org> polarssl-1.1.3.ebuild:
sparc stable wrt #421479
diff --git a/net-libs/polarssl/files/polarssl-1.2.0-makefile.patch b/net-libs/polarssl/files/polarssl-1.2.0-makefile.patch
new file mode 100644
index 000000000000..f82918355123
--- /dev/null
+++ b/net-libs/polarssl/files/polarssl-1.2.0-makefile.patch
@@ -0,0 +1,22 @@
+--- old/library/Makefile 2012-11-17 18:20:25.000000000 +0100
++++ ./library/Makefile 2012-11-17 18:20:40.000000000 +0100
+@@ -5,7 +5,7 @@
+ # environment
+ #
+ CFLAGS += -I../include -D_FILE_OFFSET_BITS=64 -Wall -W -Wdeclaration-after-statement
+-OFLAGS = -O2
++#OFLAGS = -O2
+
+ ifdef DEBUG
+ CFLAGS += -g3
+--- old/programs/Makefile 2012-11-17 18:20:25.000000000 +0100
++++ ./programs/Makefile 2012-11-17 18:21:25.000000000 +0100
+@@ -4,7 +4,7 @@
+ # To compile with PKCS11: add "-lpkcs11-helper" to LDFLAGS
+
+ CFLAGS += -I../include -D_FILE_OFFSET_BITS=64 -Wall -W -Wdeclaration-after-statement
+-OFLAGS = -O2
++#OFLAGS = -O2
+ LDFLAGS += -L../library -lpolarssl $(SYS_LDFLAGS)
+
+ ifdef DEBUG
diff --git a/net-libs/polarssl/polarssl-1.1.3.ebuild b/net-libs/polarssl/polarssl-1.1.3.ebuild
index 074f1f8ced26..9e11100b3faa 100644
--- a/net-libs/polarssl/polarssl-1.1.3.ebuild
+++ b/net-libs/polarssl/polarssl-1.1.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/polarssl/polarssl-1.1.3.ebuild,v 1.7 2012/08/28 18:05:16 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/polarssl/polarssl-1.1.3.ebuild,v 1.8 2012/11/17 18:26:11 tommy Exp $
EAPI=2
-inherit eutils toolchain-funcs
+inherit eutils multilib toolchain-funcs
DESCRIPTION="Cryptographic library for embedded systems"
HOMEPAGE="http://polarssl.org/"
diff --git a/net-libs/polarssl/polarssl-1.2.0.ebuild b/net-libs/polarssl/polarssl-1.2.0.ebuild
new file mode 100644
index 000000000000..9c32626c6ee0
--- /dev/null
+++ b/net-libs/polarssl/polarssl-1.2.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/polarssl/polarssl-1.2.0.ebuild,v 1.1 2012/11/17 18:26:12 tommy Exp $
+
+EAPI=2
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Cryptographic library for embedded systems"
+HOMEPAGE="http://polarssl.org/"
+#https://polarssl.org/download/polarssl-1.2.0-gpl.tgz
+SRC_URI="http://polarssl.org/download/${P}-gpl.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="examples sse2"
+
+src_prepare() {
+ sed -i '/.SILENT:/d' Makefile */Makefile
+ epatch "${FILESDIR}"/${PN}-1.2.0-makefile.patch
+ cd library
+ if use sse2 ; then
+ sed -i '15iCFLAGS += -DHAVE_SSE2 -fPIC' Makefile
+ else
+ sed -i '15iCFLAGS += -fPIC' Makefile
+ fi
+}
+
+src_compile() {
+ tc-export CC
+ emake -C library libpolarssl.so || die "emake failed"
+
+ if use examples ; then
+ emake -C programs all || die "emake failed"
+ fi
+ ln -s libpolarssl.so library/libpolarssl.so.0
+}
+
+src_test() {
+ cd programs
+ emake test/selftest || die "emake selftest failed"
+ LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:../library" ./test/selftest || die "selftest failed"
+ cd "${S}"
+ LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:../library" emake check || die
+}
+
+src_install() {
+ insinto /usr/include/polarssl
+ doins include/polarssl/*.h || die
+ dolib.so library/libpolarssl.so || die
+ ln -s libpolarssl.so "${D}"usr/$(get_libdir)/libpolarssl.so.0
+ dolib.a library/libpolarssl.a || die
+
+ if use examples ; then
+ for p in programs/*/* ; do
+ if [[ -x "${p}" && ! -d "${p}" ]] ; then
+ f=polarssl_`basename "${p}"`
+ newbin "${p}" "${f}" || die
+ fi
+ done
+ for e in aes hash pkey ssl test ; do
+ docinto "${e}"
+ dodoc programs/"${e}"/*.c || die
+ dodoc programs/"${e}"/*.txt || die
+ done
+ fi
+}