summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-04-22 20:51:23 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-04-22 20:51:23 +0000
commit462f3bff99ac609105aaada906c2c697a1ecf0e5 (patch)
tree541f8be0658fe29752d9038812d5a631437217a6 /net-mail/grepmail
parent- Initial version of the ebuild. (diff)
downloadgentoo-2-462f3bff99ac609105aaada906c2c697a1ecf0e5.tar.gz
gentoo-2-462f3bff99ac609105aaada906c2c697a1ecf0e5.tar.bz2
gentoo-2-462f3bff99ac609105aaada906c2c697a1ecf0e5.zip
- Initial version of the ebuild.
- grepmail is an awesome Perl script that searches mailboxes using a grep-like regex and/or time/date constraints, and pipes out a mailbox, containing the matching messages.
Diffstat (limited to 'net-mail/grepmail')
-rw-r--r--net-mail/grepmail/ChangeLog9
-rw-r--r--net-mail/grepmail/files/digest-grepmail-4.701
-rw-r--r--net-mail/grepmail/grepmail-4.70.ebuild28
3 files changed, 38 insertions, 0 deletions
diff --git a/net-mail/grepmail/ChangeLog b/net-mail/grepmail/ChangeLog
new file mode 100644
index 000000000000..c2610a9cb60b
--- /dev/null
+++ b/net-mail/grepmail/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-perl/DateManip
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-mail/grepmail/ChangeLog,v 1.1 2002/04/22 20:51:23 agenkin Exp $
+
+*grepmail-4.70 (22 April 2002)
+
+ 22 Apr 2002; Arcady Genkin <agenkin@thpoon.com>: grepmail-4.70.ebuild
+
+ Initial version of the package. \ No newline at end of file
diff --git a/net-mail/grepmail/files/digest-grepmail-4.70 b/net-mail/grepmail/files/digest-grepmail-4.70
new file mode 100644
index 000000000000..72dd2dc1c75b
--- /dev/null
+++ b/net-mail/grepmail/files/digest-grepmail-4.70
@@ -0,0 +1 @@
+MD5 5ebb0809df1bf4eb8f6251d23e286965 grepmail-4.70.tar.gz 405805
diff --git a/net-mail/grepmail/grepmail-4.70.ebuild b/net-mail/grepmail/grepmail-4.70.ebuild
new file mode 100644
index 000000000000..63a7f48fb030
--- /dev/null
+++ b/net-mail/grepmail/grepmail-4.70.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2002 Arcady Genkin <agenkin@thpoon.com>
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Arcady Genkin <agenkin@thpoon.com>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/grepmail/grepmail-4.70.ebuild,v 1.1 2002/04/22 20:51:23 agenkin Exp $
+
+DESCRIPTION="Search normal or compressed mailbox using a regular expression or dates."
+HOMEPAGE="http://grepmail.sourceforge.net/"
+
+SRC_URI="http://prdownloads.sourceforge.net/grepmail/${P}.tar.gz"
+S=${WORKDIR}/${P}
+
+DEPEND="dev-perl/TimeDate
+ dev-perl/DateManip"
+
+src_compile () {
+ perl Makefile.PL FASTREADER=0 PREFIX=/usr
+ emake || die
+}
+
+src_install () {
+ # BUG: Can't quite work out the compilation of the FastReader module.
+ # For now it's disabled.
+ make PREFIX=${D}/usr \
+ INSTALLMAN1DIR=${D}/usr/share/man/man1 \
+ INSTALLMAN3DIR=${D}/usr/share/man/man3 \
+ install || die
+ dodoc MANIFEST LICENSE CHANGES README
+}